This document is for information and instruction purposes. Mentor Graphics reserves the right to make changes in specifications and other information contained in this publication without prior notice, and the reader should, in all cases, consult Mentor Graphics to determine whether any changes have been made.

The terms and conditions governing the sale and licensing of Mentor Graphics products are set forth in written agreements between Mentor Graphics and its customers. No representation or other affirmation of fact contained in this publication shall be deemed to be a warranty or give rise to any liability of Mentor Graphics whatsoever.

MENTOR GRAPHICS MAKES NO WARRANTY OF ANY KIND WITH REGARD TO THIS MATERIAL INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE.

MENTOR GRAPHICS SHALL NOT BE LIABLE FOR ANY INCIDENTAL, INDIRECT, SPECIAL, OR CONSEQUENTIAL DAMAGES WHATSOEVER (INCLUDING BUT NOT LIMITED TO LOST PROFITS) ARISING OUT OF OR RELATED TO THIS PUBLICATION OR THE INFORMATION CONTAINED IN IT, EVEN IF MENTOR GRAPHICS CORPORATION HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

RESTRICTED RIGHTS LEGEND 03/97

U.S. Government Restricted Rights. The SOFTWARE and documentation have been developed entirely at private expense and are commercial computer software provided with restricted rights. Use, duplication or disclosure by the U.S. Government or a U.S. Government subcontractor is subject to the restrictions set forth in the license agreement provided with the software pursuant to DFARS 227.7202-3(a) or as set forth in subparagraph (c)(1) and (2) of the Commercial Computer Software - Restricted Rights clause at FAR 52.227-19, as applicable.

Contractor/manufacturer is:
Mentor Graphics Corporation
8005 S.W. Boeckman Road, Wilsonville, Oregon 97070-7777.
Telephone: 503.685.7000
Toll-Free Telephone: 800.592.2210
Website: www.mentor.com
SupportNet: www.mentor.com/supportnet
Send Feedback on Documentation: www.mentor.com/supportnet/documentation/reply_form.cfm

TRADEMARKS: The trademarks, logos and service marks ("Marks") used herein are the property of Mentor Graphics Corporation or other third parties. No one is permitted to use these Marks without the prior written consent of Mentor Graphics or the respective third-party owner. The use herein of a third-party Mark is not an attempt to indicate Mentor Graphics as a source of a product, but is intended to indicate a product from, or associated with, a particular third party. A current list of Mentor Graphics' trademarks may be viewed at: www.mentor.com/terms_conditions/trademarks.cfm.
## Revision History

<table>
<thead>
<tr>
<th>Revision</th>
<th>Changes</th>
<th>Date</th>
</tr>
</thead>
<tbody>
<tr>
<td>EE2007.3</td>
<td>Updated content to reflect changes to DxDesigner</td>
<td>Sep 2008</td>
</tr>
<tr>
<td>Rev 0</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
# Table of Contents

## Chapter 1

**Introduction to DxDesigner** ................................. 13
- Working Concurrently within EE2007 .......................... 13
- The DxDesigner Workflows .................................. 14
  - The Expedition Workflow .................................. 15
  - The Netlist Workflow ..................................... 16
- Finding Information within DxDesigner ....................... 16
- Switching Between Releases or Flows ......................... 17
- Understanding the DxDesigner User Interface ................. 17
  - Changing Between Floating and Docked Window Types ..... 17
- Starting and Exiting from DxDesigner ....................... 21
  - Starting DxDesigner in Windows .......................... 21
  - Starting DxDesigner in UNIX or LINUX .................. 21
  - Starting DxDesigner From a Command Window .............. 21
- Creating a New Project ..................................... 22
- Adding Libraries to a Project (Netlist workflow only) .... 23
- Copying or Deleting a Project .............................. 24
- Using the Navigator ........................................ 25
  - Designs vs. Blocks Nodes ................................. 25
  - Navigator Contents ....................................... 25
  - Manipulating Objects from the Navigator ................. 27
  - Managing Schematic Sheets from the Navigator ........... 29
- Working With Sheets ........................................ 30
  - Traversing from Sheet to Sheet ........................... 30
  - Viewing Pins and Nets and Their Associated Components .. 31
- Basic Editing of Selected Schematic Objects ............... 32
  - Reflecting a Selected Object .............................. 32
  - Rotating a Selected Object ............................... 33
  - Scaling a Selected Object .................................. 33
  - Changing Size of Selected Text, Properties, or Names ... 33
  - Stretching a Selected Object .............................. 33
  - Cutting or Copying a Selected Object ..................... 34
  - Pasting Objects From the Clipboard ....................... 34
  - Adding an Array for Selected Objects .................... 35
  - Zooming on a Selected Area or Object ................... 35
  - Changing the Name of a Selected String ................. 36
- Executing DxDesigner Command Line Commands ............... 37

## Chapter 2

**Defining Project Settings** ................................. 39
- Customizing the Dashboard ................................. 39
- Setting Dashboard Preferences to Fit Your Style ........... 39
Table of Contents

Creating, Adding, and Deleting Items in a Toolbox .......................... 40
Accessing Frequently-Used Documents ........................................ 40
Configuring the Shortcut Bar ....................................................... 41
Customizing DxDesigner From the User Interface ......................... 42
Customizing the Tools Menu ....................................................... 43
Customizing your DxDesigner Workspace ................................. 46
Displaying and Customizing Pintype Arrows ............................. 46
Changing the Appearance of the Cursor .................................... 46
Changing Object Colors ............................................................. 46
Framing a Design with Borders ................................................. 47
Creating a Sheet Border Symbol .............................................. 48
Specifying Border Configuration File Location ......................... 50
Creating a Border Configuration ............................................. 51
Controlling Sheet Borders on a Schematic ............................... 53
Changing Border Properties ..................................................... 54
Configuring Special Components ............................................. 55
To Configure Special Components ..................................... 56
Setting Up Constraints in CES .................................................. 57

Chapter 3
Creating and Editing Symbols .................................................. 59
Creating a Local Symbol ......................................................... 59

Chapter 4
Creating and Editing Flat Designs ............................................ 61
Returning Schematic to a Prior State ........................................ 62
Creating a New Schematic ....................................................... 62
Opening a Non-DxDesigner Schematic .................................... 63
Preparing a Schematic for Design Creation ............................... 63
Editing Schematic Borders ....................................................... 63
Creating Designs Within a Spreadsheet .................................. 64
Creating and Editing an Interconnectivity Table ......................... 64
Adding Nets to Pins ................................................................. 67
Grouping and Ungrouping Rows and Columns ......................... 69
Adding Ports to the ICT ............................................................ 71
Adding a Block ........................................................................... 72
Creating and Removing Differential Pairs ................................. 73
Creating and Ripping a Bus in an ICT .................................... 73
Splitting an Interconnectivity Table ....................................... 74
Setting Color Preferences ......................................................... 74
Using the Interconnectivity Table Viewer ................................. 75
Creating Designs Graphically ..................................................... 75
Adding Components ................................................................. 76
Adding and Replacing Power/Ground Pins ............................... 77
Synchronizing a Component With its Associated Base Symbol .... 78
Specifying the Characteristics of Components ......................... 79
Adding and Editing Properties .................................................. 79
Handling Mechanical Parts ....................................................... 83
# Table of Contents

- Handling Test Points ................................................................. 84
- Using Constraints in DxDesigner .................................................. 85
- Connecting/Disconnecting Components .......................................... 85
- Routing Modes .................................................................................. 86
- Creating Intersecting Connections .................................................... 87
- Creating Dangling Connections ........................................................ 87
- Automatically Creating Connection by Net Label Names ....................... 87
- Disconnecting a Component ............................................................. 87
- Adding and Editing Ports on a Schematic .......................................... 88
- Propagating Ports ............................................................................... 88
- Adding Missing Ports ........................................................................ 88
- Replacing Ports .................................................................................. 89
- Creating and Editing Nets ................................................................. 89
- Creating and Editing Nets Using the Schematic Editor ......................... 89
- Aliasing Nets ..................................................................................... 91
- Merging Nets ....................................................................................... 92
- Establishing Connectivity in Multi-Sheet Designs ................................ 93
- Creating Differential Pairs Automatically ......................................... 94
- Inserting a Serial Component on a Net .............................................. 95
- Connecting Components With Busses ................................................. 96
  - Adding a Bus .................................................................................... 96
  - Ripping Nets .................................................................................... 97
- Working Within the Schematic Editor ................................................ 101
  - Adding or Deleting a Schematic Sheet .............................................. 101
  - Copying a Schematic Sheet .............................................................. 102
  - Adding Text to Schematics ............................................................... 102
  - Adding Graphics to Schematics ......................................................... 103
  - Selecting and Deselecting Objects .................................................. 104
  - Filtering Which Objects to Select ..................................................... 108
- Moving and Copying Objects ............................................................ 109
- Replacing a Symbol or Part ............................................................... 110
- Finding and Replacing Text ............................................................... 111
- Viewing Names and Properties ......................................................... 111
- Executing Commands Using Strokes ............................................... 111
- Verifying Your Design ..................................................................... 114
- Processing Your Completed Design .................................................. 114

## Chapter 5
### Creating and Editing Hierarchical Designs .................................... 115
- Hierarchical Designs and Design Reuse ............................................. 115
- Selecting a Design Methodology ...................................................... 115
- Creating Bottom-Up Hierarchical Designs ........................................ 115
  - Generating a Block from a Schematic ............................................. 116
  - Editing a Generated Block ............................................................. 117
- Moving Generated Blocks into the Central Library .............................. 118
- Placing a Symbol in an Open Schematic .......................................... 118
- Adding Ports to the Schematic .......................................................... 119
- Creating Top-Down Hierarchical Designs With Blocks ....................... 120
Table of Contents

Placing Blocks on the Top-Level Schematic ........................................ 120

Chapter 6  
Exchanging Data with Other Tools ...................................................... 123  
  Exchanging Data Within Expedition Workflow ..................................... 125  
  Working with Foreign Databases ....................................................... 126  
  Exchanging Data Within Netlist Workflow ......................................... 130  
  Exporting a Quick Connection View ................................................. 130  
  Configuring the Quick Connection View Output ................................... 131  
  Interpreting the Netlist Output ....................................................... 133  
  Using LineSimLink to Interface with HyperLynx ................................ 134  
  Exporting to HyperLynx with LineSimLink ....................................... 134  
  Importing from HyperLynx with LineSimLink .................................... 135  
  Packaging A Design ............................................................................ 137

Chapter 7  
Verifying the Schematic with the Design Rule Checker .......................... 139  
  Configuring the DRC ........................................................................... 139

Chapter 8  
Archiving Projects ................................................................................ 141

Chapter 8  
Printing, Plotting and Generating PDF .................................................. 143  
  Printing in Windows ............................................................................ 143  
  Setup for Windows .............................................................................. 143  
  Printing the Current Sheet ................................................................. 144  
  Paper Tray Selection in UNIX ............................................................. 144  
  Printing in UNIX ................................................................................ 145  
  Setup for UNIX .................................................................................. 145  
  Print the Current Sheet ...................................................................... 146  
  Plotting in Windows ............................................................................ 146  
  Configure a Basic Plot ....................................................................... 146  
  Export the Design to Metafile Format ................................................. 147  
  Spool the Plot .................................................................................... 148  
  Plotting in UNIX ................................................................................ 148  
  Plotting Setup in UNIX ...................................................................... 148  
  Plotting in UNIX Using Default Settings .......................................... 149  
  Plotting in UNIX Using Custom Settings ......................................... 150  
  Generating a PDF of Your Design ......................................................... 155

Chapter 9  
Generating Bills of Materials ................................................................. 157  
  General Part Lister Information and Operation .................................... 157  
  Why Use Part Lister? .......................................................................... 157  
  Using Part Lister from the DxDesigner Window ................................... 158  
  Using Part Lister from the Command Line ......................................... 158
# Table of Contents

Output File Format. ............................................................... 159

Appendix A
Troubleshooting Your Environment. ........................................ 161
  Troubleshooting DxDesigner Environment Variables. .................. 161
  Troubleshooting Your License ............................................. 163
    Running Licensing Utilities From the Command Line ................ 164
  Finding Files in your PATH or WDIR ................................... 164

Appendix B
Using VHDL and Verilog in DxDesigner ................................. 165
  Preparing Schematic Designs for Export to ModelSim. ............... 165
    Creating Schematics that Export Correctly to VHDL ............... 166
    Creating a ModelSim Project ......................................... 167
  Exporting the DxDesigner Schematic to VHDL ....................... 168
  Importing a Netlist into ModelSim ................................. 168
  Importing Data from ModelSim into DxDesigner ..................... 168
  Using VHDL or Verilog Symbols in a Schematic .................... 170
    Creating a VHDL Symbol ............................................. 170
    Simulate the Entire Design - VHDL ............................... 170
    Creating a Verilog Symbol .......................................... 170
    Simulate the Entire Design - Verilog ............................ 171
  Inserting VHDL and SPICE Files onto a Schematic ................. 171
    Insert a File over an Existing Symbol ............................ 171

Appendix C
Linking and Embedding Objects. ......................................... 173
  Inserting Objects ..................................................... 173
  Embedding an Object .................................................. 173
    Converting an Embedded Object to a Different File Format .... 174
  Linking Objects ....................................................... 174

Index

Third-Party Information

End-User License Agreement
List of Tables

<table>
<thead>
<tr>
<th>Table</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Table 2-1</td>
<td>DxDesigner Arguments Listing</td>
<td>45</td>
</tr>
<tr>
<td>Table 2-2</td>
<td>Special Component Definitions</td>
<td>55</td>
</tr>
<tr>
<td>Table 2-3</td>
<td>Special Component Toolbar Icons</td>
<td>57</td>
</tr>
<tr>
<td>Table 3-1</td>
<td>Local Symbol Types</td>
<td>59</td>
</tr>
<tr>
<td>Table 4-1</td>
<td>Property Editing Rules</td>
<td>80</td>
</tr>
<tr>
<td>Table 4-2</td>
<td>Ripped net nomenclature</td>
<td>97</td>
</tr>
<tr>
<td>Table 4-3</td>
<td>Numerical Sequences Defining Strokes</td>
<td>112</td>
</tr>
<tr>
<td>Table 4-2</td>
<td>Ripped net nomenclature</td>
<td>97</td>
</tr>
<tr>
<td>Table A-1</td>
<td>Environment Variable Diagnostics</td>
<td>162</td>
</tr>
<tr>
<td>Table A-2</td>
<td>Diagnostics Dialog Box - Licensing Tab Items</td>
<td>163</td>
</tr>
<tr>
<td>Table A-3</td>
<td>License Utilities from PC or UNIX Command Line</td>
<td>164</td>
</tr>
<tr>
<td>Table B-1</td>
<td>Naming Guidelines for VHDL Data Transfer</td>
<td>167</td>
</tr>
<tr>
<td>Table B-2</td>
<td>ModelSim load Command Options</td>
<td>169</td>
</tr>
<tr>
<td>Figure</td>
<td>Description</td>
<td>Page</td>
</tr>
<tr>
<td>--------</td>
<td>------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>1-1</td>
<td>DxDesigner Indicator Light</td>
<td>14</td>
</tr>
<tr>
<td>1-2</td>
<td>DxDesigner Interface With Various Utility Windows Displayed</td>
<td>19</td>
</tr>
<tr>
<td>1-3</td>
<td>DxDesigner Interface with Different Add-ins than Figure 1-1</td>
<td>20</td>
</tr>
<tr>
<td>1-4</td>
<td>DxDesigner Project Navigator Example</td>
<td>26</td>
</tr>
<tr>
<td>1-5</td>
<td>Project Navigator - Example of Cross-Probe Viewing</td>
<td>27</td>
</tr>
<tr>
<td>1-6</td>
<td>Traversing Sheets of a Flat Design</td>
<td>30</td>
</tr>
<tr>
<td>1-7</td>
<td>Traversing Sheets of a Hierarchical Design</td>
<td>31</td>
</tr>
<tr>
<td>2-1</td>
<td>Using Library Manager to Copy/Paste a New Border Symbol</td>
<td>49</td>
</tr>
<tr>
<td>2-2</td>
<td>Specifying Which borders.ini File to Use for Border Configurations</td>
<td>51</td>
</tr>
<tr>
<td>2-3</td>
<td>Setting Border Configuration for a Project</td>
<td>53</td>
</tr>
<tr>
<td>2-4</td>
<td>Changing Border Properties</td>
<td>55</td>
</tr>
<tr>
<td>4-1</td>
<td>Contrasting a Flat Design With a Hierarchical Design</td>
<td>61</td>
</tr>
<tr>
<td>4-2</td>
<td>Interconnectivity Table Layout</td>
<td>64</td>
</tr>
<tr>
<td>4-3</td>
<td>New Block in Interconnectivity Table (ICT)</td>
<td>65</td>
</tr>
<tr>
<td>4-4</td>
<td>Adding Nets and Net Names Automatically</td>
<td>66</td>
</tr>
<tr>
<td>4-5</td>
<td>Dragdown Tab for Adding Multiple Nets</td>
<td>68</td>
</tr>
<tr>
<td>4-6</td>
<td>Forward To PCB Property Example</td>
<td>84</td>
</tr>
<tr>
<td>4-7</td>
<td>Part List Exclude Property Example</td>
<td>85</td>
</tr>
<tr>
<td>4-8</td>
<td>Net Short Dialog Example</td>
<td>92</td>
</tr>
<tr>
<td>4-9</td>
<td>Split Net Dialog Example</td>
<td>95</td>
</tr>
<tr>
<td>4-10</td>
<td>Ripper Symbols Example</td>
<td>98</td>
</tr>
<tr>
<td>6-1</td>
<td>Possible Dataflows Using the Expedition Workflow</td>
<td>124</td>
</tr>
<tr>
<td>6-2</td>
<td>Possible Dataflows Using the Netlist Workflow</td>
<td>125</td>
</tr>
<tr>
<td>6-3</td>
<td>Quick Connection View Cross-Probing Example</td>
<td>131</td>
</tr>
<tr>
<td>6-4</td>
<td>Quick Connection View Netlist Example 1</td>
<td>133</td>
</tr>
</tbody>
</table>
DxDesigner provides a scalable, multi-user design definition environment using schematics or interconnect tables that integrate with Expedition Enterprise (EE) layout tools across multiple computing platforms.

The following topics introduce you to some of the basic DxDesigner concepts and tasks:

- Working Concurrently within EE2007
- The DxDesigner Workflows
- Finding Information within DxDesigner
- Switching Between Releases or Flows
- Understanding the DxDesigner User Interface
- Starting and Exiting from DxDesigner
- Creating a New Project
- Copying or Deleting a Project
- Using the Navigator
- Working With Sheets
- Basic Editing of Selected Schematic Objects
- Executing DxDesigner Command Line Commands

**Working Concurrently within EE2007**

Because all applications use the same central database, multiple users can work simultaneously on the same design. This is called working concurrently.

**Requirements**

You must be working within a Client/Server environment. Your System Administrator sets up this environment, and provides designers with paths to libraries, projects, etc.

**Concurrency Examples.**

- Multiple users can open the same design in DxDesigner. DxDesigner locks files on a sheet-by-sheet basis. The first user to open a sheet has editing (read/write) privileges. If additional users open a sheet that is already being edited, DxDesigner opens the sheet in read-only mode, and specifies the user who is editing it. All changes made in the editing session appear immediately in the read-only sessions.
Introduction to DxDesigner

The DxDesigner Workflows

- Multiple users can open a design in different tools, such as DxDesigner, Expedition PCB or CES. When a user makes changes in one of the tools, the other tools indicate that forward or back annotation is required. These indications are provided by indicator lights in the status bar of the application.

![Figure 1-1. DxDesigner Indicator Light](image)

Yellow light indicates backward annotation pending

The DxDesigner Workflows

DxDesigner allows you to create projects that target different layout tools. When creating a new project you must choose between an Expedition workflow or a Netlist workflow. When you choose the Expedition flow, you target the tightly-coupled Expedition PCB layout tool. When you choose the Netlist flow, you can choose between a number of different layout tools.

The following topics briefly describe characteristics of each flow:

- The Expedition Workflow
- The Netlist Workflow

The DxDesigner User Interface (UI) accommodates the flow you have chosen. This means that various dialog boxes and menu items may change slightly depending on which of these flows you are working in. The DxDesigner documentation calls out these differences in the appropriate sections.

**For information about choosing a particular workflow**, see the topic “Creating a New Project” on page 22.

Related Topics

- Exchanging Data with Other Tools
The Expedition Workflow

Beginning with the 2007 release, Expedition Enterprise (EE), stores design data in a central, client/server database and stores symbol, cell, and padstack data in the Expedition Central Library. This architecture enables multiple applications to access design data simultaneously, resulting in:

- Real-time concurrent access to design data, with concurrent design entry, including constraints, resulting in a true concurrent design environment.
- Flexible client/server architecture
- Real-time connectivity creation - no netlist generation or compilation required
- Cross-probing between and within concurrent applications

For more information on this architecture, including setup, see the *DxDesigner Administrator’s Guide*.

This concurrent architecture lets you fit DxDesigner into your overall EE workflow in the most appropriate way for your design environment. For example, you can assign one person to schematic capture in DxDesigner, while another is working on PCB Layout in Expedition. See *Synchronizing DxDesigner and Expedition PCB* for more information.

Using the Expedition workflow gives you access to the following features (*not* accessible in the Netlist workflow):

**Supported in Expedition Workflow**

- Package (*Tools* menu)
- Library Manager (*Tools* menu)
- Expedition PCB (*Tools* menu)
- Constraint Editor System (*Tools* menu)
- Variants (*View > Other Windows* menu)
- Function Managed Variants (*View > Other Windows* menu)
- RF (*View* menu - if DxRFEngineer License Option enabled)

**Toolbar Buttons**

**Synchronizing DxDesigner and Expedition PCB**

When you are designing concurrently in DxDesigner and Expedition PCB, both tools track when changes are made in the other. Both contain an “Indicator Light” in the status bar at the bottom of the application that indicates when synchronization is needed. In DxDesigner, the light is green if no annotation is needed, and yellow if annotation is needed.
Depending on where changes were made, you synchronize by Forward Annotating from DxDesigner to Expedition PCB, or Back Annotating from Expedition PCB to DxDesigner.

**To forward annotate design data to Expedition PCB:**

1. Select **Tools > Package**.
2. Specify the parameters in the Packager Dialog Box. For detailed information, see Packager Dialog Box in the *DxDesigner Reference Manual*.

**Related Topics**
- Managing Design Changes Between Tools in the *Constraint Editor System User’s Manual*
- DxDesigner Flow in the *Expedition PCB User’s Guide*

### The Netlist Workflow

The Netlist workflow has the following characteristics:

- Uses Symbol Libraries instead of a Central Library as in the Expedition workflow
- Provides access to the following features (*not* accessible in the Expedition workflow):

  **Supported in Netlist Workflow**
  - PCB Interface (ViewPCB) (**Tools** menu)
  - DxLibrary Studio (**Tools** menu)
  - Property Definition Editor (**Tools** menu)
  - Constraints (**View > Other Windows** menu)

**Related Topics**
- *PCB Interfaces User’s Guide*
- *Managing Parts Databases with DxLibraryStudio*

### Finding Information within DxDesigner

You can find information within DxDesigner in any of the following ways:

- The DxDesigner User’s Guide Table of Contents

  The DxDesigner User’s Guide Table of Contents is built to reflect a typical workflow model, and provides flow-based links to information about your design tasks, including pre-and post-schematic capture tasks such as FPGA design, layout, and simulation.
Introduction to DxDesigner

Switching Between Releases or Flows

You can keep multiple DxDesigner releases or flows on your system. To switch between them, use the SDD Configurator. For more information, see the topic Switching Between Releases or Flows in Setting your Software Environment with SDD Configurator.

Understanding the DxDesigner User Interface

The flexibility of the DxDesigner interface enables you to customize your workspace by choosing which functionality (toolbar commands) you want to display at any given time or which icons appear in your session toolbars.

To display or hide the any of the following toolbars:

- Toggle any of the items listed from the menu View > Toolbars > Add Addins Command Line Main Transform View RF (if applicable to your installation)

For a brief description on each of these toolbars, refer to the Toolbars description in the topic titled “View Menu” in the DxDesigner Reference Guide.

You can also choose to close all add-ins, and display only the schematic editor window.

Tip: Many designers choose to close add-ins when they are not using them in order to maximize screen real estate for the schematic capture.

Changing Between Floating and Docked Window Types

DxDesigner uses two window types for displaying add-ins:

- Docked windows
By default, the windows stay in a specified location within the DxDesigner interface. You have the ability to remove them from view or change their display setting to a floating window.

- Floating windows
  You can display your windows as floating entities outside of the main DxDesigner interface.

To convert a docked window into a floating window:

1. In a blank spot in the docked window, uncheck the Allow Docking feature by right-click > Allow Docking.
2. Click-and-hold the title bar of the window.
3. Drag the window to another location on your screen.

To convert a floating window to a docked window:

1. In a blank spot in the floating window, enable the Allow Docking feature by right-click > Allow Docking.
2. Click-and-hold the title bar of the window.
3. Drag the window anywhere on top of the DxDesigner interface.

Tip: DxDesigner window placement is stored in the dxdesigner.wsp file. If you “lose” any undocked windows outside the bounds of your screen, delete this file. DxDesigner creates a new file that restores default window placement.
**Figure 1-2. DxDesigner Interface With Various Utility Windows Displayed**

- **Navigator:** displays, and allow you to operate on, the project hierarchy.
- **Properties:** interface for creating and editing property constraints.
- **Output:** displays the output results from commands. Other tabs display results from other actions.
- **Schematic Editor window:** interface for placing components on both flat and hierarchical designs.
Figure 1-3. DxDesigner Interface with Different Add-ins than Figure 1-1

**DxDataBook**: interface for searching and selecting components from various part libraries.

**Command Line Toolbar**: interface for executing commands.

**ICT Viewer**: allows you to view the interconnect table representation of the design.

**Symbols**: interface for searching, selecting, and placing symbols from various libraries.
Starting and Exiting from DxDesigner

On Windows or UNIX, you access DxDesigner through the Dashboard. On Windows, you can also access it from Windows Explorer or the Windows Start menu.

Starting DxDesigner in Windows

To invoke the Dashboard:

- Double-click the DxDesigner icon on the desktop.

To invoke DxDesigner from the Dashboard:

1. Open the Toolboxes folder.
2. Double-click the Board-level Design (PCB) toolbox.
3. Double-click the DxDesigner icon.

To invoke DxDesigner from the Windows Start menu:

- Select Start > Programs > Mentor Graphics SDD > DxDesigner-Expedition Flow> Design Entry> DxDesigner.

To exit from DxDesigner do one of the following:

- Select File > Exit.
- Click the outer red X to close the window.

Starting DxDesigner in UNIX or LINUX

1. In a command shell, navigate to: %SDD_HOME%/common/<platform>/bin
2. Type viewdraw.

Note

The first time you start DxDesigner, it may take a few minutes to appear. Subsequent invocations will be much faster.

Starting DxDesigner From a Command Window

You can start DxDesigner from a command window in Windows, UNIX or LINUX, without opening Dashboard.

To start DxDesigner from a command window:

1. Open a Windows command window, or a UNIX or LINUX command shell.
Creating a New Project

Before you can create a schematic, you must create a project in which to store the design data files that are generated.

Create a project from within the DxDesigner or the Dashboard in one of the following ways:

- Specify project parameter settings using a default or custom template for the particular workflow you are using, either Expedition or Netlist.
- From a DMS database. See “Copying or Deleting a Project” on page 24 for more information.

To create a new project using a default or a custom template in either the Expedition or Netlist workflow:

1. Do one of the following:
   - Within the DxDesigner or the Dashboard, select File > New > Project.
   - Within the Dashboard, right-click on the Projects folder and select Create Project from the popup menu.

2. In the New Project dialog, select a Project Template from the available list for the appropriate workflow you are using. There is one default template for each type of workflow. In addition, the list may contain custom templates that have been created by your administrator.
The following figure shows an example of various templates available from each workflow. If you choose a Netlist workflow template, you can then choose your target layout tool:

3. Enter the name of your project.
4. Enter the Location where your project folder will be created.
5. **Expedition Flow Only**: If it is not already filled in by a template, enter the path to the Central Library that your project will use.

   **Netlist Flow Only**: Choose your layout tool from the drop-down list.
6. If you choose to use the Client-Server Configuration manager, select the checkbox and enter the path to the server. For more information, see the topic “iCDB Administration” in the *DxDesigner Administrator’s Guide*.
7. Click **OK** to create the project.

   **Result**: The new project appears in the project list.

**See Also:**
- [The DxDesigner Workflows](#)

### Adding Libraries to a Project (Netlist workflow only)

You can add legacy DxDesigner symbol libraries to either a new or existing Netlist workflow project. If your company uses the Central Library model, you can add symbol libraries stored in
the SymbolLibs partition. You can also add libraries in this format from any network location accessible to DxDesigner.

**To add libraries:**

1. From the menu, click **Setup > Settings > Symbol Libraries** (section). The Symbol Libraries window opens.
2. Click the **Add** icon . The Library dialog box opens.
3. Browse to the symbol library you want to add. This library can be located in the SymbolLibs partition of your Central Library, or anywhere on you network where it is accessible to your system.
4. Click OK.

**Result:** The library is added to the list. Library entries are color-coded as follows:

- Read-only libraries are white.
- Writeable libraries are green.
- Mega libraries are Blue.

**Note:** Mega libraries are store in a proprietary, compiled format. DxDesigner decompiles the libraries automatically before displaying them in the Symbols window.

**To edit the library list:**

- Do one of the following:
  - Delete a library by selecting it and clicking the **Delete** icon .
  - Move a library up in the list by selecting it and clicking the **Move Up** icon .
  - Move a library down in the list by selecting it and clicking the **Move Down** icon .

**Related Topics**

- Working Concurrently within EE2007
- Creating a New Schematic
- Creating a Template File in the *DxDesigner Administrator Guide*

**Copying or Deleting a Project**

You can copy a project from another user on your network, rename a project, or delete a project from your project list.
To copy or move a project:

- Using the method appropriate to your operating system, copy or move the project folder to its new location.

To rename a project:

- Using the method appropriate to your operating system, rename the project folder.

To delete a project:

- Using the method appropriate to your operating system, delete the project folder from its location within your file system.

Using the Navigator

The DxDesigner Navigator contains a project tree as a graphical representation of your designs and their hierarchies. It dynamically updates and displays the project data in two primary structures: the design hierarchy and the list of blocks.

Designs vs. Blocks Nodes

The top-level block in a design is the root. Everything from the design root and below in its hierarchy appears in the navigator window under the Design node. You can have multiple designs in a project. Each design represents a separate PCB. Keeping all related PCB designs in one project allows the designs to share libraries and local blocks, and allows you to manage concurrent design throughout the entire project.

All the non-root blocks for all the designs in the project appear in the navigator window under the Blocks node in alphabetical order by name. You can create a design from a block and define the root node of the design from the RMB popup menu ( > Create Design and > Set as Root) after a right-click on the block of interest.

The first schematic you create in a project automatically goes under the Designs node as the root. Subsequent schematics go under the Blocks node.

For each block in either the Designs node or Blocks node, the navigator shows all the sheets associated with that block. For each sheet, the navigator shows an expandable folder for symbols and one for nets.

Navigator Contents

The project hierarchy is as follows: Project > Designs > Schematics > Blocks[0..n] > Leaf Cells, where the number of blocks can be zero to an indefinite number greater than zero. The complexity of blocks containing other blocks define the complexity of the design hierarchy.
You can toggle the Navigator on or off either by:

- Selecting the View > Navigator menu item or
- Clicking the button

The Project tab of the Navigator displays information within a hierarchical tree-like structure as shown in the following figure.

**Figure 1-4. DxDesigner Project Navigator Example**

The Project tab of the Navigator allows you to view the hierarchy of the design.

Click the minus (-) sign or plus (+) sign to expand or collapse the contents of entries on the Project tab. Right-click on the object name to display a shortcut menu with a list of applicable options.

The Project Navigator cross-probes bidirectionally with the Schematic Editor, the InterConnect Editor, CES, and Expedition Enterprise. Selecting a design object in one highlights it in the other. See Figure 1-5 for an example. It also updates dynamically. Design changes appear immediately, with no manual refresh required.
From the Navigator you can do additional tasks as described in the following topics:

- **Manipulating Objects from the Navigator** (rename, filter, reset filters)
- **Managing Schematic Sheets from the Navigator** (reorder, copy, add, delete,)

**Related Topics**

- **Changing Between Floating and Docked Window Types**
- **Navigator Settings - Settings Dialog** in the *DxDesigner Reference Manual*

**Manipulating Objects from the Navigator**

From the Navigator you can select sheets, symbols, and nets and manipulate them, such as filter the displayed list, reset existing filters, or rename selected object.

In the Navigator, blocks are denoted as either a schematic with the symbol or as an ICT object with the symbol.
To filter the displayed list:

1. Position the cursor over one of the objects in the list you want to filter. For example, if you want to filter a list of blocks, position your cursor over any block object in the list. See the following figure. You could also filter on sheets, symbols, or nets.

2. Right-click > Filter. In this example, the Filter blocks dialog appears. A similar dialog box appears for sheet, symbol, or net selections.

3. Select either the Wildcard or Reg. exp. (regular expression) radio button for your search.

4. Click the Add button shown in the following figure. A new line is added in the Filter blocks dialog list box.
5. As shown in the previous figure, select the Property type you want to use from the drop-down list. This example uses the Name of the block objects for the filter operation.

6. Edit the Pattern field to restrain the filter operation. This example is searching for all blocks that begin with “pci”, by using the wildcard operator “*” as shown in the previous figure.

7. Click the OK button. The list is filtered down. In this example, the filtering causes the following list to be displayed:

   Blocks
   - pci_conn
   - pci_express_conn
   - pci_x_conn

To reset all filters and display the complete list of objects:

1. Position the cursor over any object in the Project Navigator list.
2. Right-click > Reset all filters.

To rename selected object from Navigator:

1. Right-click > Rename or double-click the object name so it appears highlighted in a box. For example:

   ![Schematic]

2. Type the new name of the object and press <Return>. For example:

   ![new_name]

Managing Schematic Sheets from the Navigator

A sheet is a grouping of design elements that is equivalent to a schematic page. You can do the following with sheets:

To re-order the sheets in a design:

1. In the Project Navigator, select a sheet, then drag and drop it to its new position in the order. The sheets will still reflect their original sheet number.
2. Select all the sheets in the design.
3. Right-click > Renumber. DxDesigner renumbers the sheets to reflect the new sheet order.

To copy sheets:

1. In the Project Navigator, select the sheet you want to copy.
2. Right-click > Copy.
3. Place the cursor in the schematic into which you want to paste the sheet.
4. Right-click > Paste.
To add a sheet:

- In the Project Navigator, position the cursor over the last sheet name in the level where you want to add a new sheet.
- Right-click > Page Down.

To delete a sheet:

- In the Project Navigator, position the cursor over the schematic name you wish to delete.
- Right-click > Delete.

Working With Sheets

The following topics describe some basic schematic sheet operations:

- Traversing from Sheet to Sheet
- Viewing Pins and Nets and Their Associated Components

Also see

- Managing Schematic Sheets from the Navigator

Traversing from Sheet to Sheet

You can explore multiple sheets of a flat design or the hierarchy of a design as follows:

Figure 1-6. Traversing Sheets of a Flat Design

To move to the previous sheet:

- <Page Up> key (Pop-up) > Previous Sheet
- (Pop-up) > Goto Sheet
- On command line, enter “psheet” or “psh”

To move to the next sheet:

- <Page Down> key (Pop-up) > Previous sheet
- (Pop-up) > Goto Sheet
- On the command line, enter “pop”
The title bar of the active window indicates the schematic or symbol's name.

For additional information on the command line commands shown in the previous figures, see the topic “List of Command Line Commands” in the DxDesigner Reference Manual.

**Viewing Pins and Nets and Their Associated Components**

You can browse and show all of the components that are attached to selected nets in your design or show all pins and their corresponding nets attached to selected components in your design.

**To show the pins and nets that are attached to one or more components:**

1. In a schematic, select the component(s) of interest.
2. Right-click > **List Connected Nets**. The result appears in the Output window.
**Basic Editing of Selected Schematic Objects**

The following topics outline the procedures of some of the schematic editing tasks that can be accessed from the menus or their equivalent command line commands:

- Reflecting a Selected Object
- Rotating a Selected Object
- Scaling a Selected Object
- Changing Size of Selected Text, Properties, or Names
- Stretching a Selected Object
- Cutting or Copying a Selected Object
- Pasting Objects From the Clipboard
- Adding an Array for Selected Objects
- Zooming on a Selected Area or Object
- Changing the Name of a Selected String

**Also See**

- Selecting and Deselecting Objects

**Reflecting a Selected Object**

You can reflect the selected object(s) as a mirror image across a horizontal or vertical line, or both as follows:

1. Select the object or objects you want to reflect. For more information, see “Selecting and Deselecting Objects” on page 104.

2. **To flip horizontally**, select **Format > Mirror**, or click .
   
   **Result:** Objects are reflected 180 degrees about their horizontal axis.

3. **To flip vertically**, select **Format > Flip**, or click .
   
   **Result:** Objects are reflected 180 degrees about their vertical axis.

4. **To flip both vertically and horizontally**, select **Format > Flip/Mirror**, or click .
   
   **Result:** Objects are reflected 180 degrees about their vertical and horizontal axis.

**To flip the selected object(s) around a defined axis:**

1. Select the desired object(s).

2. Type “reflect” in the command line.

3. On the schematic, use the mouse to draw either a horizontal or vertical line through the selected object(s) to define the axis of rotation.

   **Result:** Objects are reflected 180 degrees about the axis that you defined.
Rotating a Selected Object

You can rotate the selected object(s) to the left in 90-degree increments as follows:

1. Select the object or group of objects. For more information, see “Selecting and Deselecting Objects” on page 104.
2. Select Format > Rotate.
3. For additional rotations, repeat these steps.

Scaling a Selected Object

You can scale the size of the selected object or group of objects by the scale factor you specify, as follows:

1. Select the object or group of objects you want to scale. For more information, see “Selecting and Deselecting Objects” on page 104.
2. Choose Format > Scale or click \( \text{F1} \) or type “scale” on the command line and execute the command.
3. Fill in the Scale factor field of the Scale dialog box.
4. Click OK.

Changing Size of Selected Text, Properties, or Names

You can change text, properties, or names to a specified size in the schematic or symbol window.

**To change the size of text, properties, or names using the command line:**

1. Select the text, property, or name.
2. Type “size new_value” in the command line field and execute the command. If you do not specify new_value, a Text Size dialog box appears.
3. In the Text Size dialog box, enter the size you want to change the text to.
4. Click OK.

Stretching a Selected Object

You can stretch the selected object in any direction. Stretchable objects are: Lines, Boxes, Circles, Arcs, and Pins.
Introduction to DxDesigner

Basic Editing of Selected Schematic Objects

1. Select the object or group of objects you want to stretch. For more information, see “Selecting and Deselecting Objects” on page 104.

2. Choose Format > Stretch or 
   click or 
   type “stretch” on the command line and execute the command.

3. With the left mouse button, use the cursor to grab the object and drag it to the shape and size you want.

4. Release the mouse button.

Cutting or Copying a Selected Object

You can remove (cut) the selected object(s) or areas of the drawing or copy the selected object(s) and place them on the clipboard, which overwrites the previous clipboard contents. If you use the copy command, the original selected object(s) remains untouched. Use either of these commands as the first step when you want to paste the objects elsewhere.

1. Select the object or group of objects you want to cut or copy. For more information, see “Selecting and Deselecting Objects” on page 104.

2. To cut the selected object(s), choose Edit > Cut. (Removes and saves-to-clipboard.)
   To copy the selected object(s), choose Edit > Copy. (Saves-to-clipboard.)

Related Topics

- Pasting Objects From the Clipboard
- Paste Special Dialog Box in the DxDesigner Reference Manual

Pasting Objects From the Clipboard

You can paste the contents of the clipboard into the drawing at the location you specify as follows:

1. Choose Edit > Paste or click .

2. When performing a paste, start with the cursor in the approximate location you want the lower left corner of the pasted object to land.

3. Press-and-hold the left mouse button as you move the mouse slightly. This causes the object to appear on the cursor and you can then place it as necessary. You can use the function keys while dragging the pasted objects to move around the schematic.

4. Once you have the object in place, release the mouse button.

To paste information in a specified format, or create a link to information that can be updated in another application, use the Edit > Paste Special ... menu item to bring up the Paste Special
Related Topic

- Cutting or Copying a Selected Object

Adding an Array for Selected Objects

You can create an array for one or more selected objects as follows:

1. Select the object or group of objects to include in the array. For more information, see “Selecting and Deselecting Objects” on page 104.

2. Choose Add > Array or enter “array” on the command line.

3. In the Array Dialog Box, specify the number of columns and rows as well as relative or absolute spacing.

Using positive values for the spacing settings creates the array to the right and/or upward in the window.

Zooming on a Selected Area or Object

You can increase the size of your view in the following ways.

To zoom in on a selected area:

1. Select View > Zoom Area

2. Drag the cursor to form a box around the area you want to zoom in on.

3. Release the cursor. The view zooms in.

4. Repeat until you have zoomed in sufficiently.

To zoom in on a selected object:

1. Select the object or group of objects you want to zoom in on. For more information, see “Selecting and Deselecting Objects” on page 104.

2. Choose View > Fit Selected or click the button or enter “zselect” on the command line.

Tip: If you want to zoom in more tightly than the default, you set the VL_FULL_ZOOM environment variable, using the syntax VL_FuLL_ZOOM=1. If you do not set this environment variable, you will zoom in at a medium distance from the selected object.
3. Pressing Esc cancels the redisplay.

**If you want to zoom in and out on the entire sheet:**

- Use the Zoom In 🔗 and Zoom Out 🔗 buttons.

### Changing the Name of a Selected String

You can change the name of any selected name, property, or text string as follows:

**To select and change a string using the associated Properties window:**

1. Right-click on the property, name, or text string to select it and bring up a menu. Also see “Filtering Which Objects to Select” on page 108.
2. Choose **Properties** to bring up the appropriate Properties window.
3. In the Properties window, change the name and click **OK**.

**To find a string from the Find/Replace dialog box:**

1. Choose **Edit > Find/Replace**.
2. In the Find and Replace Text dialog box, the Find tab, enter the string you want to find, and set the scope of the search.
3. Optionally, click **More**
4. Specify additional search parameters.
5. Click Find Next or Find All.

**To replace a string from the Find/Replace dialog box:**

1. After you have filled in the Find tab, click the Replace tab.
2. Enter the replacement string.
3. Click **Find Next**.
4. Once the string is found, click Replace... or Replace All.

**To change a string using the command line:**

1. Select the string that you want to change. For more information, see “Selecting and Deselecting Objects” on page 104.
2. Type “string” on the command line and execute the command.
3. Enter the new string name in the Edit String dialog box.
4. Click **OK**.
Executing DxDesigner Command Line Commands

- Rather than using the GUI, you can use DxDesigner functionality with the Command Line.

**To invoke the Command Line:**

You invoke the command line by depressing the space bar. This places the cursor at the beginning of the command line in the command line menu.

The command line entry field is a dockable bar. You can drag it to the edge of the application window and the bar will dock to the edge of the window automatically. To undock it, drag it into the application window.

**To use the Command Line dialog boxes:**

The Command Line Dialog boxes support several useful Hot Keys. Use them to manipulate the data in the dialog box.

- To open a pulldown list, use ALT+ DOWN ARROW or click anywhere in the list box
- To close a pulldown list, use ALT+ DOWN ARROW or ENTER.
- To select the desired value from the pulldown list use UP ARROW or DOWN ARROW.
- To select a new value, type the first letter of the value you want. The box will be automatically filled in.

**Related Topic**

- **DxDesigner Key Bindings and Strokes** in the *DxDesigner Reference Manual*
Chapter 2
Defining Project Settings

The following topics describe methods you can use to set up DxDesigner.

- Customizing the Dashboard
- Customizing DxDesigner From the User Interface
- Framing a Design with Borders
- Configuring Special Components
- Setting Up Constraints in CES

Some of the general DxDesigner setup may be performed by a system administrator. An administrator can define company-wide standards or styles for selected settings (for example, object colors and schematic borders) in the standard DxDesigner.xml file. Other settings, such as paths to the central library (Expedition workflow only) can be specified in a .prj template file(s) that you can then apply when you create a new project.

Other tasks such as setting the WDIR environment variable and setting soft pathnames are also tasks an administrator should perform before you create your project. These topics are covered in Preparing your Environment for Project Development in the DxDesigner Administrator’s Guide.

Related Topics

- DxDesigner.xml File (in DxDesigner Reference Manual)
- project.prj File (in DxDesigner Reference Manual)

Customizing the Dashboard

By taking advantage of DxDesigner customization capabilities, you can streamline the Dashboard so that it reflects your design process flow needs. You do this by setting default preferences, creating and manipulating toolboxes, adding shortcut groups to the Shortcut Bar, and using automation and scripting.

Setting Dashboard Preferences to Fit Your Style

To configure the Dashboard so that it appears in a specific format and operates in a specific way by default, you define a set of user preferences.

To set defaults for the Dashboard based on your personal preferences:

1. Select Edit > Preferences.
Defining Project Settings

Customizing the Dashboard

2. From the Preferences dialog box, set the following default behaviors:

- Whether the Dashboard will open Internet Explorer in the Application Launch Pad or open your system’s default browser in a full-screen window when you click a Web-enabled item in the Dashboard Tree.
- Whether a user-specifed Web page or expanded information from the Dashboard Tree will appear in the Application Launch Pad when you open the Dashboard.
- What color various message types displayed in the Output Bar will be.

Creating, Adding, and Deleting Items in a Toolbox

In addition to using the default toolboxes shipped with DxDesigner, you can create and define the contents of new toolboxes, as well as adding items to existing toolboxes.

Accessing Frequently-Used Documents

Along with the tools shipped in a toolbox, you may also require additional items as part of your design process, such as a functional specification document for your design and a specific text editor. To customize the Dashboard so that it includes easy access to these items, you can add links within an existing toolbox. For example, your job may be to prepare schematics for export to Layout, so you work primarily in the Board-Level PCB Toolbox. You can add the items to this toolbox for easy access. You can also create a new toolbox with links to these items. If desired, you can then drag and drop an entire toolbox or a specific item into the Shortcut Bar for even faster access to it.

Each toolbox has a directory associated with it. DxDesigner places all default toolbox directories in the standard directory, which is located one level below your DxDesigner installation directory. When you create a new toolbox, you specify where you want to place the associated directory. This directory can include items of the following types:

- Executables
- Shortcuts to executables
- Batch files
- Script files (such as VBScript)
- Icons associated with any of these items

To create a toolbox use one of the following methods:

- Select File > New > Toolbox, and then enter the name and path of the toolbox in the toolbox properties dialog box.
- From the Dashboard Tree, (right-click) > Toolboxes > New Toolbox, and then enter the name and path of the toolbox in the toolbox properties dialog box.
To add items to a toolbox or modify the properties for an existing tool:

1. From the Dashboard Tree or Application Launch Pad, right-click the desired toolbox, and then click New Tool.

   **Alternative:** To modify properties for an existing tool, right-click the tool icon, and then click Properties.

2. From the Properties dialog box, type a name for the tool.

3. Type the path or browse to the executable file for the tool and enter any command line arguments you want to use with the tool.

   **Tip:** A command line argument is often used to identify a specific document associated with an application. For example, if the item you are adding is a link to a specific.doc file, you still need to associate the application to the item. In this case, the path to the tool would be the path to the Microsoft Word or Wordpad application executable to which you want the file to be associated. The command line argument is the path to the specific file you want opened when the user clicks on the item.

4. If you do not want a generic icon to represent the tool in the toolbox, type the path or browse to the icon you want to use.

   **Tip:** The graphic used to represent the tool in the Dashboard can come from an icon (.ico) file, or an executable or dll with an embedded graphic (such as viewdraw.exe).

5. Specify whether you want the tool to be visible in the Output Bar while it is running.

6. If your tool does not require user input, specify that you want to see messages and errors from the tool in the Output Bar.

   **Tip:** If the tool will require user input, do not select this option. Instead, the tool will open in a separate window, where you will be asked to enter the input it requires. You will see messages and errors in this window, rather than in the Output Bar.

To delete items from a toolbox:

1. From the Application Launch Pad, open the toolbox.

2. Right-click the item you want to delete, and then click Delete from the shortcut menu that appears.

**Configuring the Shortcut Bar**

The Shortcut Bar gives you an additional level of customization within the Dashboard. Similar to the grouping capability available with Toolboxes, the Shortcut Bar allows you to organize commonly used or similar type applications and documents within shortcut groups and to access them with a single mouse click.
Entries you may find useful to include within a shortcut group include:

- DxDesigner tools or other applications
- Projects listed in the Dashboard Tree (Clicking a Project icon in the Shortcut Bar will automatically expand that particular branch of the Dashboard Tree containing the list of libraries associated with that project)
- Commonly used schematics (DxDesigner will launch automatically and the schematic will open)
- Utilities
- Text Editors

**To add a new shortcut group to the Shortcut Bar:**

1. Select **File > New > Shortcut Group**.

   **Alternative:** Within the open space of the Shortcut Bar, (right-click) > **New Shortcut Group**.

2. Type a name for the desired group, and then click **OK**.

   **Result:** A title bar for the new shortcut group appears in the Shortcut Bar using the name you specified. The group is now active and any items you add will be included within this shortcut grouping.

3. Do one of the following:

   - Drag and drop items from the Dashboard Folders Bar or Application Launch Pad into the Shortcut Bar to create links to them
   - Right-click within the open space of the Shortcut Bar, click **Add Shortcut**, and then navigate to and select the desired item.

   **Tip:** If you create multiple shortcut groups, you can quickly switch between them by clicking on the title bar of the desired group.

**To rename or remove a shortcut group from the Shortcut Bar:**

- Right-click within the open space of the Shortcut Bar, and then click **Rename Group** or **Remove Group**.

---

**Customizing DxDesigner From the User Interface**

Some of the DxDesigner characteristics that you can customize and change from within DxDesigner are listed as follows:
Customizing the Tools Menu

You can customize the Tools menu to include programs that you want to launch from your DxDesigner application.

You customize your Tools menu by adding, removing, or editing menu command entries. The Tools menu has three sections:

- **System menu commands:**
  Commands that the application places on the Tools menu. These commands appear in the top most section of the Tools menu command list. You cannot customize or edit these commands.

- **Common menu commands:**
  Commands that you place on the Tools menu that are customizable and available to any user. These commands are identified with a “(common)” text string appended to your menu name in Tools menu command list.

  DxDesigner stores changes to the common menu in a file named commontools.ini that is located in the %SDD_HOME%\standard directory. These changes will be effective for all users of this machine in all projects.

- **User menu commands:**
  Commands that you place on the Tools menu that can run any program. These commands appear in the bottom section of the Tools menu command list.

  DxDesigner stores information about the user menu in a file named usertools.ini. DxDesigner maintains copies of this file in either the project directory or in the first writable directory in your WDIR path based on the whether you select the “Customize this project only” option.

Related Topics

- Using Arguments
Adding a Command to the Tools Menu

**To add a command to the Tools menu:**

1. Select **Tools > Customize** to display the Customize Tools Menu dialog box.
2. If you want the command available to all users who log on to your PC, select the Common option from the Menu Item Types section.
3. Enter the name that you want to appear as the new menu command in the Menu Text field.
4. You can specify a letter in the menu title as a menu accelerator by entering the title with an ampersand (&) immediately preceding the accelerator letter. If you do not specify an accelerator, the first unique letter in the title is the accelerator by default.
5. Enter the command that invokes the new application in the Command field.
   - You can use the **Browse** button to select the appropriate drive and directory, and then select the executable you want to add from the list of file names.
6. Enter the arguments associated with the command in the Arguments field.
   - For information on valid arguments, refer to "Using Arguments" on page 45.
7. Enter the working directory for the tool in the Initial directory field.
8. Click the **Add** button to add the menu item to the Tools menu.
9. Click the **OK** button to dismiss the dialog box.

**Result:** The command now appears on the Tools menu. To run the program, choose it from the menu.

Editing a Tools Menu Command Entry

**To edit a Tools menu entry:**

1. Select **Tools > Customize**.
   - The Customize Tools Menu dialog box appears.
2. Select the menu option that you want to edit from the Menu Contents field.
3. When you select the option, the information associated with that option appears in the Menu Text, Command, Argument, and Initial Directory fields.
4. Edit the field that you want to change. For example, edit the command name that appears on the Tools menu by editing the text in the Menu Text field.
5. You can also change the location of the menu item in list using the Move Up and Move Down buttons.
6. Click OK.

**Removing a Command From the Tools Menu**

To remove a command from the Tools menu:

1. Select **Tools > Customize**.
   
The Customize Tools Menu dialog box appears.
2. In the Menu Contents field, select the command you want to remove.
3. Click **Remove**.
4. Click **OK**.

**Using Arguments**

Each application may support a set of predefined variables called arguments. Arguments are not required. You can specify arguments for any program that you add to the Tools menu.

Enter arguments (in uppercase) in the Arguments field of the Customize Tools Menu dialog box. If you want to use more than one argument, leave a space between each argument entry.

**Note**

If the command is named the same as the executable, the application closes the window when done executing. If you want to keep the window open, use the /k qualifier as the first argument.

**DxDesigner Arguments**

Argument entries are case sensitive and must be entered in uppercase.

<table>
<thead>
<tr>
<th>Argument</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>$BLOCKNAME</td>
<td>The file name of the current symbol or schematic.</td>
</tr>
<tr>
<td>$BLOCKPAGE</td>
<td>The current sheet of the schematic.</td>
</tr>
<tr>
<td>$BLOCKTYPE</td>
<td>A string that defines the type of drawing (SCHEMATIC or SYMBOL). This string is always uppercase.</td>
</tr>
<tr>
<td>$PROJDIR</td>
<td>The path to the current project directory.</td>
</tr>
<tr>
<td>$COMPNAME</td>
<td>The component label of the selected component.</td>
</tr>
<tr>
<td>$NETNAME</td>
<td>The net label of the selected net.</td>
</tr>
<tr>
<td>$PINNAME</td>
<td>The pin label of the selected pin.</td>
</tr>
</tbody>
</table>
Customizing your DxDesigner Workspace

Use the View menu to toggle display of toolbars and addins, such as the Properties Editor and the Navigator.

Tip: You can toggle the Add-ins toolbar on and off using the View > Toolbars > Addins menu choice. When the Addins toolbar is displayed, hover over the buttons to see a tooltip which describes the associated addin.

You can drag and drop icons on the toolbar as a shortcut to customizing the toolbar.

For more information, see View Menu in the DxDesigner Reference Manual.

Displaying and Customizing Pintype Arrows

Select the Setup > Settings > Advanced (section) > Pintype Arrows (option) to configure directional arrows on component and symbol pins that have PINTYPE properties. Your choices are None (do not display), Full Size and Half Size.

Changing the Appearance of the Cursor

Select Setup > Settings (dialog box) > Advanced (section) to select either no cursor, a small cursor or a full-extent cursor that spans the entire schematic.

Changing Object Colors

You can change how objects are displayed on your screen using the Settings command from the Project menu.

To change the color settings for a graphical object:

1. Select Setup > Settings (dialog box) > Display (section) > Objects (subsection).
2. Select the object type whose color you want to change
3. For each object you select choose the object color, text color, fill and line styles, and font. Note that all choices will not be available for every selection.
4. Click OK.

To change the color of an object using the command line:

1. Select the object or group of objects that you want to change.
2. Enter “color” and the color you want the object changed to in the command line field and execute the command. For example, “color blue”.

46
If you enter only the command “color”, the Change Color dialog box appears to prompt you to enter the color.

**Note**

If the object is a text object, you can change the only the color and font style for the object.

**Related Topic**

- Display - Settings Dialog in the *DxDesigner Reference Manual*

---

**Framing a Design with Borders**

You use borders to display corporate and custom information on your schematics, such as company name and logo, project name, creation or revision dates, and sheet numbers. You can also specify borders for each sheet size that your company uses.

Things that must be done to use borders on your DxDesigner schematics are as follows:

- **Create** or locate border symbols for each sheet size you will be using in your project(s). You store these border symbols in a partition in your Central Library. You can start with the border symbols provided in the SymbolLibs/Borders partition of the default Central Library or create your own.

- Decide where you will store the **border configuration** for your project or group of projects. The border configuration is stored in a borders.ini file. You can choose to locate the borders.ini file in location visible to multiple users, such as the Central Library or in a local project or a working directory.

- Use DxDesigner to **configure a project** to use selected borders for each sheet size you will be using, both for the first sheet in a design and for subsequent sheets.

Once you have a set of border symbols and have set up your project with a border configuration, you are ready to **add a border** to your schematic sheet.

**Related Topics**

- Creating a Sheet Border Symbol
- Specifying Border Configuration File Location
- Creating a Border Configuration
- Controlling Sheet Borders on a Schematic
- Changing Border Properties
Creating a Sheet Border Symbol

A sheet border is a specialized type of symbol. Therefore, to build a sheet border, you build a symbol. You can treat a border like any symbol, by assigning properties to it, and placing it on a schematic. A simple way to create a new sheet border is to find an existing border that is similar to the one you will want to use. You can copy it and edit it.

To copy/paste an existing border symbol to create a new border symbol:

1. Use the Library Manager to copy/paste an existing border symbol from your current Central Library. See the following example in Figure 2-1.

   For more details refer to the topic “Copying Objects via the Library Navigator Tree” in the Library Manager Process Guide.
2. Use the Symbol Editor (click the icon from Library Manager) to edit your new symbol. The *DxDesigner Symbol Editor* manual describes the details of creating and editing symbols.

3. If you have started this symbol creation process from DxDesigner as described here, you will have to restart DxDesigner before your new symbol(s) is available in the Border Symbol window (accessed from **Setup > Settings > Borders**), as shown in Figure 2-3 on page 53.

---

**Figure 2-1. Using Library Manager to Copy/Paste a New Border Symbol**

- a. Select border symbol you want to copy.
- b. Right-click to select Copy menu choice.
- c. Fill in name of your new symbol.
- d. Optionally specify a different Target Partition if applicable.
Specifying Border Configuration File Location

The border configuration is the assignment of a particular border symbol to each of the sheet sizes that you will use in DxDesigner. (See “Creating a Border Configuration” on page 51.) Configuration information for your borders is stored in a file named “borders.ini”. An example of a borders.ini is shipped in the “standard” directory of your DxDesigner installation. You can control the scope of your border configuration, making it available to your projects in either of two ways:

- Place borders.ini in a location that is visible to multiple users/projects such as a Central Library.
- Place borders.ini in a location that is limited to one user (such as WDIR) or to a local project (in the project directory).

To save and point your project to a particular borders.ini file:

1. Select Setup > Settings > Project (section).
2. In the Border Symbols field (shown in Figure 2-2) enter a path to the borders.ini file as described at the bottom of the figure:
Creating a Border Configuration

This topic describes how you select the border symbol you want to use for each sheet size that will appear in your project(s).

Requirement

Before you create a border configuration for your project, you should have specified where the configuration is stored (where the border.ini file is located). See “Specifying Border Configuration File Location” on page 50.
Defining Project Settings
Framing a Design with Borders

Procedure

To configure each sheet size with a particular border symbol:

1. Select the **Setup > Settings** menu choice to open the Settings dialog.

2. Under the Project section of the Settings dialog, click Borders.

   The Borders section of the Settings dialog lists the possible sheet sizes that can be used in your project. Now you must assign a border symbol to each of the sizes you plan to use.

3. Locate the Sheet size you wish to assign a border symbol. Left-click in the associated “First sheet” column. For example, click the “First sheet” box in the “A Portrait” row.

   The Border Symbol window appears as shown in Figure 2-3.

4. In the Border Symbol window, navigate to the desired partition that holds your border symbols. (In the Figure 2-3 example, the border symbols are located in the Border partition.)

5. Select the desired border symbol and click **OK**.

   The border symbol is added to the box and recorded in the border.ini file you specified earlier. **(Note: if you did not specify a border.ini file in Setup > Settings > Project (section), your setting(s) will be ignored.)**
Framing a Design with Borders

Figure 2-3. Setting Border Configuration for a Project

Left-click in the First sheet or Next sheets box to open the Border Symbol window.

6. Repeat the previous step for all sheet sizes and first and next sheet columns as needed.

Controlling Sheet Borders on a Schematic

You can add borders to a schematic sheet automatically, add them manually, change a border or delete a border.

Requirement

Before you can add borders to a schematic sheet, you first must create and configure the sheet borders.

Procedure

To automatically have a sheet border applied to each schematic:

1. Select Setup > Settings to open the Settings dialog.

2. In the Schematic Editor section of the Settings dialog, click New Sheets.
Defining Project Settings
Framing a Design with Borders

3. In the Border Sheet Options section, check the option “Automatically add border to new schematic sheets.”

To add a border to a schematic manually:

- In the Schematic window, (right-click) > Insert Border.

To delete a border from a schematic:

- In the Schematic window, (right-click) > Delete Border.

To change an existing border:

1. In the Schematic window, (right-click) > Change Border.
   The Border Symbol window appears.
2. Navigate to the partition that holds the border symbol you want.
3. Select the desired symbol and click OK. Use care to pick a proper symbol for your current sheet size.

Changing Border Properties

Certain properties may have been associated with pre-defined borders. It is possible for you to change these properties and propagate those changes to either the entire project, a selected design level, a selected schematic level, or a selected sheet level.

To change an existing border property value:

1. Select Setup > Settings > Project (section) > Borders (subsection).
2. Click the Properties button. The Border Properties dialog appears as shown in Figure 2-4.
3. Click OK in the Border Properties dialog, followed by OK in the Settings dialog. Your change did not yet take effect in the project, but did get saved to the Border Symbols file that is specified in Setup > Settings > Project (section) > Border Symbols (field).
4. You must choose the scope for this property change to take effect as one of the following: Project, Design, Schematic, or Sheet.
   If you are going to make this change to the entire project, you do not need to select anything in the Navigator window. For any other scope, in the Project Navigator window, select the desired Design, Schematic, or Sheet for this change to take effect.
5. To propagate the property change, select Edit > Update Properties. Choose the scope for this property change to take effect. Once you have selected the desired scope, the property change is made to that area of the project.
Configuring Special Components

Use DxDesigner to create lists of available ports, Onsheet/Offsheet pins and Power/Ground pins. You then add special components from this list as you design.

Table 2-2. Special Component Definitions

<table>
<thead>
<tr>
<th>Pin Type</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Port</td>
<td>A component of type pin that indicates that the net connected to this component is an interface signal. It represents a connection to a specific pin on the corresponding symbol. Labeling the component with the same name as the symbol pin specifies a connection down through the hierarchy.</td>
</tr>
<tr>
<td>Onsheet Pin</td>
<td>A component of type annotate that contains one pin. Indicates that the net to which it is attached is coming from another sheet in the design. Labels on Onsheet pins have no electrical significance, and will generate a check warning.</td>
</tr>
</tbody>
</table>
To Configure Special Components

Use the following procedure to create or modify a list of symbol names to associate with each type of special component. You select from this list when you add a special component to your design.

To add a symbol name to the list:

1. Select Setup > Settings > Project (section) > Special Components (subsection).
2. From the pulldown, select the type of component you want to edit.
3. Use the New (insert) button to open a list of available symbols for the component type you have selected.
4. Add as many symbols as you want for each type of component you select in the pulldown.
5. Click Apply to finish building your list and leave the Settings dialog box open, or click OK to complete this process and close the Settings dialog box.

To remove a symbol name from the list:

1. Select Setup > Settings > Project (section) > Special Components (subsection).
2. From the pulldown, select the type of component whose list you want to modify.
3. Select the symbol name you want to remove.
4. Delete as many symbols as you want for each type of component you select in the pulldown.
5. Click Apply to finish building your list and leave the Settings dialog box open, or click OK to complete this process and close the Settings dialog box.

To change the order of a symbol list:

1. Select Setup > Settings > Project (section) > Special Components (subsection).
2. From the pulldown, select the type of component whose list you want to modify.

<table>
<thead>
<tr>
<th>Pin Type</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Offsheet Pin</td>
<td>A component of type annotate that contains one pin. Indicates that the net to which it is attached is going to another sheet in the design. Labels on Offsheet pins have no electrical significance, and will generate a check warning.</td>
</tr>
<tr>
<td>Power/Ground Pin</td>
<td>A component of type pin that contains one pin. Indicates that the net to which it is attached is connected to either power or ground.</td>
</tr>
</tbody>
</table>
3. Within the list, select a symbol, and click the Move Up  or Move Down  button.

4. Click **Apply** to finish editing your list and leave the Settings dialog box open, or click **OK** to complete this process and close the Settings dialog box.

**To add a special component to a schematic:**

1. On the Add toolbar, click the icon for the special component you want to add. The icons are shown in Table 2-3.

### Table 2-3. Special Component Toolbar Icons

<table>
<thead>
<tr>
<th>Special Component</th>
<th>Icon</th>
</tr>
</thead>
<tbody>
<tr>
<td>Port</td>
<td>![Port Icon]</td>
</tr>
<tr>
<td>Onsheet Connector</td>
<td>![Onsheet Connector Icon]</td>
</tr>
<tr>
<td>Offsheet Connector</td>
<td>![Offsheet Connector Icon]</td>
</tr>
<tr>
<td>Power</td>
<td>![Power Icon]</td>
</tr>
<tr>
<td>Ground</td>
<td>![Ground Icon]</td>
</tr>
</tbody>
</table>

2. If you have configured more than one symbol for the component, a list appears. Select a symbol from the list.

**Setting Up Constraints in CES**

You use the Constraint Editor System (CES) to create and configure constraints. You then add constraints to the Schematic within DxDesigner.

CES is a centralized tool for storing constraint information and analysis results. CES reads a DxDesigner database and displays net, pin, and component data in a spreadsheet format. Constraints can then be entered into CES and passed to the layout tool.

CES supports both Net Classes and Constraint Classes. Net Classes include trace properties such as trace width and impedance, as well as via assignments for each layer. Constraint Classes are used to define the routing topology, crosstalk and parallelism rules, delay or length constraints, and matched net lengths. Clearance rules can also be defined for all design objects and assigned on a per-layer basis.

CES also supports topology templates. You use topology templates to define all the constraints for a type of net and then apply the constraints to similar nets in the same design or in a new design. For example, a complex bus topology may be created for a type of memory design. When the same memory is used in a new product, the topology template can be applied to the bus structure so that it does not have to be reentered.
Setting Up Constraints in CES

Note

You can enter a subset of constraints in the existing constraint tab of the Properties Editor in DxDesigner. These constraints will be synchronized with CES.

For details on how to use CES within the DxDesigner-Expedition PCB flow, refer to the DxDesigner-CES-Expedition PCB Design Flow topic in the Constraint Editor System™ (CES) User’s Manual.
Chapter 3
Creating and Editing Symbols

You create and edit Central Library symbols using Library Manager. These symbols are placed into partitions in the Central Library, and placed on a DxDesigner schematic using the Symbols Window. For more information, see the *DxDesigner Symbol Editor* manual.

Also see “Creating a DxDesigner Symbol Using Dx Symbol Editor (DxD-Expedition Flow)” in the *Library Manager Process Guide*.

When you build hierarchy from the bottom up, you create a symbol to associate with the underlying schematic by creating a local symbol.

This symbol is appears in the [local symbols] “pseudo-partition” of the Symbols window. This “pseudo-partition” is displayed separately from true Central Library partitions.

You can edit generated symbols or import them into the Central Library using the Symbol Editor.

Creating a Local Symbol

You can create the following types of local symbols:

<table>
<thead>
<tr>
<th>Symbol Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Module</td>
<td>Does not have an underlying schematic. Represents a base function or physical part in the design. Appears as a leaf cell in the Navigator.</td>
</tr>
<tr>
<td>Composite</td>
<td>Has an underlying schematic. Implements the underlying schematic function at a higher level of the design. This is also called a block.</td>
</tr>
<tr>
<td>Pin</td>
<td>A port or interface on the schematic (for example, IN, OUT, or BI built-in symbols). You also use pin symbols to tie a net to a global symbol.</td>
</tr>
<tr>
<td>Annotate</td>
<td>A graphic or annotation that has no electrical or connectivity information</td>
</tr>
</tbody>
</table>

To create a local symbol:

1. Select **File > New > Local Symbol**. The Symbol Editor opens.
2. Using the drawing tools, create the symbol graphic.
Creating and Editing Symbols

Creating a Local Symbol

3. For Pin0, which appears by default, specify the Name, Direction, Side, and Pin Number parameters, and then click Enter. An asterisk appears in the left-hand column, indicating that the pin is unplaced.

4. Create additional pins by clicking below existing rows to add new rows.

5. Place pins by selecting the row and dragging it onto the symbol graphic. As you drag the row, it become a graphic of a pin, for easy placement.
   
   **Note:** After you placed a pin, the asterisk for the corresponding row disappears.

6. In the Properties window, do the following:
   
   • Enter the symbol name.
   
   • Select a symbol type from the list.
   
   • Leave the Forward PCB value at default (True).
   
   • Add any other properties from the <new property> list.

7. When you are finished, save the symbol.

   **Result:** The local symbol appears in the [Local Symbols] pseudo-partition in the Symbols Window. You can add it to the design like any other symbol.

To edit a local symbol:

1. In the Schematic Window or the Project Navigator Tree, select the symbol

2. Click **File > Edit Local Symbol**

Also See

• *DxDesigner Symbol Editor* manual

• Adding Components
When all sheets of a schematic are at the same level of hierarchy, this is known as a flat, or non-hierarchical schematic. The following figure shows a flat design in contrast with a design that contains hierarchy.

**Figure 4-1. Contrasting a Flat Design With a Hierarchical Design**
The following topics describe how to create and edit flat schematics:

- Returning Schematic to a Prior State
- Creating a New Schematic
- Preparing a Schematic for Design Creation
- Creating Designs Within a Spreadsheet
- Creating Designs Graphically
- Synchronizing a Component With its Associated Base Symbol
- Specifying the Characteristics of Components
- Using Constraints in DxDesigner
- Connecting/Disconnecting Components
- Adding and Editing Ports on a Schematic
- Creating and Editing Nets
- Connecting Components With Busses
- Working Within the Schematic Editor
- Verifying Your Design
- Processing Your Completed Design

## Returning Schematic to a Prior State

DxDesigner includes Backup and Rollback functions to allow you to return a document to a prior state. You can perform a Backup at any time. Rollback returns your document and its constraints to the state of the last Backup. You cannot Rollback a document until you have run Backup at least once.

Backup and Rollback affect only the active document.

**To Backup an active document:**

- Select File > Backup.

**To cause the Backup feature to execute each time you open a project:**

- Turn on Setup > Settings > Advanced (section) > Create automatic backup.

**To Rollback an active document:**

- Select File > Rollback.

## Creating a New Schematic

To create a new schematic, do the following:

- Select the File > New > Schematic pulldown menu item. If the schematic is the first schematic in the project, it appears in the project tree under the Design node as the root.
Creating and Editing Flat Designs

Preparing a Schematic for Design Creation

block. If it is not the first schematic, it appears under the Blocks node. It contains sheet labelled “1” by default.

Once you have created a schematic, you can open it for editing at any time.

To open an existing schematic:

1. In the Project Navigator, click the plus sign + to expand the Project node, and then the Designs node.
2. From the list of designs under the Designs node, double-click the name of the schematic you want to open.

   Note: The navigator tree displays the design hierarchy. You can open any schematic in the hierarchy by expanding the nodes and double-clicking the level you want to edit.

To open an existing schematic from the command line:

- On the command line, enter “schematic schematic_name” and execute the command.

   Note: if you execute the command without a command name, the Open Schematic dialog box appears. Enter the name in the Schematic field.

Opening a Non-DxDesigner Schematic

You can convert other vendor schematic types to DxDesigner format, and then open them in DxDesigner.

To convert a third-party design:

1. From the Windows Start menu, select Programs > Mentor Graphics SDD > DxDesigner-Expedition Flow > Translators and 3rd Party Interfaces.
2. Select the interface or translator you want to use.

Preparing a Schematic for Design Creation

Before you begin your design, you can perform the following optional setup and configuration task:

Editing Schematic Borders

You can edit borders at any time by inserting, deleting, or changing them. You can also edit the values of the default properties assigned to borders.

You must have previously created a border or borders and specified how they will be used. For details on how to create and set up a border, see “Framing a Design with Borders” on page 47.
Creating Designs Within a Spreadsheet

You can use the Interconnectivity Editor (ICE) to create and edit designs in non-graphical mode without the use of the Schematic Editor. You create and edit ICE designs in Interconnectivity Tables (ICTs). This capability requires a separate license.

Creating and Editing an Interconnectivity Table

You use the same toolbar and resources to create and edit an Interconnectivity Table (ICT) as you use to create and edit a schematic. You can create an ICT from scratch, or from an existing schematic. ICT spreadsheets default to listing components in the top row and nets in the leftmost column, as shown in Figure 4-2.

You can reorganize the table to show nets in the top row and components in the leftmost column by clicking the curved arrow icon in the top left cell of the table.

You can also view the net properties and the symbol properties in the ICT viewer in the Net Properties and Symbol Properties tabs. For Net properties, each net is listed on the left while the properties of the nets are listed on top. For Symbol properties, each symbol is listed on the left while the properties of the symbols are listed on top. You can modify the properties on a cell-by-cell basis.

To create an ICT from scratch:

1. Select File > New > Interconnectivity Table. The new ICT appears in the viewing window and its name appears in the Navigator window as Blockn, where n indicates the number of ICTs created during the session.
2. Give the ICT an identifiable name, for example; RLDRAM. There are two methods to rename an ICT:
   - Right-click > Rename on Blockn in the Navigator window.
   - Click twice, slowly, on the Blockn cell in the ICT.

To create an ICT from an existing schematic:

**Note**

You lose all graphical information in the schematic when you convert it to an ICT. This operation is irreversible.

1. In the Navigator pane, place the cursor on the schematic you want to convert to an ICT.
2. Right-click > Change to ICT. A popup window warns that all graphical information will be lost if you proceed.
3. Select Yes in the popup window.

### Placing Components

To place components in the ICT:

1. Select View > Symbols to open the Symbols addin.
2. Select the Symbol View tab.
3. Select a symbol from the list. A graphical representation of the symbol appears in the symbol view pane.
4. If you want to automatically add nets and net names while placing the symbol in the design, click the Add Nets and Add Net Names check boxes in the Symbol View pane. You cannot select Add Net Names unless you have first selected Add Nets.

**Figure 4-4. Adding Nets and Net Names Automatically**

![Figure showing symbol view and ICT with options for adding nets and net names](image)

**Note**: If a symbol has any pins without net connections, a red circle with a yellow x appears on the ICT icon for the symbol. When all pins on a symbol have net connections, the ICT icon appears without the red circle/yellow x overlay.

5. Click the **Place Symbol** button above the Symbol View pane.

6. Click the main cell in the ICT (the Block cell, which you may have renamed) to place the symbol. Click multiple times to place multiple instances of the symbol.

7. Right-click to quit the Place Symbol function.

**Note**: You can also drag and drop from the Preview symbol window to place a single instance of the symbol into the table. You can drop the symbol on any icon in the component row at the top of the ICT.

**Renaming Components**

You can rename components in place in the schematic, and by editing the component properties.

**To rename a component in place:**

1. Double-click, slowly, on the component name in the table.
2. Enter the new name.
To rename a component in the component properties:

1. Right-click > Properties on the component you wish to rename.
2. In the properties window, click the cell to the right of Name.
3. Enter the new name.

Adding Nets to Pins

You can add nets to pins either manually or automatically and manipulate them as described in the following topics:

- Adding Nets Automatically
- Adding Nets Manually
- Adding Nets with Advanced Connect
- Sorting Nets
- Renaming Nets

Adding Nets Automatically

You can add nets to a symbol automatically when you copy a symbol from the Symbol window to the ICT.

To add nets automatically when placing the symbol:

- Select the Add Nets option at the right end of the Symbol View pane. You can also select Add Net Names, but only after you have selected Add Nets. When you select these options, the symbol appears in the ICT with nets already connected and named.

If you did not select the Add Nets option, you can add nets to pins later, either automatically, or manually.

To add nets to pins automatically after placing the symbol:

1. Select the symbol or symbols to add nets to. Click on a single symbol, or <Shift>-click to select multiple symbols.
2. Right-click > Add Nets To Pins.

This procedure creates nets in the ICT, and connects them to the symbol pins. Warnings appear in the Output window for already existing nets. Cross probing is enabled between the Output window and the table.

Adding Nets Manually

You can manually add nets to pins either one net at a time, or multiple nets at a time.
Creating and Editing Flat Designs
Creating Designs Within a Spreadsheet

To add single nets manually:

1. Double-click in the cell corresponding to the pin you want to connect to get a dropdown list of the unconnected pins.

2. Select a name from the dropdown list, type in a name, or copy and paste an existing net from elsewhere in the ICT. If you enter an invalid name, a warning appears in the Output window.

**Note**

Copying and pasting is an efficient way to connect symbols. You can copy and paste components, component pins, and block pins.

To add multiple nets manually:

1. Click in the appropriate cell to select the first of the bits you want to add.

2. Enter a name, or select a name from the dropdown list.

3. Click the small tab in the bottom right corner of the cell (the cursor turns to a plus sign when you are over the tab), and drag it down to envelope the rest of the cells you want to add. Bits are added to each cell, and the bus index increments automatically.

**Figure 4-5. Dragdown Tab for Adding Multiple Nets**

Adding Nets with Advanced Connect

The Advanced Connect tool allows you to connect, by name, multiple components with common pins. From the Advanced Connect dialog, you can:

- Rename nets (which you can’t do from the Add Nets to Pins command).
- Select nets by clicking and dragging, as in the ICT.
- Automatically add hierarchical ports

**To use the Advanced Connect tool:**

1. `<Shift>`+click or `<Ctrl>`+click to select the components you want to connect.
2. Right-click > Advanced Connect on one of the selected components, or select Edit > Advanced Connect. This opens the Add nets with ports dialog box.

3. Select the nets you want to connect in the dialog box.

4. Select the type of net you want to view from the Directions filter dropdown list.

5. Click Generate Nets, then OK.

**Sorting Nets**

You can sort nets by name, hierarchy, or type; single net, bus or differential pair, for example. To sort nets, do the following:

1. In either the nets (the leftmost) column or the component (the top) row, Right-click > Sort.
2. Select the sorting method from the list.

**Renaming Nets**

**To rename a net in a cell:**

1. Double-click in the cell.
2. Type in the new name.
3. Click elsewhere in the window, or press Enter.

**To rename a net in the Properties window:**

1. Right-click > Properties on the net you wish to rename.
2. In the Properties window, click the cell to the right of Name.
3. Enter a new name or select a name from the dropdown list.

**Grouping and Ungrouping Rows and Columns**

You can group rows and columns and enter a group name in the ICT to help keep track of connections.

**To group rows or columns:**

1. In the nets (the leftmost) column or the components (the top) row, select the rows or columns you want to group. Use the <Shift> and <Ctrl> keys to make multiple selections.
2. Right-click > Group.
3. Enter a meaningful name for the group in place of the supplied default name, if desired.

   The group name cell is the only cell visible after you group a set of rows or columns.

**To view the contents of the group:**

- Click on the plus (+) sign to the left of the group name.

The placement of rows and columns in an ICT is arbitrary. Pressing the button with the curved double-headed arrow in the upper left corner of the ICT reverses the layout of rows and columns.

**To ungroup rows or columns:**

1. Select the rows or columns you want to ungroup. Use the <Shift> and <Ctrl> keys to make multiple selections.
2. Right-click > Ungroup.

The selected items are removed from the group. If all of the items in the group are selected and ungrouped, the group is deleted.

**Adjusting Row and Column Width**

You can manually adjust the width of rows and columns in one of the following ways:

- In the topmost or leftmost column, place the cursor over the right-side delineator of a cell, and double-click. The cell automatically resizes.
- In the topmost or leftmost column, place the cursor over the delineator between cells, then click and drag to the new width.
- Right-click > Autofit Selection to adjust column width to fit the text in the column.

**Hiding Rows and Columns**

You can hide multiple rows and columns to let you focus on areas of interest.

**To hide a row or column:**

1. Select the rows or columns to hide. Use the <Shift> and <Ctrl> keys to select multiple rows or columns.
2. Right-click > Hide. An icon of a spreadsheet appears in the upper left cell of the ICT to indicate that rows and columns are hidden.
To reveal hidden rows and columns:

1. Right-click > **Show Hidden** on the “hidden” icon in the upper left corner of the ICT. Hidden rows and columns appear with their names in italics.
2. Right-click > **Unhide** on a row or column to take it out of the hidden state.

**To unhide all of the hidden rows and columns in the ICT at once:**

- Right-click > **Unhide All** on the icon in the upper left corner of the ICT.

### Adding Ports to the ICT

Connections to the outside of the ICT are referred to as ports. You can add ports to the ICT singly or in groups. If nets of the same name already exist, a warning occurs. There are two modes for adding ports:

- A net is selected — When you apply the **Add > Port** command, the port is added to the net. There is no need to enter a net name. This also works for busses.
- No net is selected — You get an entry box to type the name of the port in. If a net of the same name already exists, they are automatically connected.

**To add ports:**

1. Select **Add > Port** or click the button.
2. Select the port type from the dropdown list. A small black arrow appears near the block symbol to show that ports have been created.

### Viewing Ports

**To view ports:**

- Click on the arrow next to the block symbol to expand the block interface to show the net connections. An icon of a black square with a horizontal line through it depicts the net connections.

### Connecting or Disconnecting Ports

**To connect or disconnect ports:**

- Click on the net connection button to disconnect or reconnect the port to a net.
Adding a Block

A block can be a mixture of ICTs and schematics across the entire hierarchy. The Interconnectivity Table editor is a hierarchical editor. You can use the Add > Block command to create ports dynamically. The new block is generic; the Push command decides its type:

- **Push ICT** places an interconnectivity table under the main block. The icon for an interconnectivity table is 🔄.
- **Push Schematic** places a new schematic page under the main block. The icon for a schematic is 🎨.

You can also copy a block within or between designs.

**To copy a block with a project,**

1. In the Project Navigator Tree of the source project, select the block you want to copy.
2. Right-click > Copy.
3. Open another sheet in the same project.
4. In the Project Navigator tree, select the Block Node.
5. Right-Click > Paste.

**To copy a block to a different project:**

1. In the Project Navigator Tree of the source project, select the block you want to copy.
2. Right-click > Copy.
3. From the File menu, click Open > Project
4. DxDesigner warns you that it is closing the source project. Click OK. The destination project opens.
5. In the Project Navigator Tree of the destination project, select the Block node.
6. Right-Click > Paste.

**To add a block:**

1. Click on the block that is above the one you want to add.
2. Select Add > Block.
3. Type in the desired name for the block. (You can edit the name without clicking it when it first comes up.)
4. Right-click > Push ICT or right-click > Push Schematic. The push command displays the design (schematic or ICT) that underlies the block.
Connecting Nets to the Block

To connect a net to a block:

1. Double-click on the ICT cell corresponding to the net you want to connect, to get the pin type drop-down list.
2. Select the pin type from the drop-down list. Pin types include IN, OUT, BI, TRI, OCL, OEM, and ANALOG. After you choose a pin type, the ICT updates automatically to show the connections.

To connect multiple nets to a block:

1. Click and drag to include all of the cells you want to connect. One of the cells in the group will have a different color than the rest.
2. Click in the different colored cell to get the pin type drop-down list.
3. Select the pin type from the drop-down list.

Creating and Removing Differential Pairs

The differential pair command is available only when the nets are either not connected, or are connected between blocks. Differential pairs created in ICT automatically appear in the Constraint Editor System (CES).

To create a differential pair:

- Right-click on the net and select Create Diffpair. Create Diffpair creates the second net in the pair automatically, and adds the extensions _p and _n to the nets in the pair.

To remove a differential pair:

- Right-click on a differential pair, and select Revert From Diffpair.

Creating and Ripping a Bus in an ICT

To create a bus:

- Select Add > Bus.

To rip a bus, or a subset of nets in the bus:

1. Click on the bus.
2. Right-click > Rip Nets. The bus name shows up in an editable row.
   - To rip all nets, press Enter.
Creating and Editing Flat Designs

Creating Designs Within a Spreadsheet

- To rip a subset of nets, enter the list of nets in place of the bus name, in the format; busname# busname#. For example; to rip nets 0, 1, 6, and 7 of a bus named DAT[0:7], enter DAT0 DAT1 DAT6 DAT7.

If you add nets in the table, and create a bus later, the bits are concatenated into the bus automatically. For example; if you add nets xxx0, xxx1, and xxx6 to the table, and later use the Add Bus command to create xxx[0:7], the table will show:

```
xxx[0:7]
xxx0
xxx1
xxx6
```

Splitting an Interconnectivity Table

You can split an interconnectivity table horizontally or vertically when it becomes too large to view easily.

**To split an interconnectivity table horizontally:**

1. Locate the handle at the top of the vertical scrollbar. The handle is a small rectangle just above the up arrow at the top of the scrollbar.
2. Click-and-drag the handle down. A horizontal separation bar appears in the table to indicate the split.

**To split an interconnectivity table vertically:**

1. Locate the handle at the left end of the vertical scrollbar. The handle is a small rectangle just to the left of the left pointing scrollbar arrow.
2. Click-and-drag the handle to the right. A vertical separation bar appears in the table to indicate the split.

**To recombine the table and remove the separation bar:**

- Click on the separation bar, and drag it up (for a horizontal separation bar) or to the left (for a vertical separation bar) until the bars merge.

Setting Color Preferences

You can use different colors to indicate different ICT block, component, or symbol types.

**To apply a color to a specific type of object:**

1. Select Setup > Settings > Display Objects to open the Objects table.
2. Select the ICT option to see the current color scheme.
3. Click on any cell in the Objects table to bring up a color pallet for the object associated with that cell.
4. Select a color for the object from the color pallet.
5. Click Apply.

Note
To save the changes for future use, click Save Scheme. Reload a saved scheme by clicking Load Scheme.

Related Topic
- Display - Objects - Settings Dialog in the DxDesigner Reference Manual

Using the Interconnectivity Table Viewer

The interconnectivity table (ICT) viewer allows you to look at a schematic in tabular form, without permanently converting it to tabular form. However, you cannot edit the table when using the ICT viewer. ICT viewer is available to all users and does not require a license.

To use the ICT viewer:

1. Open up a schematic.
2. Select View > ICT Viewer.
3. Select the appropriate viewing tab:
   - Hierarchy — View the entire schematic in tabular form.
   - Net Properties — View the schematic’s nets in tabular form.
   - Symbol Properties — View the Schematic’s symbols in tabular form.
4. Use the dropdown arrows in the top row of table cells on each tab to filter selections on the tab to view the specific information you are interested in. To return the table to its original state after filtering, click the reset icon in the upper leftmost cell of the table, then click Reset All Filters.

Creating Designs Graphically

You build schematics by doing any of the following tasks:

- Adding Components
- Adding and Replacing Power/Ground Pins
Adding Components

You use the Symbols dialog box to add components to a design. The Symbols dialog box consists of three tabs. You select a tab based on how you want to view the information.

- **The Part View tab**: Items in the Part View tab are PDBs (or parts) that contain symbol, cell, and padstacks (including pads and hole) data in one package. Parts are normally used to create or edit designs with both logical (electrical) and physical (footprint) characteristics.

- **The Symbol View tab**: Items in the Symbol View tab are symbols only. There is no cell or padstack data associated with them. Symbols are normally used to create or edit designs with logical (electrical) characteristics only. In addition, you can use symbols as a basis to build and create a new part.

- **The Reuse Blocks tab**: Items in the Reuse Blocks tab are entire designs that can be treated as a single component when placed in your project.

**Note**
When a .prj file in DxDesigner is mapped to a central library, the entries in the Partition column (in both the Part View and Symbol View tabs) match those that appear in Library Manager (Parts and Symbols entries in the library navigator tree).

To place a symbol on a schematic:

1. Open the Symbols dialog box with the View > Symbols pulldown menu item.
2. Filter the window for the symbol you want to add.
3. Select the symbol. The symbol appears in the view window to the right of the Symbols window. Cells and alternates preview also appear when relevant.
4. To place one instance of the symbol, drag the symbol from the view window to the schematic and click where you want to place the symbol.
5. To place multiple instances of the symbol, click the Place Symbol button followed by a click on each location on the schematic where you want that symbol to appear.

**Filtering the Symbol List**

You filter the symbol list to present only those symbols you are interested in.

**To filter the symbol list:**

1. Click Clear Filters to remove previous filter criteria.
2. Select a tab.
3. The filter fields correspond to the list columns directly below them. Enter all or part of the information you want to filter on in the appropriate field. For example, if you want to filter for all parts beginning with CC0, type CC0 in the Part field of the Part View tab.

**Tip:** the filter supports * and ? wildcards.

**Related Topics**

- For more information on Reusable Blocks and the Reuse Blocks tab of the Symbols dialog box, see “Placing a Logical-Only Reusable Block in a Host Design” in the Reusable Blocks Process Guide, and “Symbols Window” in the DxDesigner Reference Manual.
- You can also add symbols from the DxDataBook and DMS. For more information, see the DxDataBook User’s Guide, and the DMS Librarian User’s Guide.

**Adding and Replacing Power/Ground Pins**

Power/Ground pins are one type of special components. When you configure special components, you create a list of components (such as power and ground pins) you want available to place on your schematic.

**Requirement**

You have previously configured Specialized Components. See “Configuring Special Components” on page 55 for instructions.

**Procedures**

**To manually place a pin on the schematic:**

1. Select **Add > Power** (or click ![Power Symbol]) or **Add > Ground** (or click ![Ground Symbol]). A list appears of all the choices available for a given type such as Basic:power.1, Basic:vbb.1, etc.

2. From the list, select the pin you want to place.

3. DxDesigner automatically attaches the pin to your cursor. Drag and drop it onto a component or net. You can add multiple copies of the component. When you are finished, press the <ESC> key.

**Tip:** If you have only provided one symbol for the pin type during setup, the pin is automatically attached to the net you selected, and you are in drag mode with the component and net.

**To automatically attach a pin to an existing net:**

Use the following procedure to attach a pin to an existing net that has only one unconnected point.

1. Select the net to which you want to attach the pin.
Creating and Editing Flat Designs

Synchronizing a Component With its Associated Base Symbol

2. Select **Add > Power** or **Add > Ground**.

   **Tip:** If you have only provided one symbol for the pin type during setup, the pin is automatically attached to the net you selected.

   **Result:** The pin is automatically attached to the net you right-clicked.

**To replace power/ground pins**

1. Position the cursor on the pin you want to change.
2. Right-click > **Change**. A list of available, matching, components appears.
3. Select the component you want to substitute.

Synchronizing a Component With its Associated Base Symbol

DxDesigner symbols are stored in the Central Library. Only Central Library symbols can be edited. When a Central Library symbol is first placed on a schematic, a copy is placed in a local project “symbol cache”. All subsequent instances of the symbol are take from the cached copy.

If a Central Library symbol changes, the equivalent components may need to be updated to reflect the changes. DxDesigner checks design components against their base symbols upon startup, or when you reload a schematic. All components whose symbols have changed are highlighted in pink. You can then choose to update the components with the new symbol definition. When you are finished updating, the highlights are cleared.

**To update all components whose symbols have changed:**

1. Select **Tools > Update Symbols** or (right-click on any symbol) > **Symbol Update > Update Symbol**.
2. In the Component Definition Update dialog box, select the desired symbol(s) you want to update, and click **OK**.

   **Result:** The highlights on all schematic sheets with updated selected symbols are cleared.

**To clear all highlights:**

1. Select any symbol on the sheet.
2. Right-click > **Symbol Update > Clear All Highlights**.

   **Result:** The highlights on the current sheet are cleared for the remainder of this DxDesigner session.
Specifying the Characteristics of Components

You define logical component characteristics using properties, and physical design rules using Constraints.

When constraints mode is enabled for a design, you can assign constraints defined within classes to nets, components, and differential pair nets on a schematic.

For more information, see the following topics:

- Adding and Editing Properties
- Setting Up Constraints in CES
- Handling Mechanical Parts
- Handling Test Points

Adding and Editing Properties

Existing pre-EE2007 DxDesigner attributes are replace by Expedition Enterprise properties during project conversion. For more information, see Converting DxDesigner Attributes to Expedition Enterprise Properties in the DxDesigner Administrator’s Guide.

In an Expedition workflow, you create new properties using the Library Manager Property Definition Editor. For more information see the Property Definition Editor in the Library Manager Process Guide.

In a Netlist workflow, you can create and edit properties with the Property Definition Editor from the Tools > Property Definition Editor menu. For more information see “Using the Property Definition Editor - Netlist Workflow” on page 81.

When you instance a symbol on your design, you can select which of the symbol properties to use for the instance, then add or edit them within DxDesigner using the Properties window. The Properties window can be toggled on and off by selecting the View > Properties menu item or clicking the button. You can also display the Properties window by double-clicking an object or you can select an object and right-click Properties.

Property and value visibility is controlled by the following order of precedence, with “1” having the highest precedence and “3” the lowest:

1. Schematic level settings
2. Symbol level settings
3. Property Definition Editor level settings

With the Properties window you can assign names to schematics, sheets, properties, nets, and busses, using the following rules:
• Name strings can consist of any characters except the following: < > ’ , () = \.

• Name strings cannot contain spaces.

For editing purposes, there are three types of properties. The rules for editing them are different as described in Table 4-1.

### Table 4-1. Property Editing Rules

<table>
<thead>
<tr>
<th>Property Type</th>
<th>Example</th>
<th>Editing Actions Allowed</th>
</tr>
</thead>
<tbody>
<tr>
<td>Symbol Property</td>
<td>Partition</td>
<td>• Change Values</td>
</tr>
<tr>
<td>• Added by the librarian to the symbol</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Instance Property</td>
<td>Description</td>
<td>• Change values</td>
</tr>
<tr>
<td>• Added by the user to the instance</td>
<td></td>
<td>• Delete</td>
</tr>
<tr>
<td>System Property</td>
<td>Id</td>
<td>• None</td>
</tr>
<tr>
<td>• Added by the tool</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Related Topics**

• Changing Between Floating and Docked Window Types

**Procedures**

**To add a property:**

1. If the Properties window is not visible, double-click the object you want to add the property to.

   **Tip:** You can select multiple objects using the <Ctrl> key.

2. Click the empty box at the bottom of the Property column (see figure below). A list of available properties appears.

   ![Property Window](image)

   Click in this area

3. From the available list (created from the Property Definition Editor), select the property you want to add.
4. In the associated columns, enter the value and, optionally, instance value you want to assign to the property.

**To change a property or name value visibility status:**

- In the Properties window, select or clear the checkbox in the Property or Value field.

**To change the value of a property:**

- In the Properties window, click on the desired property value to select it and type the new value.

**To delete editable properties:**

- In the Properties window, move the cursor over the desired property and right-click > Delete Property. Visibility may need to be turned off before the delete can happen.

**Parameterized Properties**

A parameterized property has a variable value field. You use parameterized properties to specify values that change in the design. The following parameterized properties are supported. For more information, see the *DxDesigner Properties Glossary*.

- @NAME
- @SHEET
- @PATH
- @SHEETTOTAL
- @XYCOORD

**Using the Property Definition Editor - Netlist Workflow**

To invoke this editor from DxDesigner in a Netlist workflow, select **Tools > Property Definition Editor**.

Use the Property Definition Editor to define the available properties and their format in a central library. Use this editor to define new properties, define property types and their associated syntax, and change certain aspects of pre-defined system properties. The values of the properties are stored on the data objects and are not defined in the Property Definition Editor.

User-defined properties are used to add custom information to symbols and parts from DxDesigner. When saved, the Property Definition Editor writes all properties to the central library property definition file.
Note
System properties cannot be deleted, and user-defined properties are not used by simulation tools.

User properties (created using the Property Definition Editor) are assigned a unique property number. However, when using the compiler on a schematic design that contains user properties, the user property numbers that appear in the generated ASCII file are different than what appears in the Property Definition Editor.

Example: Property Definition Editor software assigns “UserProp1” with a Property Number of 224. However, after using the compiler and generating an ASCII file, “UserProp1” appears in the file with a randomly assigned property number. Therefore, refer to the property name (or “Property Value”) in the ASCII file and ignore the property number assigned to user properties. Property numbers assigned to System properties are unaffected.

Creating a User-defined Property

1. Click Tools > Property Definition Editor. The Property Definition Editor dialog box appears.
2. Click the Advanced button. The dialog box expands to display settings and options associated with the selected property in the Property List.
3. Click the New Property icon . The software places a new entry at the bottom of the list (New Property1).
4. (Optional) Click the Name header to alphabetize the list of property names in the Property List. The list of property names now appear in alphabetical order.
   Tip: If you click the Name header again, the list of property names would appear in reverse alphabetical order. Click on any column header in the Property List to sort entries in the list.
5. Enter a property name and select a format from the dropdown list. The available options are; Character String, Integer or Real.
6. Select the check box if you want to place the property in the schematic when Packager is used.
   Packaging can assign properties from the part entries to a symbol in the schematic. For example, if a check is placed next to the System - Cost option (you click OK or Apply), this enables the software to place selected properties in a schematic during the packaging process or when you use the Place Device command to place a device in a schematic file.
7. Use keyin fields and options in the “Options applied in Design Entry” section of the dialog box to set up all the options that are available in the appropriate property definition file. Regular expression options can be built up from single-characters. For
more information see the table titled Regular Expressions Used by Property Definition Editor in the DxDesigner Reference Manual.

8. Attach the selected property by placing a check against one or all of the following: Symbol (default), Pin, or Net.

9. Include the selected property in the property lists for Design Entry (selected by default).

10. Select the “Ignore notation settings when displaying property value” checkbox to ignore the notations settings. This option is only active when the property format is set to Integer or Real. For example, 0.01 could be displayed as 10m if the option is selected. If the checkbox is not selected, 0.01 would display.

11. (Optional) Click the Import button to Import properties from a file using the Import Properties From File dialog box.

You can import properties from either design entry or Parts Database by selecting the appropriate property file name with an extension of .prp. Once you have selected a property file, the available properties within that file are displayed.

a. Select the properties you want to import.

b. Click Apply to display the selected properties in the Property List of the Property Definition Editor and continue the display of the Import Properties from File dialog box or click OK to dismiss the dialog box and return to the Property Definition Editor. Click Cancel to terminate the operation without updating the Property List and return to the Property Definition Editor dialog box.

12. Click Apply to save changes incrementally to the Property Definition Editor without dismissing the dialog box. Click OK to save changes in the Property Definition Editor dialog box to the CentLib.prp file associated with the central library. Click Cancel to dismiss the Property Definition Editor dialog box without saving changes since the last Apply.

Handling Mechanical Parts

The “Forward To PCB” property described in this topic only works for designs created with the Expedition workflow.

A mechanical part, such as a socket, bolt, nut, etc. has no electrical significance, and should not appear in the PCB netlist, but may be placed on the schematic for inclusion during the Part Lister process.

To control whether a component is forward annotated to the layout tool:

1. Right-click the desired symbol on the schematic and choose Properties from the pulldown menu.

2. In the Properties window, locate the “Forward To PCB” row in the Property column.
3. In the “Forward To PCB” row, click the Value column as shown in Figure 4-6. A drop-down list appears. You can choose to set this property on the selected component to one of the following:

   a. **Inherit From Definition** - This causes the Forward Annotation process to use the setting defined in the symbol definition (either True or False)

   b. **True** - Ignore the setting in symbol definition and Forward Annotate this component.

   c. **False** - Ignore the setting in symbol definition and do not Forward Annotate this component.

![Figure 4-6. Forward To PCB Property Example](image)

### Handling Test Points

A testpoint is a part that indicates the point of entry for a testing machine. Testpoints should appear in the PCB netlist, since they show electrical constraints that must be noted by manufacturing. However, you may wish to prevent them from showing up in the Part Lister output.

**To exclude a particular component from appearing in the Part Lister output:**

1. Right-click the desired symbol on the schematic and choose **Properties** from the pulldown menu.

2. In the Properties window, click the blank field at the bottom of the Property column as shown in Figure 4-7.

3. Locate and select the “Part List Exclude” property (see Figure 4-7). The property is added to the top of the Properties window list for the selected component.
Using Constraints in DxDesigner

In an Expedition workflow design, you assign and edit constraints in CES, which you can open from DxDesigner.

**To open CES from DxDesigner on an Expedition workflow design:**

1. In the Navigator, position the cursor over the design name
2. Right-click > Constraint Editor System

For more information, see the Tool Access From Within the Flow topic in the Constraint Editor System (CES) User’s Manual for Expedition Enterprise Flow (DxDesigner).

In a Netlist workflow design, you can view and edit existing constraints using the View > Other Windows > Constraints window.

Connecting/Disconnecting Components

Once you place components on a schematic, you can connect them using nets and busses. After connecting a component you may wish to move it. It could be helpful to disconnect the component first before moving it.

The following topics describe ways to manage the connections:

- Routing Modes
- Creating Intersecting Connections
Creating and Editing Flat Designs

Connecting/Disconnecting Components

- Creating Dangling Connections
- Automatically Creating Connection by Net Label Names
- Disconnecting a Component

Routing Modes

All connectivity is formed in DxDesigner with the specification of a routing mode. You construct a net or a bus under a specified routing mode that assists with determining the optimal route path.

To set or change the routing mode for a project:

1. Select **Setup > Settings > Schematic Editor** (section) > **Nets** (subsection)
2. In the Route Mode options section, select one of the following modes:

   - **Straight**
     
     Straight routing specifies a straight connection between two points. This “as is” form of routing can overlap or pass through components and existing connections. Any incidental crossing of nets from straight routing does not imply a connection, and does not create a solder dot.

   - **Orthogonal**
     
     Orthogonal routing begins with a horizontal or vertical orientation depending on the point of origin as follows:
     
     - From a joint — begins in a horizontal or vertical direction following the cursor movement (left or right, horizontal — up or down, vertical)
     - From a pin — automatically begins in a horizontal or vertical direction, depending on the orientation of the pin
     - From a point on a net or bus segment — begins in a direction perpendicular to the orientation of the segment

     **Note:** Orthogonal routing does not allow a connection to pass through a component.

   - **Avoidance**
     
     Avoidance routing specifies an automatic connection between two points that avoids components. Specifying intermediary points along the connection creates a more distinct specification of the path of the connection.

     The distance between components and the connection is the avoidance distance. DxDesigner automatically staggering a connection by the avoidance distance as the route hugs to the components or other connections.
Related Topic

- Nets -Schematic Editor - Settings Dialog in the *DxDesigner Reference Manual*

Creating Intersecting Connections

DxDesigner creates intersecting connections automatically, and denotes them with a solder dot. Two nets that cross make a connection only if a round solder dot appears at the crossing. Any incidental crossing of nets or busses from schematic edits does not imply a connection.

You configure intersecting connections by setting the following:

Setup > Settings > Advanced (section) > Dot Size (option)

Creating Dangling Connections

DxDesigner creates dangling connections automatically when you draw a net that does not connect to a pin or another net. DxDesigner denotes dangling connections with a square box at the end of the net.

To connect dangling nets to components:

- Click on the dangling net box while the Add Net command is activated. You can then stretch the dangling net by dragging the box until it intersects a component pin

To maintain dangling connectivity when you delete a component:

- Hold down the <Ctrl> key when you select Delete from the Edit menu (or from the popup menu).
- Use the Edit-Delete Special command from the DxDesigner menu.

Automatically Creating Connection by Net Label Names

Any two nets on a schematic that have the same label are automatically connected. That is, they are the same net. This is true even if the nets are located on different pages of the schematic. No special off page or on page connector is required to connect nets with the same label on different pages. This is true for all nets with local scope. Nets with global scope will be connected if they are named the same and located on any sheet, and also if they are located under any hierarchical block.

Disconnecting a Component

To aid in moving a component after it has been connected, it might be helpful to first disconnect the component from attached nets and busses.
To disconnect a component from a schematic:

1. Click on the component to select it.
2. Disconnect the component by selecting Edit > Disconnect or clicking 

Adding and Editing Ports on a Schematic

The following topics describe working with ports on a schematic:

- Propagating Ports
- Adding Missing Ports
- Replacing Ports

Propagating Ports

DxDesigner automatically adds a port on a selected net, including power and ground nets, provided the selected net is connected at one end. DxDesigner also provides top-down automatic port insertion. Drawing nets to a block creates pins on the block. The ports corresponding to those pins are then propagated down via the Push Schematic tool.

To propagate ports:

1. Click in the block to select it.
2. Right-click > Push Schematic.

Using the Push Schematic tool has the following results:

- Ports are added to lower schematic levels
- Location and relative spacing on the block symbol are preserved.
- By default, port direction depends on the side of the block to which the net connects:
  - Left side: input
  - Right side: output
  - Top/Bottom: bidirectional

Adding Missing Ports

To update the ports list at the block level, or to insert ports on additional sheets:

1. Select the block or sheet.
2. Select Add > Missing Ports to update the ports list.
Replacing Ports

Because a port is a type of symbol, you replace a port using the Replace Symbol/Part dialog box. For more information, see Replacing a Symbol or Part.

Creating and Editing Nets

Use nets to create connections between component pins, from a single component pin to a net or bus, or between nets or busses. A net is not the same as a line. A line is only graphical; a net carries a signal, and represents an electrical connection. You can construct a net with one or more segments. If a net has more than one segment, DxDesigner indicates the segment endpoints by joints at the net vertices.

The method you will likely use to create nets depends on the number of connections you want to make.

- Creating and Editing Nets Using the Schematic Editor - for small designs or to connect low pincount components
- Adding Nets to Pins
- Merging Nets
- Establishing Connectivity in Multi-Sheet Designs
- Creating Differential Pairs Automatically
- Inserting a Serial Component on a Net

Also see

- Connecting Components With Busses

Creating and Editing Nets Using the Schematic Editor

Requirements

You must set up the routing mode for nets in your project. For information on setting up routing modes, see “Routing Modes” on page 86.

Procedures

To set or check default display characteristics for nets:

1. Select Setup > Settings > Display (section) > Objects subsection.
2. In the Object column, locate the Net type in the list.
3. For net Color, Fill Style and Line Style, click in the box and use the pulldown list to choose a value.
4. The Width column controls the displayed thickness of the net on the schematic. Enter a value from 1 to 10.

5. Click OK.

**Result:** These settings will be the default display characteristics for all nets.

**To add a net to the active schematic:**

1. Select **Add > Net** or click ![Net](image) from the object toolbar or type “net” on the command line.

2. Click the left mouse button at the origin point of the net.

   **Note:** By default, nets do not need to begin at a component pin or at an existing net. To change this default, select **Setup > Settings > Advanced**, and then clear the Begin Nets in Space checkbox.

3. Drag the mouse to form the net. You can specify vertices (intersections of net segments) along the net by clicking the space bar while dragging. The current routing mode determines how the connection is formed.

4. Release the left mouse button to specify an end point for the net.

**To over-ride the default display net width setting for an individual net:**

1. Once you have drawn a net, be sure it is selected and the Properties window is open.

2. In the Properties window, locate the Line Width property.

3. Click the Value box. A pulldown list appears.

4. Choose the desired line thickness value (1 - 10) from the pulldown list to reset the displayed net width.

**To delete a net:**

- Select the net you want to delete and press <Delete>.
  - If the net you want to delete has more than one segment, do one of the following
    - press <Ctrl> + select the segments you want to delete, then press <Delete>.
    - Drag-Select all the segments then press <Delete>.
    - Select and delete segments individually.

**To rename a net:**

1. Double-click the net.

2. In the Properties Editor, enter the new name.
Creating Global Nets

Global nets establish global connectivity, usually for power supply nets, but they can also be used for global clock signals. Global nets have a property of Global Signal Name. Nets attached to components with a Global Signal Name property inherit a Net Name of the same value as the Global Signal Name property. To create a Global Net:

1. Select **Add > Power** or **Add > Ground**.
2. Click in the schematic where you want to place the symbol for the global net. (You can click multiple times to place multiple instantiations of the symbol.)
3. Right-click to return the cursor to a pointer.
4. In the Properties window, click in the cell to the right of Global Signal Name and enter the value for the Global Signal Name. By default, the Power symbol value is VCC, and the Ground symbol is GND.

Aliasing Nets

You assign names to nets using the Name property. In DxDesigner, nets with the same name are connected, even if they appear on different sheets. That is, all nets with the same name are actually the same net. However, you might want to connect nets with two different names while preserving the original net names. This is called net aliasing.

The following are examples of net aliasing.

**Note**

Although you can use net aliasing in all three of the examples below, only the first is recommended.

- You have migrated a project to DxDesigner from another tool that uses net aliasing. DxDesigner net aliasing allows you to duplicate the behavior of the other tool.
- Given a bus named A[0:7], you want to rip a net from bit 7 and attach it to a net named C without changing the name of either net. You alias net A7 to net C.
- You want to connect two power nets while leaving their individual names intact.

**To alias two nets:**

**Requirement:** You have already assigned a value to the Name property for each net. For more information, see Adding and Editing Properties.

1. Double-click one of the nets you want to alias together. The net’s Properties dialog box opens.
2. Change the value of the Name property to include the name of both nets to be aliased, using the following syntax:

\texttt{firstnetname|secondnetname}

Where the delimiter is the vertical bar or pipe character.

**Results:**

- In the navigator, the two nets are replaced by one net named \texttt{firstnetname,secondnetname}.
- On the schematic, the selected net displays the new name \texttt{firstnetname|secondnetname}, and the unselected net retains its original name.

**Merging Nets**

DxDesigner supports merging nets. It is possible that you need to connect two nets that have previously been named. A Net Short dialog box informs you that two nets have been shorted, and gives you the option of which net name to use for the combined net as shown in the following figure:

![Figure 4-8. Net Short Dialog Example](image)
Establishing Connectivity in Multi-Sheet Designs

You use special onsheet/offsheet pin components to show that a net traverses multiple sheets in a flat design.

Prerequisite

You have configured Onsheet/Offsheet pins. (See “Configuring Special Components” on page 55.)

Adding Onsheet/Offsheet Pins

When you add an Onsheet/Offsheet pin, you can either place the pin on the schematic with an attached net, or attach it to an existing net.

To manually place a pin on the schematic:

1. Select Add > Onsheet (or click ) or Add > Offsheet (or click ). A list appears of all the choices available for a given type such as Basic:con_offsheet.1, Basic:new_offsheet.1, etc.
2. Select the pin you want to place from the list.
3. DxDesigner automatically attaches the pin to your cursor. Drag and drop it onto a component or net.

   Tip: If you have only provided one symbol for the pin type during setup, the pin is automatically attached to the net you right-clicked, and you are in drag mode with the component and net. If you have provided more than one symbol, a dialog box opens. In the dialog box, select the pin symbol you want to attach. Pins that have already been used are indicated in italics.

To automatically attach a pin to an existing net:

Use the following procedure to attach a pin to an existing net that has only one unconnected point.

1. Select the net to which you want to attach the pin.
2. Select Add > Onsheet or Add > Offsheet. DxDesigner automatically attaches the pin to the net you selected.

   Tip: If you have only provided one symbol for the pin type during setup, the pin is automatically attached to the net you right-clicked. If you have provided more than one symbol, a dialog box opens. In the dialog box, select the pin symbol you want to attach.
Creating Differential Pairs Automatically

To create differential pairs automatically and dynamically:

1. Double-click on a net or bus to view its properties. (See the figure below.)
2. In the cell to the right of the **Diff pair** property, either use the drop-down list to select the name of the second pair element or enter it manually.

   **Hint:** If the names in the drop-down list are too long to read, expand the Value column.

   ![Diagram](image)

   **Note**

   The differential pair Property of the other net is updated automatically. You don’t have to enter the information twice.

To view the diff pair in CES:

1. Select **Tools > Constraint Editor System** to open the Constraint Editor System (CES).
2. In the CES Navigator window, click on the plus (+) sign to expand Constraint Classes, then the plus (+) sign to expand All. (See the figure below.)
3. Double-click on Diff pair, and scroll down to view the differential pair you have created. (The list is arranged alphabetically.)

Inserting a Serial Component on a Net

Inserting a component in series with an existing named net brings up a Split Net dialog box. This dialog gives you options to either keep the existing net name for one side of the split net, or throw out the name. Figure 4-9 shows an example of using the Split Net dialog.

**Figure 4-9. Split Net Dialog Example**

1. Insert a series component into the net.

   The Split Net dialog appears with one side of the split net selected. In this case, the left-side net segment is selected.

2. It is desired to keep the current "FILTER_OUT" net name, so this option should be checked.

   But it should be applied to the right-side net segment, not the left.

3. Click the Other Net button to select the right-side net segment.

4. Click OK.
Selecting the “Assign default names to all pieces” option discards the existing net name on the selected net segment. You can then use the Properties window to assign net names later.

## Connecting Components With Busses

A bus is a collection of nets that can operate as a group. Create busses anywhere on a schematic, between component bus pins, or from a single component bus pin. You specify bus names and ranges (widths) using labels. When a bus is connected to a bus pin on a component, the signals in the bus are mapped to the signals on the pin by position. The labels do not have to be the same.

The following topics describe how to connect components with busses:

- Adding a Bus
- Ripping Nets

### Adding a Bus

To add a bus:

Select the Bus tool by selecting **Add > Bus** or clicking the ![Bus Tool](image) button.

1. Place the cursor in the schematic at the point you have selected as the beginning point for the bus.

2. Press-and-hold the left mouse button and move the mouse to draw the bus as desired. You can add multiple extensions from the bus by click-and-holding the mouse button and moving the mouse away from the bus. You can change the direction of the bus as you draw it by depressing the space bar while dragging.

3. If the Properties window is not open, double-click on the bus to open up the Properties window.

4. Click in the cell to the right of the Name property, shown in the figure below.

5. Either enter a name for the bus, or select a bus name from the dropdown list of busses and bus contents that already exist in the project. The name of the bus must include the
width of the bus as two numbers separated by a colon, inside square brackets. For example, L1_CADOUT_N[15:0].

**Note** While the supported bus syntax calls for square brackets, you can use parentheses ( ), or braces { }. Parentheses and braces are automatically converted to square brackets.

**Ripping Nets**

DxDesigner provides two net ripping methods that are described in this topic:

- **Ripping Nets Manually**
- **Ripping Nets With the Rip Nets Command**

Both methods automatically add rippers and net names. Regardless of the method you use to rip nets off a bus, DxDesigner names the individual ripped nets using the nomenclature that you set in **Setup > Settings > Net Name Delimiter**.

This method of name delimiting can prevent confusion in situations such as the inability to distinguish between signal A10 (bit 10 of bus A) and signal A10 (bit 0 of bus A1).

So, for example, suppose you have 2 busses named A[0:1] and A1[0:1]. The following table shows how the ripped nets would be named, according to the settings specified with the net name delimiter.

| Table 4-2. Ripped net nomenclature |
|------------------|------------------|------------------|
| **Delimiter**    | **A[0:1]**       | **A1[0:1]**      |
| None             | A0               | A10              |
|                  | A1               | A11              |
| []               | A[0]             | A1[0]            |
| ()               | A(0)             | A1(0)            |
|                  | A(1)             | A1(1)            |
Creating and Editing Flat Designs

Connecting Components With Busses

Note

Use care when assigning net name delimiters. If you copy a schematic from a migrated project to another project with different delimiter settings, it may cause some nets to become disconnected and may cause other, unintentional connections.

For example, suppose you have a project with no delimiter for ripped nets and that project includes a bus $A[7:0]$. In this case, the constituent signals of the bus are named $A7...A0$. If you then copy a schematic sheet from that project to another project that has a ripped net delimiter set, the constituent signals are not automatically renamed with brackets. That is, their names remain $A7...A0$.

Also described in this topic are the following:

- Rippers Symbols
- Changing Spacing of Nets
- Adjusting Net Orientation

Rippers Symbols

Whenever you rip a net off a bus as shown in Figure 4-10, the appearance of the ripper is dependant on the number of nets being ripped from the bus, and their designation.

Figure 4-10. Ripper Symbols Example
Ripping Nets Manually

To rip nets manually:

1. Open the Name Nets dialog box from Edit > Name Nets...
2. Enter the name of the bus (ADDRESS, for example; do not enter the width portion of the bus name (for example, [0:63]).
3. Enter the starting bit in the Bit entry box.
4. Choose the ripping order (Ascending or Descending).
5. Enter the increment in the Delta entry box.
6. Click Close.
7. Activate the Net tool by selecting Add > Net or by clicking the button.
8. Position the cursor over the start position on the bus where you want to rip a net.
9. Click-and-hold the left mouse button while moving the cursor away from the bus to rip a net. The net name will correspond to the settings of the Name Bus Elements dialog box.
10. Repeat step 8 to rip as many nets as you require.

The Name Nets tool allows you to rename nets in two modes:

- Object/Action mode - You select the net and then apply the command.
- Action/Object mode - You set up the command, which is then applied when you rip the net.

Ripping Nets With the Rip Nets Command

To rip nets automatically:

1. Click on a bus to select it.
2. With the bus selected, right-click on the bus where you want the first net to connect. If you are ripping nets to attach to a symbol, make sure you right-click on the bus across from the first pin on the symbol.
3. Select **Rip Nets** from the popup menu.

4. Select which nets to rip in the Rip Nets dialog box. By default, all nets in the bus are selected. Use the <Shift> key to select contiguous nets. Use the <Ctrl> key to select non-contiguous nets.

5. Click **OK**. The nets are ripped from the bus, with their unconnected ends attached to the cursor.

6. Move the ripped nets to their connection points and left-click to release them from the cursor.

**Changing Spacing of Nets**

The default spacing for nets you create with the Rip Nets command is two grid points. You can change the spacing dynamically with the Resize Box functionality.

**To change the spacing, do the following:**

1. Click on the **Select** icon in the tool tray at the top of the DxDesigner window. The Select icon resembles the standard cursor pointer arrow.

2. Activate the Resize Box tool by selecting **Edit > Resize Box**. This action adds handles to the box around the selected nets.

3. Click-and-drag on one of the handles to change the spacing.

4. Click elsewhere in the schematic window to deselect the nets.

The Resize Box functionality stays active. The next set of nets you select will have resizing handles until you turn Resize Box off. To turn Resize Box off, select **Edit > Resize Box** again, or press <ESC>, or click the Select icon.

**Note**

Resize Box can also be used to adjust the distance between components and other objects in your schematic. It is very useful when adjusting the spacing in an array of components.

**Adjusting Net Orientation**

By default, the Rip Nets command creates nets that are:

- To the right of a vertical bus
- Below a horizontal bus
To change the net orientation on a vertical bus:

1. Click on the Select icon in the tool tray.
2. Click-and-drag a box around the nets and their respective rippers that you want to reorient.
3. Select the Mirror tool by choosing Format > Mirror or clicking the icon.

To change the net orientation on a horizontal bus:

1. Click on the Select icon in the tool tray.
2. Click-and-drag a box around the nets and their respective rippers that you want to reorient.
3. Select the Flip tool by choosing Format > Flip or clicking the icon.

Note

The Flip and Mirror tools are also useful for changing the orientation of the rippers. The Flip tool changes the orientation of Rippers on a vertical bus. The Mirror tool changes the orientation of the rippers on a horizontal bus.

Working Within the Schematic Editor

The following are tasks that you can perform in the Schematic Editor:

- Adding or Deleting a Schematic Sheet
- Copying a Schematic Sheet
- Adding Text to Schematics
- Adding Graphics to Schematics
- Selecting and Deselecting Objects
- Filtering Which Objects to Select
- Moving and Copying Objects
- Replacing a Symbol or Part
- Finding and Replacing Text
- Viewing Names and Properties
- Executing Commands Using Strokes

Adding or Deleting a Schematic Sheet

To add or delete a sheet, do the following:

To add a sheet to the end of a design:

- From the last page of the design, press Page Down.
  
  DxDesigner appends a new sheet to the schematic.
To delete a sheet:

1. Expand the Project Navigator to display the sheet you want to delete.
2. Right-click > Delete.

Copying a Schematic Sheet

To copy a sheet from one project to another:

1. Open the source project.
2. In the Navigator window, select the sheet(s) you want to copy.
3. On the selected sheet(s), right-click > Copy.
4. Open the destination project. (You can skip this step if you are copying and pasting sheets within the same project.)
5. On the schematic node you want to add the sheet to, right-click > Edit > Paste Sheet(s).

When nets in the copied sheet already exist in the destination project, the properties of the nets in the copied sheet take precedence over the values of the nets in the destination project.

All constraints applicable to objects in the sheet are also copied and take precedence over constraints in the destination project.

Adding Text to Schematics

You can add text strings to components or schematics. Text has no association with other graphical objects or with connectivity data.

To add text to a symbol or schematic:

1. Select Add > Text or use the “T” hotkey or type “text” on the command line and execute the command.
2. Click-and-hold the left mouse button to create the text locator.
3. Drag the mouse to move the text locator to the desired location.
4. Once you have the text locator where you want, release the left mouse button.
5. Fill in the Text Properties dialog box.

• To load text from a text file, select the Read from File checkbox and browse to the file you wish to import. The text will be added to your schematic. This is a powerful way to add notes or other text documentation directly to your design.
Adding Graphics to Schematics

You can add graphical objects to a symbol or schematic using the object toolbar buttons or the Add menu commands.

**To add an arc:**

1. Select **Add > Arc** or click ![arc](image) on the Object toolbar or type “arc” on the command line.
2. Click-and-hold the left mouse button down to specify the first endpoint of the arc.
3. Drag the mouse to the location you select as the other endpoint for the arc.
4. Click right mouse button or spacebar to specify the second endpoint.
5. Continue dragging with left mouse button depressed to specify midpoint for arc.
6. Release left mouse button to finish arc.

   **Note:** To cancel arc placement, press Esc or release left mouse button before specifying the second endpoint for the arc.

**To add a box:**

1. Select **Add > Box** or click ![box](image) on the Object toolbar or type “box” on the command line.
2. Click-and-hold the left mouse button to specify a corner for the box.
3. Drag the mouse to define the box.
4. Once you have the box you want, release the left mouse button.

**To add a circle:**

1. Select **Add > Circle** or click ![circle](image) on the Object toolbar or type “circle” on the command line.
2. Click-and-hold the left mouse button to specify the center of the circle.
3. Drag the mouse to define the circle radius.
4. Once you have the circle you want, release the left mouse button.

**Tip:** All closed drawing objects can be assigned a color, line style, and fill style. Select the object then right-click > **Properties** to set these values.
Creating and Editing Flat Designs

Working Within the Schematic Editor

**To add a line:**

1. Select **Add > Line** or click on the Object toolbar or type “line” on the command line.
2. Click-and-hold the left mouse button to specify an edge for the line.
3. Drag the mouse to define the line.
4. Click the right mouse button (or press spacebar) to create a polyline.
5. After you have the line you want, release the left mouse button.

**Selecting and Deselecting Objects**

Select an object when you want to edit its properties, move it, or zoom in on it. Deselect an object when you want to exclude it from an operation.

**Selection Rules**

- When you select an object, the object outline is highlighted.
- When you select a net, bus, pin, or component, all associated names and properties are also selected.
- If the selected object contains associated names and properties that are visible on the schematic, a text-owner indicator line visually connects the text to the center of the object that owns it as shown in the following figure:
Requirement

- Before you can select an object, you must be in Select mode. To enter Select mode, click the button. The Select button is depressed when you are in select mode.

To select an object of a particular type, the selection filter must include the desired type. See “Filtering Which Objects to Select” on page 108.

Selecting Objects

Do one of the following:

- Place the cursor on the object you want to select and click the left mouse button. All previously selected objects are deselected.

- Depress the left mouse button and drag the cursor to specify the selection area. DxDesigner selects only objects completely within the selection box.

To select multiple objects:

1. Click on the first object to select it.
2. Depress the <Ctrl> key while clicking the left mouse button on additional objects to select.
3. To select a group of objects, depress the <Ctrl> key while clicking and dragging the mouse over the group of objects you want to select.

**To select a net or bus:**

1. Place the cursor on a segment of the net or bus and click the left mouse button.
2. With the cursor on the selected segment, press <Ctrl> and click the left mouse button again.

The DxDesigner schematic editor selects the entire net or bus up to the solder joint.

**To select Components:**

Do one of the following:

- Click an individual component to select it.
- Select from the Command line:
  
  Type “scomp component_name” in the command line field and execute the command. If you do not enter the component name on the command line, the Select Component dialog box appears so you can enter the component name. Enter the component name in the component name field.

**To select multiple components with the same name:**

1. Select Edit > Select.
2. In the Select dialog box Select list, choose Component.
3. In the Expression field, enter the name of the component you want to select, then click OK.

The Select command selects all components in the schematic with the symbol name you specify.

**To select nets and net segments,** do one of the following:

- In the Schematic Editor, click a net segment to select it.
- In the Schematic Editor, <Ctrl> + Double-click a net segment to select the entire net.
- In the Project Navigator Contents Window, select the line or lines that show the net you want to select. It is also selected on the schematic.

**To select objects using the command line,** do any of the following.
• Select labels:
  a. Type “slabel label_name” in the command line field and execute the command.
  b. If you do not specify label_name, the Select Label dialog box appears. In the Select Label dialog box, enter the name of the label you want to select and the specify if you want the select to apply to all labels, then click **OK**.

• Select labels and associated objects:
  a. Type “sname selected_name” in the command line field and execute the command.
  b. If you do not specify selected_name, the Select Name dialog box appears. In the Select Name dialog box, enter the Internal name or label of the desired objects, then click **OK**.

• Select objects associated with specified property value(s):
  Type “svalue property_value” on the command line and execute the command. If you do not specify property_value, the Select Value dialog box appears. Enter the property_value, specify if you want the select to apply to all properties matching the select criteria, then click **OK**.

• Select a text string:
  a. Type “stext” on the command line and execute the command. You can use wildcard characters when specifying the text string.
  b. In the Select Text dialog box, enter the text to select and specify if you want the select to apply to all text strings matching the select criteria, then click **OK**.

Deselecting Objects

A selected object remains selected until you deselect it, delete it, or select something else.

To deselect all selected objects:

• Place the cursor in an empty area of the schematic, then left-click.

To deselect a single object:

• <Shift> + left-click the object you want to deselect.

  **Note:** On a net where only some segments are select, the following rules apply:
  • If you <Shift> +left-click a selected segment, only that segment is deselected.
  • If you <Shift> +left-click a deselected segment, the entire net or bus is deselected.
To deselect a group of objects:

1. Depress the <Shift> key.
2. Click-and-drag the left mouse button to form a box over the group or area that you want to deselect.
3. Release the left mouse button.

DxDesigner deselects all selected objects located completely within the box. If any part of an object appears outside of the box, DxDesigner does not deselect the object.

Filtering Which Objects to Select

At times, you may want to select some objects but not others. For example, you might want to select a net, but not the net label. This is particularly difficult on dense designs. To filter which objects you select, use the Selection Filter.

To select certain object types:

1. Right-click an empty area of the schematic and select Selection Filter or click the button.

You will be presented with the following choices:

- All
- Arc
- Box
- Circle
- Symbol
- Label
- Line
- Net
- Pin
- Property
- Text
- Ripper
- Symbol Group
  - Reference Designators
  - Pin Properties
- Pin Group

2. Select All, or deselect All and select any combination of the objects in the upper section of the list.

Caution

Be sure to reset the selection filter to All before closing the schematic. If you do not, you may see an unexplained inability to select certain objects the next time you work on the schematic.
Moving and Copying Objects

You can move an object or objects, and duplicate an object in another DxDesigner window, or in another application.

To move an object to a different location in the same window:

1. Select the object.
2. Drag and drop it to the new location in the window.

To move a group of objects and place it at a different location in the same window:

1. Select the objects you want to copy.
2. Drag and drop it to the new location in the window.

To copy an object to another DxDesigner window or another application:

1. Select the object(s) you want to copy.
2. Select Edit > Copy or click the button or click <Ctrl> + C or enter “copy” in the command line.
3. Click in the window where you want to paste the object.
4. Select Edit > Paste or click the button or click <Ctrl> + V

To copy a block to another project:

1. In the Project Navigator Tree of the source project, select the block you want to copy.
2. Right-click > Copy.
3. From the File menu, click Open > Project
4. DxDesigner warns you that it is closing the source project. Click OK. The destination project opens.
5. In the Project Navigator Tree of the destination project, select the Block node.
6. Right-click > Paste.

To copy a bitmap picture of a schematic section to another application window:

1. Select the schematic section you want to copy
2. Select Edit > Copy or click the button or
Creating and Editing Flat Designs

Working Within the Schematic Editor

- enter <Ctrl> + C or enter “copy” in the command line.

3. Open and make active the application window that you want to paste the component in.

4. Select Edit > Paste Special.

5. Click OK on the Paste Special dialog box.

Bitmap images will show the object as selected. If you want to copy a bitmap without the selection boxes, zoom in so that the section you want to copy fills the screen and perform the copy with nothing selected.

Replacing a Symbol or Part

You can replace selected symbols/parts within a schematic, using the Replace Symbol/Part Dialog box. The dialog box lets you select the replacement symbol, control how DxDesigner handles Ref Designators, part numbers and property values, and specify whether to replace only the selected symbol or instance of symbols elsewhere in the design.

To replace selected symbols/parts:

1. Select the symbol you want to replace.

2. Right-click > Replace Symbol. The Replace Symbol/Part dialog box opens.

3. Click Browse. If it is not already visible, the Symbols window opens.

4. Select the replacement symbol. It displays in the Replace selected symbol(s)/part(s) with: field.

5. Return to the Replace Symbol/Part dialog box and specify options to control the replacement.

6. Click Replace.

Note

You can select other symbols and repeat. The Replace Symbol/Port dialog box stays open until you click Close.

Related Topic

- Replace Symbol/Part Dialog (DxDesigner Reference Manual)
- Symbols Window (DxDesigner Reference Manual)
Finding and Replacing Text

You can find and replace text on schematic objects, including components, nets, busses, pins, and text.

To find and replace text on schematic objects:

1. Select Edit > Find/Replace. The Find and Replace Text dialog box opens.
2. In the Find tab, specify what you are searching for and the scope of the search.
3. Click More to specify additional search parameters.
4. In the Replace tab, specify the string you want to use to replace the search string.
5. Use the buttons to control how the search and replace are executed.

Related Topic:
- Find and Replace Text Dialog (DxDesigner Reference Manual)

Viewing Names and Properties

You can configure DxDesigner to display the names and properties of objects as tooltips. You can also select which types of objects to display this information for. The object types you can select are Components, Nets and Pins.

To display names and properties as tooltips:

1. Select Setup > Settings > Display (section).
2. In the Show tooltips area, select the object types you want to display tooltips for.

Executing Commands Using Strokes

In addition to using menus and toolbars, you can execute commands using strokes. Strokes are predefined patterns of mouse movements that you use to execute commands or functions. You draw the pattern on an imaginary grid on the schematic. The grid translates the pattern into a numerical sequence and executes the command. You must enable the strokes to turn on the grid recognition.
The following table shows the numerical sequences that the strokes recognize and translate into commands.

### Table 4-3. Numerical Sequences Defining Strokes

<table>
<thead>
<tr>
<th>Stroke grid</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
</tr>
<tr>
<td>4</td>
</tr>
<tr>
<td>7</td>
</tr>
</tbody>
</table>

**Requirement**

- You must enable strokes before they become available in the Schematic Editor.

**Related Topics**

- DxDesigner Key Bindings and Strokes in the *DxDesigner Reference Manual*
  - List of DxDesigner vdbindings.vbs Stroke Definitions
  - List of DxDesigner exped_wvo.vbs Stroke Definitions
  - List of DxDesigner exped_pv.vbs Stroke Definitions

**Enabling and Disabling Strokes**

Stroke recognition is on by default. The following files define the strokes and shortcut keys. Depending on your platform, and depending on whether you turn on Expedition Style Keybindings in **Setup > Settings > Advanced** (section) will determine which set of bindings is in effect for your session.

- vdbindings.vbs - Contains default DxDesigner stroke definitions
- exped_wvo.vbs - Contains Expedition style stroke definitions for PC
- exped_pv.vbs - Contains Expedition style stroke definitions for UNIX

To enable strokes:

- From the **Setup > Settings > Schematic Editor** (section) > **Strokes, Pan and Zoom** (subsection), click the Right Button or Middle Button option to set the strokes.

To disable strokes:

1. **Setup > Settings > Schematic Editor** (section) > **Strokes, Pan and Zoom** (subsection), click the Strokes off option.
Entering a Command Using a Stroke

To enter a command using a stroke:

1. Press the stroke mouse button that you selected in the Settings dialog box.
2. Move the mouse in the predefined stroke pattern for the function, and release the mouse button.

As you move the mouse to draw the pattern, a red line follows the mouse movement in the window to show you the pattern you are creating.

Customizing Strokes Using Bindings Definitions File

You bind strokes to mouse movements in the same manner as you bind shortcuts to keys. You use the bindings to execute commands or functions that you use often. You can customize the strokes by adding or deleting strokes, or changing the numerical sequence associated with an existing stroke. You customize strokes by editing one or more of the following files:

- vdbindings.vbs - Contains default DxDesigner stroke definitions
- exped_wvo.vbs - Contains Expedition style stroke definitions for PC
- exped_pv.vbs - Contains Expedition style stroke definitions for UNIX

These files are in the $SDD_HOME/standard directory of your installation.

Restriction

- You can only add strokes for commands that are already in the .vbs file and are bound to a key.

Example

To add a stroke for the numerical sequence 1478963, which the system recognizes as AddArc, enter the following:

Bindings ("Stroke").AddStroke "1478963", "AddArc"

Viewing Strokes Defined in .vbs File

You can view the strokes defined in the active .vbs, as well as the commands they execute by clicking the Help > Show Bindings menu. For a listing of bindings organized by logical function actions, see one of the following:

- DxDesigner Key Bindings - Default (DxDesigner Reference Manual)
- DxDesigner Key Bindings - Expedition Style (DxDesigner Reference Manual)
Verifying Your Design

At any time during design creation, you can run the Design Rule Checker (DRC) to verify that you are keeping to the project design rules. To run DRC:

1. Select Tools > Verify.
2. On the Settings tab, select the level of checking and reporting to do.
3. Optionally, on the Rules tab, make any desired changes to the way specific rules are reported.

Related Topics

- DRC (schematic_name) Dialog in the DxDesigner Reference Manual

Processing Your Completed Design

After you complete your design, you can do any of the following:

- Prepare a design for forward annotation by assigning reference designators using the Packager. If the design is hierarchical, the packager flattens it. See “Packaging A Design” on page 137.
- Create a BOM of the design. See “Generating Bills of Materials” on page 157.
- Create a cross-reference of the design. See the Cross-Referencing a Design manual.
- Archive the design and its libraries. See “Archiving Projects” on page 141.
- Print or plot the design. “Printing, Plotting and Generating PDF” on page 143.
- Export the design in EDIF format. See “Exporting Schematic/Symbol File to EDIF Schematic File” in the DxDesigner Schematic Translators manual.
- Export a Foreign Database. See “Working with Foreign Databases” on page 126.
- Create Variant Designs (Expedition workflow only). See Variant Manager User’s Manual.
- Simulate the design. For more information, see Help > Documentation in InfoHub > Analysis - Simulation and Signal Integrity.
- Post-process the design using scripting. See the DxDesigner Automation Reference manual.
Chapter 5
Creating and Editing Hierarchical Designs

The following topics describe how to create and edit hierarchical designs:

- Hierarchical Designs and Design Reuse
- Creating Bottom-Up Hierarchical Designs
- Creating Top-Down Hierarchical Designs With Blocks

Hierarchical Designs and Design Reuse

Hierarchical designs provide an efficient way of using the same circuit multiple times without re-drawing it for each use. Instead, you create a hierarchical block, and change the underlying schematic’s properties for each instance. Thus, for each unique path through the hierarchy, you have unique properties, making each instance unique.

Selecting a Design Methodology

You can create hierarchical designs either from the bottom up, or from the top down.

**Bottom-up design** lets you re-use an existing schematic by creating a top-level composite block that represents the schematic. You then place this block multiple times on your design, assigning unique hierarchical properties (Instance Values) to the underlying schematic for each occurrence.

**Top-down design** lets you work at a more abstract level by using a “placeholder” block, in the top level design. For example, you can divide the work between a system designer and a circuit designer. The system designer designates I/O for a “black box” hierarchical block, for which the circuit designer later creates the underlying schematic. When the circuit designer has created and tested the underlying schematic, its associated “black box” block is transformed into a composite block.

Creating Bottom-Up Hierarchical Designs

Create a bottom-up design by associating a block with an underlying schematic, and then assigning instance values to the properties that you want to be unique for each instance of the block.
Creating and Editing Hierarchical Designs

Creating Bottom-Up Hierarchical Designs

You can choose to automatically create a block from an existing schematic, or you can manually create a symbol to represent the underlying schematic. The final step is to add the new block to the top-level schematic.

Requirements:

- You have already created the schematic that you want to make into a block.
- You have defined onsheet and offsheet pins in the Settings dialog, and placed them on the schematic.

Generating a Block from a Schematic

You can generate a block from an entire schematic using the Generate Symbol tool, or by extracting it from a portion of a schematic.

To generate a block using the Generate Symbol tool:

1. Open the schematic you want to use as the source of the symbol.
2. Select Tools > Generate Symbol.
3. Fill in the Generate Symbol dialog box as follows:

   - **Block Input**: This field is unavailable. It specifies the name of the schematic you currently have open.

   - **Symbol Output**: You specify the name of the symbol. It is suggested that you use the default for the name of the output symbol. This default is the same as the block name. This common name creates the hierarchical association.

   - **Override Existing Symbol, if any** - If this box is checked, a symbol with the same name as specified in the Symbol Output field will be over-written. If the box is unchecked, a warning message is issued if a duplicate name is found. In this case the symbol generation is stopped.

   - **Open Symbol in Symbol Editor** - If this box is checked, the generated symbol is opened for editing in the Library Manager Symbol Editor.

   - **Advanced (button)** - This button opens the Advanced Options dialog box, which you use to set the following options:

     - Symbol Properties - Use this field to add properties to the symbol that you are creating. The syntax for this field is: name=value. Separate multiple properties with a space.

     - Symbol Property Size - set the size of the symbol attribute

     - Input Pin(s) - Specify the names of inputs to the symbol. The values in this field are used by DxDesigner as a last resort by the algorithm that searches for I/O
Creating and Editing Hierarchical Designs

Creating Bottom-Up Hierarchical Designs


nets. Type the names of the input pins separated by a space. You can use the left and right arrow keys to scroll if you have multiple name entries

- Output Pin(s) - Specify the names of outputs from the symbol.
- Pin spacing, Pin length, and Pin label size - Enter settings to override the values you assigned in the Setup > Settings dialog box.
- Pin Sides - For each of the listed pin types, select placement values of top, left, bottom, or right.

To extract a block:

1. Open the schematic from which you want to extract a block.
   
   **Tip:** You can extract a block from a schematic at any level of hierarchy. The extracted block will be placed one level of hierarchy below the schematic from which you extract it.

2. Click Add > Block.

3. Drag-select the section of the schematic you want to use.

4. Enter the name of the block you are creating, and select the Extract schematic checkbox.

5. Click OK.

**Result:**

- DxDesigner moves all selected objects to a new schematic, which become the contents of the newly created block. The block appears in place of the selected circuitry. It also appears in the navigator, and as a new tab in the Schematic Editor window.

- If nets or busses cross the drag-select border, one of the following will happen:
  
  - If you have defined ports in the Setup, the appropriate pins on the block, and ports on the underlying schematic, are created and are connected automatically.
  
  - If you have not defined ports, you must add the ports manually by selecting the new block, clicking Tools > Push Schematic, and then, clicking Add > Missing Ports.

Editing a Generated Block

You can edit a generated symbol whether or not it has been placed on a schematic.

To edit a generated symbol:

1. Select the symbol by doing one of the following:
• Select **View > Symbols** to open the Symbols window, then select the symbol you want to edit from the [local symbols] partition.

• Within the schematic, select the generated symbol you want to edit.

2. Right-click > **Edit Local Symbol**. The Symbol Editor opens.

3. Use the Symbol Editor to edit the symbol. Also see the *DxDesigner Symbol Editor* manual.

### Moving Generated Blocks into the Central Library

1. Select **View > Symbols** to open the Symbols window, then select the symbol you want to edit from the [local symbols] partition.

2. Right-click > **Edit Local Symbol**. The Symbol Editor opens.

3. Within in the Symbol Editor, select **File > Export Symbol**.

4. Browse to the Central Library partition into which you want to place the symbol.

### Placing a Symbol in an Open Schematic

**To place a symbol in an open schematic, perform the following steps:**

1. Open the Symbols window with the **View > Symbols** pulldown menu item.

2. Choose a tab based on how you want to view the symbols, by part number (**Parts View** tab), by symbol type (**Symbol View** tab), or by reuse blocks (**Reuse Blocks** tab).

3. You can scroll through the list of symbols or filter the list by entering a string in a field above a column that matches the symbol you are looking for.

4. Select the symbol you want. An image of that symbol appears on the right side of the Symbols window.

5. Choose whether or not you want nets and/or net names to appear on the symbol.

6. If you are placing reuse blocks, set the merge options and numbering options as described in either the *Placing a Logical-Only Reusable Block in a Host Design* or the *Placing a Logical-Physical Reusable Block in a Host Design* sections of the *Reusable Blocks Process Guide*.

7. Click the **Place Symbol** button.

8. Place the mouse cursor in the schematic window. An outline of the symbol you are placing appears at the cursor.

9. Click the RMB in the location where you want to place the symbol. You can click multiple times in multiple locations to place more than one symbol.
10. Press the <Esc> key to stop the place symbol action.

**To manually create a local symbol for the low-level schematic:**

1. Open DxDesigner on the desired project.
2. Open the low-level Block that you will want to place on the high-level sheet.
3. Click **File > New > Local Symbol**.
   The Symbol Editor opens.
4. Edit your symbol as needed and save it. (See “Creating a Local Symbol” on page 59 for more details.)
   You must manually add the ports to match those on the related schematic sheet.
5. Close the Symbol Editor.
   This local symbol is now available in the DxDesigner Symbols window (**View > Symbols**).

**To add the local symbol to the top-level design:**

1. In DxDesigner, display the top-level sheet where you will add the newly-created symbol.
2. From the Symbols window (**View > Symbols**), find the local symbol you created and select it.
3. Drag-and-drop the symbol to the schematic sheet.

**Related Topics**

- Creating a Local Symbol
- Configuring Special Components

**Adding Ports to the Schematic**

The following describes how to add a port to a schematic:

**Requirement**

You have previously configured Specialized Components. See “Configuring Special Components” on page 55 for instructions.

**Procedure**

**To add ports:**

1. Select **Add > Port** or click the button.
2. Select the port type from the dropdown list.

3. Move the cursor on the schematic to point where you want to port to appear and left-click. Continue left-clicking for as many ports as you need. Right-click will stop the port-insertion.

Creating Top-Down Hierarchical Designs With Blocks

A block is a hierarchical symbol that contains underlying design data. A block can represent a schematic, and Interconnect Table (ICT), or VHDL/Verilog. Once a block is placed on a schematic sheet, you can automatically connect nets to the block, unless the block is frozen.

Related Topics
- Placing Blocks on the Top-Level Schematic
- Adding Nets and Pins to a Block
- Freezing and Unfreezing Blocks

Placing Blocks on the Top-Level Schematic

1. Select Add > Block or click the toolbar button.
2. Left-click an area of the schematic to define the starting point for the block, and then drag the mouse to define the block area.
3. Enter the block name in the Add Block dialog box. If you do not enter a name, the block is not added to the drawing.
4. Click OK. The block appears as a symbol shell in the design.

Notes
- You can resize a block by clicking and dragging a corner of the symbol shell.
- When you use the Add > block command, DxDesigner graphically creates an inner and outer box for each block. The box color that you specify in Setup > Settings > Display > Objects for the Box object determines the color of the block.

Adding Nets and Pins to a Block

1. Draw the required Nets and Busses connecting to and from the block.
2. Label each Net and Bus.
3. Drag any labeled net to the outer bounding box of the block.
Result: When the net reaches the edge of the block, a pin is automatically added to the block, named the same as connecting net. After you save the design, DxDesigner automatically updates the symbol shell to include the required pin labels by copying the labels from the attached nets.

Note
Creating a block pin clears the schematic’s Undo and Redo stacks, disabling the operation of these commands.

Deleting Block Pins

When you delete a net or bus segment that is attached to a block pin, DxDesigner automatically deletes the block pin.

Note
Deleting a block pin clears the schematic's Undo and Redo stacks, disabling the operation of these commands.

Freezing and Unfreezing Blocks

You freeze blocks to make them read-only. You unfreeze blocks to make them editable. When you create a block, its state is unfrozen. When a block is frozen, nets drawn to the block do not automatically create and attach to pins.

To Freeze a block:

1. Select an unfrozen block
2. Right-click > Freeze

To Unfreeze a block:

1. Select a frozen block
2. Right-click > Unfreeze

Related Topics:
- Adding Nets and Pins to a Block
Once you have finished your design, you may want to post-process it for use in other tools.  
**Figure 6-1** shows the possible flow of data between DxDesigner and other tools when you have 
created a project using the Expedition workflow.

**Figure 6-2** shows the dataflow possibilities when you have created a project using the Netlist workflow.

For more information on the Expedition and Netlist workflow types, see the topic titled “The 
DxDesigner Workflows” on page 14.

The remainder of this section is divided into the following topics:

- Exchanging Data Within Expedition Workflow
- Exchanging Data Within Netlist Workflow
- Exporting a Quick Connection View
- Using LineSimLink to Interface with HyperLynx
  - Exporting to HyperLynx with LineSimLink
  - Importing from HyperLynx with LineSimLink
- Packaging A Design
Figure 6-1. Possible Dataflows Using the Expedition Workflow

- **DxDesigner** ➔ iCDB ➔ Expedition PCB
- **DxDesigner** ➔ iCDB ➔ Export ➔ Foreign Database ➔ Expedition PCB
- **DxDesigner** ➔ iCDB ➔ Export ➔ Tool
  - Windows Metafile
  - HPGL
  - PDF
  - EDIF Netlist
  - EDIF Schematic
  - VHDL Netlist
  - Verilog Netlist
  - Analog Netlist
  - Quick Connection View
- **DxDesigner** ➔ iCDB ➔ Import ➔ Tool
  - EDIF Netlist
  - EDIF Schematic
Exchanging Data Within Expedition Workflow

When using the Expedition workflow, DxDesigner is tightly integrated with Expedition PCB for forward and back annotation (as shown below) along with other tools, such as the Library Manager and the Constraint Editor System. This assumes that all tools are on the same network.
Exchanging Data with Other Tools

Exchanging Data Within Expedition Workflow

If the Expedition PCB layout design process is to occur at a remote location, you can detach the PCB design process from the main schematic design project by using the **File > Export > Foreign Database** feature (shown below). This enables you to create a design database that you can ship to a remote site.

Using the **File > Import > Foreign Database** feature allows you to import changes made in layout back to the schematic. For more information, see “Working with Foreign Databases”.

Also See

- iCDB (integrated Common Database) Administration in the *DxDesigner Administrator’s Guide*
- *Expedition PCB User’s Guide*

### Working with Foreign Databases

A standalone DxDesigner database known as a “Foreign Database” is created from a DxDesigner project by exporting the connectivity and constraint data along with a dedicated project file (**File > Export > Foreign Database**). During the export process the schematic is packaged and the Reference Designators and Pin numbers are annotated onto the schematics so they are ready to enter the PCB design. See “Exporting a Foreign Database from DxDesigner - Example”.

The Expedition Job Management Wizard is used to create the PCB design from the foreign database and the project file in the remote location, but must use the same Central Library as the main DxDesigner project. During the PCB design process, Expedition modifies connectivity data in the form of “Reference Designator” and “Pin Number” changes along with modifying constraint data. These modifications may be back-annotated to the design project utilizing the DxDesigner **File > Import > Foreign Database** utility. (See “Importing a Foreign Database from DxDesigner - Example”).

Further changes at the DxDesigner front end may be re-exported with over-write to update the Expedition PCB, keeping the project synchronized.

### Exporting a Foreign Database from DxDesigner - Example

**To export a foreign database for layout:**

1. From DxDesigner select the **File > Export > Foreign Database** menu item.
   
   You are prompted for the target location for the Foreign Database.
2. Specify the location for the Foreign Database.
   A DxDesigner dialog confirms that the database Export has been successful.
   DxDesigner successfully exports the Foreign Database plus a separate project file to be
   used purely for layout purposes.

3. Launch Expedition PCB and use the File > New > Project menu or bring up the
   Expedition Job Management Wizard. For more information on using Expedition PCB,
   see the Expedition PCB User’s Guide.

   **Note:** The central library, as used on the main design project, is referenced by the PCB
   Job Management Wizard.

4. After completing the Job Management Wizard invoke Expedition and choose the Setup
   > Project Integration > Forward Annotation menu item.

5. Click the Forward Annotation button.
   The PCB design process continues with place and route of the board.

6. The following example shows an edit to the Max Vias Constraint on 3 nets and also
   renumbering the Reference Designator of the Crystal Oscillator from XL1 to XTAL1.

   ![Constraint Editor System](constraint.png)

   ![Process List](process_list.png)

7. Save and Exit Expedition PCB.
Importing a Foreign Database from DxDesigner - Example

To update the DxDesigner project with the new annotations and constraint data the user needs to **Import the Foreign Database into DxDesigner** as follows:

1. In DxDesigner, choose the **File > Import > Foreign Database** menu item.
   
   You are prompted for the Foreign Database location.

2. Select the desired database. A message box appears indicating that the import has been successful.

3. Using the previous example in “Exporting a Foreign Database from DxDesigner - Example”, step 6 when a change was made to the Crystal Oscillator: After importing this particular design, the Reference Designator for the Crystal Oscillator is back-annotated to the lower-level schematic as follows:

![Diagram of schematic with annotations]

Also, the Max Vias Constraint values that were added onto the three nets in Layout have been synchronized in the Front-End design database.
Changing Schematic and Re-Export - Example

1. To continue with the previous example, a 47 ohm resistor is added and connected from the FREEZE net to VCC as shown below:

![Resistor Diagram]

2. From DxDesigner select the **File > Export > Foreign Database** menu item. You are prompted for the target location for the Foreign Database.

3. Specify the same location for the Foreign Database as before. A DxDesigner dialog asks if you want to overwrite the old database.

4. Answer Yes. The design is incrementally packaged and Reference Designator R9 is annotated onto the lower level schematic as shown below:

![Annotations Diagram]

5. This change must now be integrated back into Expedition PCB using the same process as described in “Exporting a Foreign Database from DxDesigner - Example”.
Exchanging Data Within Netlist Workflow

Within a Netlist workflow, the primary method of exchanging data with a layout tool, including Expedition PCB, is to use the PCB Interface (Tools > PCB Interface) as shown in the following figure:

Also See
- iCDB (integrated Common Database) Administration in the DxDesigner Administrator’s Guide
- PCB Interfaces User’s Guide

Exporting a Quick Connection View

The File > Export > Quick Connection View option is a way to create a generic netlist that you can use to visually debug board connectivity or easily check other connections such as power supply (generally global nets) connections.

Quick Connection View works on packaged and un-packaged designs. If no Ref Des is available, the Id is used instead.

DxDesigner saves the Quick Connection View generic netlist in a file that you specify, and it displays the results in a Quick Connection View tab.

The following topics describe what you can do with the Quick Connection View:
- Cross-Probing from Quick Connection View Tab
- Configuring the Quick Connection View Output
- Interpreting the Netlist Output

Cross-Probing from Quick Connection View Tab

Figure 6-3 shows an example of a Quick Connection View tab that is used to cross-probe a selected net with the Navigator window and the Schematic window.
Figure 6-3. Quick Connection View Cross-Probing Example

Configuring the Quick Connection View Output

When you execute File > Export > Quick Connection View, the related dialog box appears. From the dialog box you can set the following:

- **Top Level Block** - define the top level block that you want to netlist
- **Output File** - define where you will store the .txt output
Exchanging Data with Other Tools

Exporting a Quick Connection View

- **Single Line Per Net** - If set, configures the output to put all large nets on one line. If unset, configures the output to break large nets into separate lines as shown in the following example:

  □ (unset)


  (The /RLDRAM1/GND nets are listed on multiple lines)

  □ (set)

  NET : '/RLDRAM1/GND' GND-B C206-2 C46-2 C209-2 C210-2 C211-2 C49-2 ...

  (all /RLDRAM1/GND nets are listed on one, possibly long, line)

- **Separate No/Single Pin Nets** - If set, configures the output to list the No/Single Pin nets in a separate section of the netlist as noted by the following entry:

  # begin one pin nets list

- **Display Un-connected Pins** - If set, configures the output to list the un-connected pins in a separate section of the netlist as noted by the following entry:

  # begin un-connected pins list

- **Exclude Special Components** - If set, configures the output netlist to omit connections to Special Components as defined in **Setup > Settings > Project** (section) > **Special Components**, which are typically power, ground, hierarchical ports and sheet connectors that have no part number associated with the symbols.

- **Flat mode** - If set, the output netlist displays the FlatNet name above each group of related nets as shown in the following example (Single Line Per Net is also set in this example):

  □ (set)

  FlatNet: PAR
  NET : '/MICRO1/PAR' AMD_8111_TO_HUB1-PAR PCI_CONN1-PAR
  NET : '/MICRO1/PCI_CONN1/PAR' PAR-B1 J_PCI-A43
  NET : '/MICRO1/AMD_8111_TO_HUB1/PAR' PAR-B1 U29-AP6

  □ (unset)

  The three '/MICRO1/... net lines are listed without the FlatNet line preceding them.
Interpreting the Netlist Output

The Quick Connection View netlist is divided into fields separated with a separator (a space in these examples) as follows (also see Figure 6-4):

\[
\text{FIELD1} [\text{separator}] \text{FIELD2} [\text{separator}] \text{FIELD3} [\text{separator}] \text{FIELD4} [\text{separator}]
\]

FIELD1 - Is a keyword to identify the type of net as either:
- NET
- PIN

FIELD2 - Is the colon character (":")

FIELD3 - Shows the hierarchical net name in between single quotes

FIELD4 - Shows the net connections to all pins

**Figure 6-4. Quick Connection View Netlist Example 1**

\[
\begin{align*}
\text{NET :'/SN1_off'} & \text{ $1I1-4$ $1I22-01$} \\
\text{NET :'/SN2_off'} & \text{ $1I1-22$ $1I1-11$ $1I23-01$}
\end{align*}
\]

(only one level of hierarchy is shown here)
Using LineSimLink to Interface with HyperLynx

Use the LineSimLink to export to HyperLynx for signal integrity simulation, or to import any new data from HyperLynx. You can use the link to do any of the following:

- Automate net schematic creation
- Determine if topology constraints are needed for PCB layout
- Determine if min/max delay or length constraints are needed
- Determine if additional termination parts are needed
- Plan the board stackup
- Update and retain signal integrity model assignments
- Easily re-run simulations with any updated stackup and termination properties

**Restriction:** The results from LineSim simulation are not suitable for direct interpretation for constraint synthesis; you will need to enter any derived constraint data manually into DxDesigner.

The following topics describe how to export to, and import from HyperLynx with LineSimLink:

- Exporting to HyperLynx with LineSimLink
- Importing from HyperLynx with LineSimLink

Exporting to HyperLynx with LineSimLink

To export to HyperLynx, do the following:

1. Select **Tools > LineSimLink** to open the LineSimLink dialog box.
2. In the DxDesigner schematic, select the nets you want to export.
3. Click **Load Data from DxDesigner** to populate the fields on the dialog box.
4. To exclude interconnections when exporting, click **Parts only schematic**. Otherwise click **Complete schematic**.
5. If you want to change the default layer, typically the first metal layer, select the one you want from the **Layer** list.
6. If you want to change the default length and width, type the value you want in the box.
7. To add a passive prefix, find the correct type in the **Passive Prefixes** list and type the prefix in the corresponding box.

**Tips:**
Prefixes are separated in each list by a comma, a space, or a semicolon.
You can remove a prefix from the list as well; just highlight it and press delete.

8. To add a supply net, scroll to the bottom of the Supply Nets list, click twice, slowly, in the **Net** box, and type the name of the net. Type the voltage value in the **Voltage** box.

9. Select or browse for the filename to which you want to export.

10. Verify that the correct nets are being exported, the pins are in the correct order, and the direction of all bidirectional pins are correct on the Schematic Topology tab.

11. Click **Export to HyperLynx**. The .ffs file is generated and if HyperLynx is installed on your system, it opens with the new file loaded.

12. Click **Close** to close the dialog box.

**Related Topic**

- **LineSimLink Dialog** in the *DxDesigner Reference Manual*

**Importing from HyperLynx with LineSimLink**

To import from HyperLynx, do the following:

1. Select **Tools > LineSimLink** to open the LineSimLink dialog box.
2. In the DxDesigner schematic, select the nets you want to export.
3. Click **Load Data from DxDesigner** to populate the fields on the dialog box.
4. Select or browse for the filename from which you want to import.
5. Click **Import from HyperLynx**. DxDesigner compares the imported data with the schematic that is currently loading, and opens the Merge Differences dialog box.
6. To view the stackup and trace changes, click **Show stackup and trace changes**. The dialog box expands.
7. Verify the current topology against the imported topology. Select any changed nets, listed in green, to view the pin properties and values that have changed. Click **Accept** if the changes are what you expected. Click **Deny** to reject all of the imported data.
8. If you accepted the import data, you can then change the order or direction of an imported pin, if necessary, on the Schematic Topology tab.
9. Click **Close** to close the dialog box.

The remainder of this topic describes the following:

- **Excluding a Net from Export**
- **Changing the Order of Pins**
Exchanging Data with Other Tools

Using LineSimLink to Interface with HyperLynx

- Changing the Direction of a Pin

Also see
- LineSimLink Dialog in the DxDesigner Reference Manual

Excluding a Net from Export

To exclude a net from being exported to HyperLynx, do the following:

1. Click the Schematic Topology tab.
2. If you want to automatically zoom to a net in the schematic when you select one in the Schematic Topology list, click the Zoom check box.
3. Select the net you want to exclude and click Exclude Net. The net is crossed out in red in the list.

Tip: To include an excluded net, select the excluded net from the list and click the Include Net button. This button dynamically changes to reflect whether the net is included or excluded.

Changing the Order of Pins

You can change the order of pins only.

To change the order of pins, do the following:

1. Click the Schematic Topology tab.
2. If you want to automatically zoom to a net in the schematic when you select one in the Schematic Topology list, click the Zoom check box.
3. Select the net that contains the pins you want to change and drill down until you find them.
4. Select the pin you want to move and click the up or down arrow depending on which way you want to move it.

Changing the Direction of a Pin

You can change the direction of bidirectional pins only.

To change the direction of a pin, do the following:

1. Click the Schematic Topology tab.
2. If you want to automatically zoom to a net in the schematic when you select one in the Schematic Topology list, click the Zoom check box.
3. Select the net that contains the bidirectional pin and drill down until you find it.
4. With the bidirectional pin selected, click the **Change direction** button.

## Packaging A Design

The packager prepares for forward annotation, mapping each component in the logical schematic to a physical part by assigning reference designators. If the design is hierarchical, the packager flattens it.

Although a design is packaged automatically when you forward annotate, you can also package it manually. This is useful when you are not finished with a design, but want to confirm that Reference Designators will be handled correctly when the design is forward annotated.

Refraining from forward annotation also saves time. You can increase time savings by restricting the behavior, optimization algorithm, and scope of the packager, using the Packager dialog box.

**To package a design:**

1. Click **Tools > Package**. The Packager dialog box appears
2. Configure the Packager dialog box settings (or run with default settings).

### See also

- Packager Dialog in the *DxDesigner Reference Manual*
Exchanging Data with Other Tools

Packaging A Design
You verify schematics using the Design Rule Checker, (DRC). The DRC is an event driven tool that you use to locate electrical rule violations in your design. You can configure the DRC for your design environment.

For more information on the Design Rule Checker options, see the topic “DRC (schematic_name) Dialog” in the DxDesigner Reference Manual. For information on configuring custom defaults for the DRC dialog, see the topic Design Rule Checker (DRC) Defaults File in the DxDesigner Reference Manual.

To start the DRC:

- Select Tools > Verify or click the toolbar button.

Configuring the DRC

- You configure the DRC using the DRC dialog box.

To specify how the schematic is parsed and how the results are reported:

1. In the Settings tab, select the appropriate Check option to specify what DRC will run on.
2. Chose the desired Level Property to limit how far DRC descends into the hierarchy.
3. If you want the resulting report to show hierachical paths, click the box under the Report section.

To configure the check rules:

1. Click the Rules tab.
2. Select the desired rule checks:
   - If you select a group by clicking the checkbox, all the related rules are selected.
   - If you do not want all the rules in a Group, just select the checkbox for the rule(s) you want.
3. If a rule specifies a value, you can edit it by clicking in the Values column for that rule and changing it.
4. If you want to change the severity of a rule, click in the Severity column for the rule and use the pulldown box to make the change.

**Tip:** You can reset either tab by clicking the Defaults button. The Rules tab will revert to the defaults stored in the `\<mgc_home>\<release>\SDD_HOME\standard\NetlistVerifyDefaults.ini` file for an Netlist workflow design or `\<mgc_home>\<release>\SDD_HOME\standard\VerifyDefaults.ini` file for an Expedition workflow design.

**To check the design:**

- When you have finished configuring the DRC, click **OK**.

  **Result:** The report, in the format you specified on the Settings tab, appears in the Output window. Any settings you changed in the Rules tab gets saved in the `NetlistVerify.ini` file in your project directory.
The Archiver is a project management utility that collects and stores schematics, symbols, and other data associated with a specific design or project in DxDesigner. It provides a self-contained design that is ready to be checked in to DMS or other data management tools. You run the Archiver from a Wizard, where you select such options as what files to archive, and the location and format of the output. For more information, see Archiver Wizard in the DxDesigner Reference Manual.

To archive your design, perform the following steps:

1. Open the Archive wizard with the Tools > Archiver pulldown menu item.
2. In the Options screen, select the project you want to archive and the target directory for the output.
3. If you want the output compressed, click the Compress using zip format check box.
4. If you want all the sheets saved in pdf format, click the Create pdf check box.
5. Click Next.
6. Enter any additional files you want to include in the archive.
7. Click Finish.

The Archiver produces the archive file in the format and location you specified. It also reports results to a log file in the standard directory, and to the Results screen.

To work on an archived project, simply open the archived .prj file in DxDesigner, uncompressing first if necessary.
Chapter 8
Printing, Plotting and Generating PDF

The following topics contain information on how to print and plot schematic sheets or symbol representations from DxDesigner, and how to create a PDF of your design.

- Printing in Windows
- Paper Tray Selection in UNIX
- Printing in UNIX
- Plotting in Windows
- Plotting in UNIX
- Generating a PDF of Your Design

Printing in Windows

The following topics describe how to print from Windows:

- Setup for Windows
- Printing the Current Sheet

Setup for Windows

Before you can print from the Windows version of DxDesigner for the first time, you must do the following:

- Connect the printer to the computer or network.
- Install a printer driver on the computer you are using.
- Add the printer to the computer you are using.

If you have not completed these tasks, please do so before attempting to print your schematic or symbol.

You can print the active window or a specified schematic sheet using the Window and Sheet options in the Print dialog box. You can also print an entire design using the File > Print Project option. As a special case, you can send your output to an HPGL file.

Because colors that are easy to work with during a DxDesigner session are not always the best colors to use for printing, DxDesigner allows you to define a viewing color and a printing color for each object. Refer to “Changing Object Colors” on page 46 for information about defining colors for graphical objects, components, text, and annotation objects.
Windows Environment Variables

To print from Windows, you use the following environment variables:

- WDIR (Required)
- HPGL_WIDTH_SCALE (Optional—used for HPGL output)
- HPGL_HEIGHT_SCALE (Optional—used for HPGL output)

Using WDIR

- WDIR is a required environment variable.
- You specify WDIR during your DxDesigner installation.

Using HPGL_WIDTH_SCALE and HPGL_HEIGHT_SCALE

If you are sending your output to HPGL, you can use the HPGL_WIDTH_SCALE and HPGL_HEIGHT_SCALE variables to scale the fonts in the HPGL plot file. The values you give to the variables are floating point numbers and are used as scaling constants.

- A value greater than 1 increases the font size.
- A value less than 1 reduces the font size.

Printing the Current Sheet

1. Choose File > Print from the main menu of DxDesigner.
2. Fill in the appropriate fields in the Print dialog box.
3. Click OK.

For more information about Print dialog box options, click the Help button on the dialog box.

Tip: If you want to use default print settings, click the toolbar button.

Paper Tray Selection in UNIX

DxDesigner’s plotting and printing functionality on UNIX does not let you select a specific printer input paper tray. It is suggested that you create a plot file for each page of your design or symbol of your design and then use the standard UNIX print commands (for example, lp) with the appropriate vendor-specific option switches to target the print job to the desired input paper tray of your printer.
To print a file to an HP LaserJet 5Si printer from an input tray containing 11x17 plain paper, enter the following:

```
lp -d<printer_name> -omtypePlain -o11x17 <filename>
```

Where `<printer_name>` represents the name of the printer as recognized by the UNIX system, and `<filename>` represents the name of the plot file created within DxDesigner through File >Plot or File >Plot Project...

**Note**

Please contact the vendor of your printer for further details on how to target the desired input paper tray of your printer.

To configure DxDesigner to plot to a file:

1. On the Windows command line, type

   `plotsetup`

2. Select the desired device file for your printer (for example, ps.des for generic postscript).

3. Select the File Output Option.

4. If you are plotting only a single schematic sheet or symbol, enter the filename you want to send the output to. Otherwise, DxDesigner will automatically generate names for the plot files based on the file names of the schematics or symbols, in addition to other factors.

Configuring parameters in the **Plot Setup...** utility only affect the Plot features of DxDesigner

**Printing in UNIX**

The following topics describe how to print from UNIX:

- Setup for UNIX
- Print the Current Sheet

**Setup for UNIX**

To set up a printer in UNIX:

1. Double-click Toolboxes and then Service & Documentation Center. This displays the Control Panel dialog box.

2. Double-click Printers. This displays the Printers dialog box.

3. Double-click Add New Printer. This displays the Add Printer wizard.
4. In the Add Printer wizard, do the following to define the settings for your printer:
   a. Click **Next** to start the wizard.
   b. In the Unix Printer field, type the network name of your printer or select the name from the list below. Click **Next**.
   c. In the Print Command field, change the UNIX command listed for printing (if necessary). If the default command in this field is correct, click **Next**.
   d. In the Printer Name field, type a more descriptive name for the printer (such as *HP LaserJet*), which will be displayed when you print from DxDesigner. In the Printer Description field, you can type even more information about this printer (such as *Engineering Laser Printer - 3rd floor*). Click **Next**.
   e. Review the information displayed and do one of the following:
      - Click **Back** to return to a previous wizard screen and make changes.
      - Click **Finish** to apply your printer settings.

**Print the Current Sheet**

1. Choose **File > Print** from the main menu of DxDesigner.
2. Fill in the appropriate fields in the Print dialog box.
3. Click **OK**.

**Plotting in Windows**

To plot the current sheet, perform the following steps:

1. Configure a Basic Plot
2. Export the Design to Metafile Format
3. Spool the Plot

**Configure a Basic Plot**

You can create a basic plot using the plotter’s default parameters, or customize your plot by configuring additional parameters.

Perform the following required tasks to **plot the current sheet using the plotter’s default parameters**:

1. Open the Plotting worksheet
2. Select the plotter device.
3. Select the size.

4. Select the view of the design that you will plot.

To open the plotting worksheet and select the plotter device:

1. From the command prompt, type plotsetup. This opens the plotting worksheet.

2. In the Devices box, select the device that matches your plotter.

To select the paper size:

- Click either a US or Metric Paper size.
  
  The contents of the X> and Y> boxes will reflect the size you have chosen.

Tip: You use the Plot Options worksheet to specify ZSIZE parameters or to define additional custom paper sizes.

To plot a full or zoomed view of the sheet:

1. In the Extents section, select an option as follows:

   - To plot the entire sheet, regardless of whether you are zoomed in when you initiate plotting, click Full Sheet.

   - To plot section of the sheet you are zoomed in to when you initiate plotting, click Zoomed View.

To complete the basic configuration:

- Click OK to close the plotting worksheet and save the parameters you have set.

Export the Design to Metafile Format

You export the design to a metafile format before you spool it to a plotter.

To export the design:

1. Open the design you want to plot.

2. Choose File > Export > Powerview Metafile from the main menu.

3. In the Save As dialog box, enter the path and name you want to save to.

   The default extension for the exported metafile is .met.
Spool the Plot

From a Windows DOS shell, type the following at the command prompt:

```
splplt -p <path><filename.met>
```

The file is plotted on the device you specified when you configured the plot.

Plotting in UNIX

The following topics describe plotting operations in UNIX:

- Plotting Setup in UNIX
- Plotting in UNIX Using Default Settings
- Plotting in UNIX Using Custom Settings

Plotting Setup in UNIX

Before you can plot a sheet, you must set up your environment. During installation, DxDesigner creates the following directory:

```
<install_directory>/standard/devdes
```

and populates this directory with .des (description) files for commonly used plotters. These description files are included on the installation CD. You can add plotters by copying their .des files to this directory.

To plot from UNIX, you use the following environment variables:

- WDIR (Required)
- SYSPLT (Required)
- HPGL_WIDTH_SCALE (Optional—used for HPGL output)
- HPGL_HEIGHT_SCALE (Optional—used for HPGL output)

Using WDIR and SYSPLT

- WDIR and SYSPLT are required environment variables on UNIX.
- You specify WDIR during your DxDesigner installation.
- You must manually specify SYSPLT by adding it to your .cshrc file. You can define SYSPLT as any writable directory. DxDesigner uses this directory to store temporary plotting files.
Using HPGL_WIDTH_SCALE and HPGL_HEIGHT_SCALE - Plotting

If you are sending your output to HPGL, you can use the HPGL_WIDTH_SCALE and HPGL_HEIGHT_SCALE variables to scale the fonts in the HPGL plot file. The values you give to the variables are floating point numbers and are used as scaling constants.

- A value greater than 1 increases the font size.
- A value less than 1 reduces the font size.

Plotting in UNIX Using Default Settings

Note

This procedure can only be used on UNIX. For information on plotting a design on the PC, refer to “Plotting in Windows” on page 146.

Note

To plot a design using default settings, you must first select a default device. You only need to do this once unless you want to change the default device.

Basic Plotting in UNIX

To use the plotter’s default settings, perform the following required tasks:

- Open the Plotting Worksheet dialog box.
- Select the plotter device.
- Select the paper size.
- Select the output device.
- Select the view of the design that you will plot.

To open the Plotting Worksheet and select a plotting device:

1. Choose File > Plot Setup from the main menu. This displays the Plotting Worksheet dialog box.
2. In the Devices list, select the device that matches your plotter.

Select the paper size:

- Under Paper Sizes, select either US or Metric.
  
  The values in the X> and Y> fields indicate the size you have selected.
You use the Plot Options worksheet to specify ZSIZE parameters or to define additional custom paper sizes.

**Select the output destination:**

Under Output, select one of the following:

- **FILE** — In the Output field, type the name of the plot file you want to create. If you do not enter a filename, the filename will default to the current sheet.
- **SPOOL** — Select this to spool the plot to a specified plotter.
- **Port...** — From the popup menu, select an available port (such as /dev/ttya).

**Select the view:**

You can plot a full or zoomed view of the sheet.

- To plot the entire sheet, regardless of whether you are zoomed in when you initiate plotting, click Full Sheet.
- To plot the section of the sheet at the current zoom setting, click Zoomed View.

**Complete the configuration:**

- Click **OK** to close the Plotting Worksheet and save your settings.

**Plotting in UNIX Using Custom Settings**

You can define customize settings for your plot from the following dialog boxes, which you can display from the Plotting Worksheet:

- **Plot Options (click OPTIONS...)**
- **Plot Graphics (click Graphics...)**

**Plot Options Dialog Box**

The Plot Options dialog box provides the following customizations:

- Specifying paper size for ZSIZE.
- Creating and specifying new custom paper sizes.
- Sending control strings to your plotter.
- Selecting a directory to hold your FILE output.

**To specify ZSIZE Paper Size:**

1. In the Paper Size area of the Plotting Worksheet, click the **ZSIZE** button.
2. Click **Options** to open the Plot Options worksheet.

3. Fill in the boxes in the DEFINE ALTERNATE PAPER SIZE area.
   - The Name: box displays ZSIZE. Do not change this box. If you want to create a custom paper size with a new name, click here for instructions.
   - In the Range: boxes, enter the length (X>) and width (Y>) of the paper in inches or millimeters.
   - In the Margins: boxes enter the Left>, Right>, Top> and Bottom> margins in inches or millimeters.

**To create a new custom paper size and define its measurements:**

1. From the Plotting Worksheet, select any US or Metric paper size, depending on the type units you want to use.
   
   **Note:** It does not matter which size you select. You select a size to tell Plot Setup whether to add a sheet using US or Metric units.

2. Click **Options** to open the Plot Options worksheet.

3. Fill in the boxes in the DEFINE ALTERNATE PAPER SIZE area.

4. In the Name: box, enter the name of the new custom paper size.

5. In the Range: boxes, enter the length (X>) and width (Y>) of the paper in inches or millimeters.

6. In the Margins: boxes enter the Left>, Right>, Top> and Bottom> margins in inches or millimeters.

   The new paper size is added as a selection in the Paper Sizes section of the Plotting Worksheet. It will be added to the US or Metric size list depending on which units you selected in step 1.

**To place a string at the beginning or end of your plot output:**

You can place control strings at the beginning or end of your plot file. You can also send control form feed behavior of the plotter by enabling an automatic control string.

1. From the Plotting Worksheet, click **Options** to open the Plot Options worksheet.

2. Enter the string you wish to prepend in the Init String> box. You can leave the box blank.

3. Enter the string you wish to append in the Term. String> box. You can leave the box blank.

**To specify a Form Feed:**

- Select Feed On to enable form feed or deselect Feed On to disable form feed.
If you select Feed On, DxDesigner will place a form feed control string before each plot.

**To select a directory for your file output:**

You can select a directory to hold your File output when you are not sending your output directly to the printer:

1. In the Output area of the Plotting worksheet, click **FILE**.
2. In the Output> box, enter the name you want to use for the output file. Do not enter a path.
3. Click **Options** to open the Plot Options worksheet.
4. In the Out Directory> box, enter the full path to the directory where you want to store the output file. Do not enter the output filename.

**Note**

If you do not enter a directory, your file will be placed in the current project directory.

**Plot Graphics Dialog Box**

The Plot Graphics dialog box allows you to do the following customizations:

- To specify a font:
- To specify scaling constants:
- To specify a fit rectangle:
- To set the plot origin:
- To specify a rotation:
- To enable automatic rotation for best fit:
- To partition an image:
- To set line width:
- To select device rendering:

Your plotter may not support all of these options.

**To specify a font:**

You can specify a font for the text on your plot if font rendering is supported for your plotter.

1. From the Plotting Worksheet, click Graphics to open the Plot Graphics worksheet.
2. In the font area, select the font you want to use.
3. Click Device Text to enable font rendering.
To specify scaling constants:

1. From the Plotting Worksheet, click Graphics to open the Plot Graphics worksheet.
2. Enter a scaling multiplier in the Scale X> and Scale Y> boxes. To reduce the size of the plot, enter a decimal number between zero and one.
   The plotting image is multiplied by the scaling constants you have specified.

To specify a fit rectangle:

1. From the Plotting Worksheet, click Graphics to open the Plot Graphics worksheet.
2. Enter the X> and Y> measurements of the fit rectangle. If you have selected US paper size, units are inches. If you have selected Metric paper size, units are millimeters.
   The plotting image is scaled to fit the rectangle by stretching or compressing it along the X- and/or Y-axis.

To set the plot origin:

You can set the location of the lower left corner of the plot (plot origin) relative to the lower left corner of the paper as follows:

1. From the Plotting Worksheet, click Graphics to open the Plot Graphics worksheet.
2. Select Enable Corner.
3. In the boxes to the right of Enable Corner, specify the offset of the X> and Y> positions from the corner of the paper. If you have selected US paper size, units are inches. If you have selected Metric paper size, units are millimeters.

To specify a rotation:

1. From the Plotting Worksheet, click Graphics to open the Plot Graphics worksheet.
2. In the Plot Expansion area, select ALIGN.
3. In the Rotation area of the worksheet, select a rotation amount. You can rotate the plot on the paper by 0, 90, 180, or 270 degrees. The plot will rotate counterclockwise.

To enable automatic rotation for best fit:

1. From the Plotting Worksheet, click Graphics to open the Plot Graphics worksheet.
2. In the Plot Expansion area, select BESTFIT.
To partition an image:

You can partition an image so that it can plot onto several smaller-sized sheets. Tiling works only with plotters that support form feed.

1. From the Plotting Worksheet, click **Graphics** to open the Plot Graphics worksheet.
2. Select Enable Tile.
3. In the boxes to the right of Enable Tile, specify the number of Rows and Columns into which you want to partition the image.
4. Select a Tiled Output size to specify the size of the sheet your plot will be printed on.

If you select ZSIZE, a dialog opens to allow you to specify the ZSIZE dimensions for the tiling output. When you disable tiling, the system returns the ZSIZE dimensions to those you have previously specified.

**Example 1: Tile one D-size sheet onto two C-size sheets**

A D-size sheet measures 22 by 34. A C-size sheet measures 22 by 17. To tile a design that was created on a D-size sheet into two C-size sheets, you would specify 2 rows and 1 column.

**Example 2: Tile one D-size sheet onto four B-size sheets**

A D-size sheet measures 22 by 34. A B-size sheet measures 11 by 17. To tile a design that was created on a D-size sheet into four B-size sheets, you would specify 2 rows by 2 columns.

To set line width:

If you are plotting to a PostScript plotter, you can set a line width for graphics. You specify line width in device units.

1. From the Plotting Worksheet, click **Graphics** to open the Plot Graphics worksheet.
2. Drag the Line Width slide to the right for a thicker line or to the left for a thinner line.

   The line width you have specified is displayed in the box to the left of the slide.

**Select Device Rendering**

If your plotter supports it, you can select a method to render objects. You make your selection to optimize for display resolution or speed. You can select rendering for Text, Arc, Circle and/or Box, depending on your plotter. Any unsupported rendering will be unavailable.

Select Device to render the object directly by the output device. This improves speed, but may degrade resolution.
Deselect Device to render the object using an internal algorithm. This produces WYSIWYG resolution, but degrades speed.

**To select device rendering:**

1. From the Plotting Worksheet, click **Graphics** to open the Plot Graphics worksheet.
2. Select Device Text, Device Arc, Device Circle and/or Device Box to enable rendering for that object.

## Generating a PDF of Your Design

You use DxPDF to read a DxDesigner schematic, generate a hierarchical representation of the schematic design, and then save the design as an Adobe Acrobat PDF file. During this process, DxPDF preserves the hierarchy of the design and cross references the nets.

You can distribute the generated PDF design to other design team members. You can also use DxPDF in conjunction with enterprise wide data management systems to store and distribute schematic design data.

For more information on DxPDF setup and options, see **DxPDF Dialog** in the *DxDesigner Reference Manual*.

**To generate a PDF file Using the DxPDF Graphical User Interface:**

1. Select **File > Export > PDF**.
2. Fill in the General, Advanced, and Fonts tabs. See the “**DxPDF Dialog**” topic in the *DxDesigner Reference Manual* for details.
3. Click **Run**.

**Result:** DxPDF displays information about the status of the PDF file it generates in the Output window. You can use this information to diagnose any problems that occur during the conversion process. If you selected the Start Acrobat Reader check box, DxPDF displays the design in Adobe Acrobat. You can search for any text that is visible on the schematic. If you cleared the Start Acrobat Reader check box, DxPDF generates a PDF file and saves it in the folder where the DxDesigner project is located.
Chapter 9
Generating Bills of Materials

The following topics provide information on using the Part Lister to generate bills of materials:

- General Part Lister Information and Operation
- Using Part Lister from the DxDesigner Window
- Using Part Lister from the Command Line
- Output File Format

General Part Lister Information and Operation

The Part Lister reads schematic databases to extract component property information for generating data files of user-defined format and content. The property data you extract can be any user- or Mentor Graphics-defined symbol (unattached) property. Using the dialog box options or settings in the icdbpartslistert.ipl file, you can easily specify the resulting file format. For specific information on the icdbpartslistert.ipl file, refer to Part Lister Initialization File topic in the DxDesigner Reference Manual.

Why Use Part Lister?

You can use the Part Lister to generate reports such as the following:

- Parts lists
- Cost estimate summaries
- Printed circuit board area requirements
- MRP (Manufacturing Resource Planning) reports
- Bill of materials

To access and configure the Part Lister, use the DxDesigner pulldown menu Tools > Part Lister to bring up the Part Lister dialog box.

Default settings for the Part Lister are stored in a file called $SDD_HOME\standard\icdbPartsLister.ipl.

You can save customized settings with the Part Lister dialog > File > Save As command.
Generating Bills of Materials

Using Part Lister from the DxDesigner Window

Note

To avoid accidentally overwriting your default icdbPartsLister.ipl file, you should always save your customized settings with the Part Lister dialog > File > Save As command, before you click Run.

You can use your saved settings by using the Part Lister dialog > File > Open command and navigating to the desired .ipl file. If desired, you could also modify a .ipl with an editor prior to opening it with Part Lister.

Using Part Lister from the DxDesigner Window

To invoke Part Lister from DxDesigner, select Tools > Part Lister from the menu bar. The Part Lister dialog opens in a separate window.

The Part Lister dialog has three tabs:

- Settings
- Page
- Columns

From the Settings tab, you set the path to the project and block, and choose the type of output you want.

From the Page tab, you select the page size, margins, headers, and spacing.

From the Columns tab, you set up the spreadsheet columns for your output, and define the items and labels for the columns.

For specific information on the Part Lister GUI, refer to Part Lister Dialog topic in the DxDesigner Reference Manual

Using Part Lister from the Command Line

You invoke Part Lister from the command line by typing:

```
icdbpartslister.exe [-o path][-i path]...[-b name][-d path][--]
[--version][-h]
```

Where:

- `-o path`, `--output path` — The output file path
- `-i path`, `--config path` — The configuration file path. You can enter multiple configuration file paths.
-b name, --block name — The block name.
-d path, --projectpath path — The path to the project file.
--ignore_rest — Ignore any labeled arguments following this flag.
--version — Display version information and exit.
-h, -help — Display usage information and exit.

Output File Format

The way the output file appears is dependent on two things: the design, and the initialization file. The design is the data source, and the initialization file dictates what data will appear and how it will appear in the output file.

As an example, below is an output file generated for a simple mixed signal design:

```
test Wednesday, September 29, 1993 11:41 am Page 1

TEST_CIRCUIT

REVISION_HISTORY:
REV0
REV1

# QTY REF DESC TOLR WATT VALUE
----------------------------------
  1 1 C1 100UF
  2 1 R1 2% .1W 10K
  3 3 U1,U3,U4 14PDIP
  4 1 U2 16PDIP
-----
  6.0
```

In this example, the initialization file specified the column labels, retrieved the values of the properties associated with the labels, and put these values in columns defined in the initialization file. For specific information on the output file, refer to Part Lister - Settings Tab topic in the DxDesigner Reference Manual.
Appendix A
Troubleshooting Your Environment

DxDesigner Diagnostics let you troubleshoot your working environment by displaying information on the following:

- Your Host ID (PC only)
- The value of LM_LICENSE_FILE, your licensing environment variable
- Server information (networked-client license only)
- Locate DxDesigner-specific files

To start DxDesigner Diagnostics:

1. In the Dashboard Folders Pane, double-click Toolboxes, and then click Service and Documentation Center.
2. In the Application Launch Pad, double-click Diagnostics.

Related Topics

- Troubleshooting DxDesigner Environment Variables
- Troubleshooting Your License
- Finding Files in your PATH or WDIR

Troubleshooting DxDesigner Environment Variables

DxDesigner uses environment variables to define specific file and directory locations. DxDesigner sets the values for these environment variables during installation. You use DxDesigner Diagnostics to confirm that these environment variables are set correctly.
To view your DxDesigner environment variables:

- In the DxDesigner Diagnostics dialog box, select the **Environment** Tab. The tab displays the following information, that you can use to confirm that your environment variables are set correctly.

### Table A-1. Environment Variable Diagnostics

<table>
<thead>
<tr>
<th>Environment Variable</th>
<th>Getting information</th>
</tr>
</thead>
</table>
| **PATH** - a list of directories through which the operating system searches to find executables. | • Shows all of the directories specified in your PATH environment variable. Click an item to see the contents of that directory in the right-hand box.  
• Verify that PATH points to the location of the DxDesigner executables you want to run. |
| **WDIR** - a writable directory used to store system and user files. WDIR is the first directory DxDesigner searches when looking for information such as an .ini file. | • Shows all of the directories specified in your WDIR environment variable. Click an item to see the contents of that directory in the right-hand box.  
• Verify that the WDIR variable points to a local writable directory: |
| **LM_LICENSE_FILE** - points directly to a license file, or to a license server using the <port>@<host> terminology. | • Show the entries specified in the LM_LICENSE_FILE variable. Click an entry to see the PortID (tcp/ip port) and hostname in the right-hand box.  
• Verify that the LM_LICENSE_FILE variable on each client points to a valid the license file using either the port@hostname of the license server or the explicit path to the license file. For example:  
  LM_LICENSE_FILE=7654@<NT_server_name>  
  LM_LICENSE_FILE=<dir_path>/<license_path> |
| **OTHER** - This box lists any environment variables other than PATH, WDIR and LM_LICENSE_FILE. | • The contents of this box change depending on your individual environment.  
• Click a variable to see its value in the right-hand box.  
• Refer to specific component documentation for correct environment variable values. |
You can get troubleshooting information about your license from the Licensing tab of the Diagnostics dialog box. Use the following information as a guide to using the tab.

### Table A-2. Diagnostics Dialog Box - Licensing Tab Items

<table>
<thead>
<tr>
<th>Dialog Box Item</th>
<th>Troubleshooting tips</th>
</tr>
</thead>
</table>
| Host ID box       | Reads the HostID from the key or ethernet card of a node-locked system  
• PC only  
• If the box says “not available”, it could mean  
   • You may be using network licensing  
   • You may not have installed the Sentinel Driver, or you may have installed it incorrectly. For information on installing the Sentinel Driver, refer to the FlexLM End User’s Guide, located in the common\doc directory of your install tree.  
   • You have a bad parallel port  
   • You have a bad ethernet card  
   • You have a bad key |
| Variable/Value box| Lists all license-related environment variables and the values of the variables that are used.  
• Select a used variable. Its values appear in the box below the Variable/Value box. Click on a value to display more information |
| Licensing Diagnostic Tools | Provides additional information about your license.  
• **See if license server is running** -- Checks if server and Daemon are running.  
  • Enable by selecting an entry in the Variable/Value box  
  • Works for network licenses only  
• **See who has licenses in use** -- Lists, by tool, the name of each user who has a currently checked-out license  
  • Enable by selecting an entry in the Variable/Value box  
  • Works for network licenses only  
• **Get list of all licenses** -- Lists the total number of licenses available for each licensed tool.  
  • Enable by selecting an entry in the Variable/Value box  
  • Works for network licenses only  
• **Get HostID from Ethernet card** -- reads the HostID from the address of the ethernet card  
  • Ethernet card may be local, or attached to the workstation you are logged into |
| Clear Summary     | Click to clear old information from the results box. If you do not clear the results box, new output appends to existing information. |
Running Licensing Utilities From the Command Line

You can run licensing utilities from the Windows or UNIX command line. The following table gives Windows and UNIX equivalents to utilities available in the Licensing tab of the Diagnostics dialog box.

<table>
<thead>
<tr>
<th>Utility</th>
<th>PC Command</th>
<th>UNIX Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>LM_LICENSE_FILE</td>
<td>set LM_LICENSE_FILE</td>
<td>printenv LM_LICENSE_FILE</td>
</tr>
<tr>
<td>See if license server is running</td>
<td>lmutil lmstat</td>
<td>lmstat</td>
</tr>
<tr>
<td>See who has licenses in use</td>
<td>lmutil lmstat -A</td>
<td>lmstat -A</td>
</tr>
<tr>
<td>Get list of all licenses</td>
<td>lmutil lmstat -a</td>
<td>lmstat -a</td>
</tr>
<tr>
<td>Get hostid from Ethernet card</td>
<td>lmutil lmhostid</td>
<td>lmhostid</td>
</tr>
</tbody>
</table>

Finding Files in your PATH or WDIR

When troubleshooting your working environment, you may need to confirm the presence of files such as a viewdraw.ini file, the appropriate draw.ini-controlled file, or PCB configuration file. You use the Find File tab of the Diagnostics dialog box to search for files in the locations defined by either your PATH or WDIR environment variables. If you do not find the files, you may need to edit these environment variables.

To find a file:

1. In the Filename box, enter the name of the file you want to find
2. Click either Search through all directories in PATH or Search through all directories in WDIR, and then click Find.

*Tip:* Your results will append to the information in the output window. To clear the output window, click Clear Summary
Appendix B
Using VHDL and Verilog in DxDesigner

From within DxDesigner, you can netlist your design to VHDL or Verilog design files that can be used for simulation as described in the following topics:

- **Preparing Schematic Designs for Export to ModelSim**
  Shows the process you would use with ModelSim and VHDL to export a schematic into ModelSim and import simulation data back to DxDesigner.

- **Using VHDL or Verilog Symbols in a Schematic**
  Described how you can create a schematic in DxDesigner where each of the components represents a VHDL or Verilog model.

- **Inserting VHDL and SPICE Files onto a Schematic**
  Describes how you can use the Windows drag-and-drop action to insert VHDL (.vhd) and SPICE (.cir, .ckt, .mod, .spi) files directly from a Windows Explorer directory onto a schematic.

**Preparing Schematic Designs for Export to ModelSim**

Within DxDesigner, you can export a schematic design into VHDL design files for simulation in ModelSim, a mixed-language simulator for Verilog, VHDL, and mixed-language design. After you import the VHDL design files into ModelSim, you simulate the design using an interactive simulation process. At any time during the process, you can pause the simulator and, using a snapshot of the ModelSim data at that point in time, you can then import data back into DxDesigner to update the original schematic and its nets using the simulation values.
The following diagram outlines this process:

![Diagram]

**Creating Schematics that Export Correctly to VHDL**

When creating schematic designs within DxDesigner, name all VHDL basic identifiers (signals, variables, entity architectures, and so on) as follows:

- Start the name with an alphanumeric character
- Use only alphanumeric characters and underscores
- Do not use sequential underscores or end with an underscore

In addition to the above rules, observe the following naming guidelines for busses and symbol pins so that you can update schematics with simulation results without ambiguity.
The following table shows DxDesigner bus and symbol pin naming guidelines for VHDL data transfer:

### Table B-1. Naming Guidelines for VHDL Data Transfer

<table>
<thead>
<tr>
<th>Item</th>
<th>Rule</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Bus</strong></td>
<td>Use square brackets only to specify bus ranges, slices, or indices.</td>
</tr>
<tr>
<td></td>
<td><strong>Tip:</strong> Enclose individual bits of a bus, as in BUS[2].</td>
</tr>
<tr>
<td></td>
<td>• Declare busses in full somewhere on the schematic level.</td>
</tr>
<tr>
<td></td>
<td><strong>Example:</strong> If the schematic uses bits 0 through 15 of a bus named BUS, then BUS[0:15] or BUS[15:0] should appear somewhere on the schematic.</td>
</tr>
<tr>
<td></td>
<td>• Reference a range of bus elements in the same direction as the full bus.</td>
</tr>
<tr>
<td></td>
<td><strong>Example:</strong> If a design has BUS[15:0], use BUS[7:4] to refer to this slice of BUS[15:0].</td>
</tr>
<tr>
<td></td>
<td>• Place bus ranges at the right of the bus name whenever possible.</td>
</tr>
<tr>
<td></td>
<td><strong>Example:</strong> Use the name BUSA[15:0] rather than BUS[15:0]A or [15:0]BUSA.</td>
</tr>
<tr>
<td></td>
<td>• Avoid bus bundles, such as A[1:0],B[1:0],C, which are difficult to properly represent in VHDL.</td>
</tr>
<tr>
<td></td>
<td>• Avoid stepped busses.</td>
</tr>
<tr>
<td></td>
<td><strong>Rationale:</strong> Schematic busses can have a step specification, but this can also cause confusion. For example, BUS[7:0:2] is four bits wide, and the valid indices are 7, 5, 3, and 1. Because VHDL does not support noncontiguous busses, this construct will be declared in VHDL as being eight bits wide, with the bits 6, 4, 2, and 0 left unconnected. When you import the simulation values back into DxDesigner, the value for this signal will then have eight bits as opposed to the four bits actually desired.</td>
</tr>
<tr>
<td><strong>Symbol pin</strong></td>
<td>Specify unique names for symbol pins and the net names on the symbol's schematic.</td>
</tr>
<tr>
<td></td>
<td><strong>Rationale:</strong> DxDesigner symbols that have two pins with the same name cannot be directly translated to VHDL. For example, you will not be able to translate a symbol that has two pins with the same name and a unique range, such as BUS[15:8] and BUS[7:0].</td>
</tr>
</tbody>
</table>

### Creating a ModelSim Project

1. From within ModelSim, create a project file in the DxDesigner project directory, specifying the name you want for the project.
   
   **Rule:** The filename you specify will automatically be given a .mpf extension, as in mymodelsimproject.mpf.

2. Add the VHDL source for all leaf nodes to the project.
Exporting the DxDesigner Schematic to VHDL

You access the VHDL Netlister from the File > Export > VHDL Netlist menu. The VHDL Netlister dialog box appears. For more information, refer to the VHDL Netlister Dialog topic in the DxDesigner Reference Manual.

Importing a Netlist into ModelSim

After you export a DxDesigner schematic to VHDL and generate a VHDL netlist for it, you can work with schematic data in ModelSim. To do so, you import the VHDL netlist into ModelSim.

To import the netlist into ModelSim:

1. Add the generated VHDL files to the ModelSim project using a depth-first order to create a proper file compile order.
2. Compile the files, reordering them as necessary.
3. Load the top-level VHDL design into the ModelSim simulator using the same name as the top-level DxDesigner schematic.

For more information, see the ModelSim documentation that is shipped with the product.

Importing Data from ModelSim into DxDesigner

To import simulation data resulting from the ModelSim simulation process into DxDesigner, you can either enter a command to send the data when desired, or set up your system so that data is automatically sent each time you start the simulator. (Every time the simulator pauses, data is automatically sent back to the DxDesigner schematic.)

Exception: Unless a net has a user-supplied label and a unique ID (for example, $N9, $1N32, and so on), its simulation value will not be updated onto the schematic.

When you send ModelSim data to DxDesigner, one of the following shared object files from root/3.1/common/arch/lib is loaded so that you can transfer the data:

- dx2ms.dll (Windows)
- libdx2ms.so (Solaris)
- libdx2ms.sl (HP/UX)

To manually import ModelSim data into DxDesigner:

From the ModelSim simulation command prompt, enter one of the following load command strings consisting of a path to the shared object file and the ba option, depending on your platform:
• load \path\dx2ms.dll  ba
• load \path\libdx2ms.so  ba
• load \path\libdx2ms.sl  ba

The DxDesigner schematic is updated with the simulation values. The current simulation time appears in the lower right-hand corner of the active schematic sheet.

Tip: In addition to the ba command option specified above that explicitly requests the import of data from DxDesigner, you can also enter the following commands from either a ModelSim or DxDesigner command prompt.

ModelSim load command options are shown as follows:

Table B-2. ModelSim load Command Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
</table>
| von    | Turns on the display of the data being imported and leaves it on as the default setting until you turn it off.  
Tip: The ba option invokes von automatically. |
| voff   | Turns off the display of the data being imported. |

To automatically import ModelSim data into DxDesigner each time you run the simulator:

1. Within the DxDesigner project directory, use a text editor to create a file named startup.do.
2. Within the file named startup.do, type one of the following text strings depending on your platform, and then save the file:
   • load <path>/dx2ms.dll  ba
   • load <path>/libdx2ms.so  ba
   • load <path>/libdx2ms.sl  ba
3. Open the project.mpf file in the DxDesigner project directory, search the file for the following line, and then remove the semicolon that appears at the beginning of the expression:
   
   ;startup = do startup.do

ModelSim data for this project will automatically be sent to DxDesigner each time you start the simulator and the simulator pauses.

Tip: To automatically send ModelSim data to DxDesigner each time you run the simulator for all your projects, modify the modelsim.ini file in the ModelSim install directory as described above rather than modifying the .mpf project file.
Using VHDL or Verilog Symbols in a Schematic

You can create a schematic in DxDesigner where each of the components represents a VHDL or Verilog model. The structural design can be either flat or hierarchical. See one of the following topics for more information.

- Creating a VHDL Symbol
- Creating a Verilog Symbol

Creating a VHDL Symbol

You create a VHDL symbol with Library Manager. For more information, see “Creating a DxDesigner Symbol Using Dx Symbol Editor (DxD-Expedition Flow)” in the Library Manager Process Guide.

Once you have created the symbol and placed it in a schematic, you can simulate the entire design.

Simulate the Entire Design - VHDL

1. Export the design to a VDHL netlist in one of the following ways:

   To export from the DxDesigner User Interface:
   
   i. Select File > Export > VHDL Netlist.
   
   ii. Fill in the VHDL Netlister dialog box. (Also see the VHDL Netlister Dialog topic in the DxDesigner Reference Manual)

   To export from the System Command Prompt:
   
   • Type icdb2vhdl [-option|-option=argument]

2. Simulate the design using ModelSim and the generated VHDL netlist.

Creating a Verilog Symbol

You create a Verilog symbol with Library Manager. For more information, see “Creating a DxDesigner Symbol Using Dx Symbol Editor (DxD-Expedition Flow)” in the Library Manager Process Guide.

Once you have created the symbol and placed it in a schematic, you can simulate the entire design.
Simulate the Entire Design - Verilog

1. Export the design to a Verilog netlist in one of the following ways:

   **To export from the DxDesigner User Interface:**
   
   i. Select **File > Export > Verilog Netlist**.
   
   ii. Fill in the Verilog Netlister dialog box.

   **To export from the System Command Prompt:**
   
   • Type `icdb2vlog [-option|-option=argument]`

2. Simulate the design using ModelSim and the generated Verilog netlist.

Inserting VHDL and SPICE Files onto a Schematic

You can use the Windows drag-and-drop action to insert VHDL (.vhd) and SPICE (.cir, .ckt, .mod, .spi) files directly from a Windows Explorer directory onto a schematic. When you do this, DxDesigner automatically creates a symbol for the file. If the file contains multiple model descriptions, then a dropdown menu lets you select a component from the file when you drop the file onto the schematic.

The name of the generated symbol is the same as the name of the VHDL entity or the SPICE model. DxDesigner adds attributes to the symbol to support netlisting for simulation.

Insert a File over an Existing Symbol

When you and drag and drop a VHDL or SPICE file onto a schematic, you can edit the resulting symbol contains all of its original attributes and it just like any other symbol. If the symbol already exists, the existing symbol attaches to the cursor, and you can place it on the schematic.
The following topics describe how to link and embed objects in your DxDesigner document:

- Inserting Objects
- Embedding an Object
- Linking Objects

**Inserting Objects**

**Note**

This functionality is not available on UNIX.

You can include information or documents created in other applications in your DxDesigner document. You can link or embed documents or objects in your DxDesigner documents. The main difference between linking and embedding is where the data is stored. If you embed the object, the data becomes part of your DxDesigner document. If you link the object, the DxDesigner document stores only the location of the information and then displays a graphic representation of the information in the DxDesigner document.

**Note**

On the PC, you can insert objects on to border symbols and they will also be shown on the schematic that the border is inserted on.

**Embedding an Object**

You can embed a new or existing object into your DxDesigner document.

**To embed a new object:**

1. Position the insertion point where you want to embed the object in the document.
2. Select **Add > Insert Object**.
3. Select the Create New option.
4. Select the Object Type that you want to create.
Linking and Embedding Objects

Linking Objects

The list of options in this list depends on the applications you have installed on your computer. You cannot insert objects created by an application that you do not have installed.

5. Click **OK**.

6. Return to DxDesigner.

7. Exit the application used to create the object or click anywhere in the schematic editor.

To embed an existing object:

1. Position the insertion point where you want to embed the object in the document.

2. Choose **Add > Insert Object**.

3. Select the Create from File option.

4. Enter or select the file name of the object you want to embed.
   
   You can use the Browse button to search for and select the file.

5. Click **OK**.

6. If you want to display the object as an icon, click the Display as Icon check box before clicking **OK**.

7. Return to DxDesigner.

8. Click anywhere in the DxDesigner window.

Converting an Embedded Object to a Different File Format

You can convert the object to a different file format by selecting a different application to be the object's source application.

Linking Objects

You can create a link to an object to share the object between two DxDesigner documents or a DxDesigner document and a file created in another application. You must be running both applications, and both applications must support dynamic data exchange (DDE) or object linking and embedding (OLE).

To create a link to another file or Word document:

1. Make sure that you save the source file before you link the information.

2. In the application in which the information you want to link was created, open the source file and then select the information you want to link.
3. Select **Edit > Copy**.

4. Switch to the DxDesigner document and position the cursor on the insertion point where you want to insert the linked information.

5. Select **Edit > Paste Special**.

6. Select the Paste Link Option button.

7. In the As box, select the appropriate option.

8. Click **OK**.
Index

— A —
Adding
arc to schematic, 103
array, 35
box to schematic, 103
circle to schematic, 103
constraints with Constraint Editor System (CES), 85
graphics to schematic, 103
line to schematic, 104
specialized pins to symbol, 55
text to schematic, 102
Adding nets to pins
automatically, 67
manually, 67
with Advanced Connect, 68
Aliasng nets, 91
Arc
adding to schematic, 103
Archiving
projects, introduction, 141
See also Project Archive
Arguments
DxDesigner, 45
using with Tools menu, 45
Array
adding, 35

— B —
Block
adding in ICT, 72
blocks, 25
Border, 47
applying/removing/changing, 53
changing on schematic, 54
configuration, definition of, 50
creating, 48
creating configuration, 51
deleting from schematic, 54
editing schematic, introduction, 63
inserting on schematic, 54
specifying configuration file location, 50
Box
adding to schematic, 103
Bus
adding, 96
connecting components with, 96
ripping in ICT, 73
selecting, 106

— C —
Changing, See Customizing
Circle
adding to schematic, 103
Color preferences in IC, 74
Columns
adjusting width, 70
grouping, 69
hiding, 70
unhiding, 71
Command line commands
arc, 103
box, 103
circle, 103
copy, 109
executing, 37
line, 104
pop, 30
psch, 31
psh, 30
psheet, 30
scale, 33
schematic, 63
size, 33
slabell, 107
sname, 107
stext, 107
stretch, 34
string, 36
svalue, 107
text, 102
zselect, 35

Commands
Add Block in ICT, 72
Advanced Connect, 68
Flip, 101
Mirror, 101
Push ICT, 72
Push Schematic, 72
Resize Box, 100
Rip Nets, 100

Component
connecting with busses, 96
connecting, introduction, 85
disconnecting, 87
handling mechanical parts, 83
handling test points, 84
placing, 65
renaming, 66
selecting, 106
selecting multiple with same name, 106
specifying the characteristics of,
introduction, 79
synchronizing with associate symbol, 78

Configuring, See Customizing

Connection
automatically creating by net label names,
87
creating dangling, 87
creating intersecting, 87

Connectivity
routing modes, 86

Constraint Editor System (CES)
adding with, 85
setting up constraints in, 57

Copying
objects, 34

Creating
connections by net label names, 87
dangling connections, 87
intersecting connections, 87
ModelSim project, 167
nets, introduction, 89
new project, introduction, 22
new schematic, 62

schematic to export to VHDL, 166
schematic, preparations, 63
Verilog symbol, 170
VHDL symbol, 170

Cursor
changing appearance of, 46

Customizing
appearance of cursor, 46
border on schematic, 54
Dashboard, 39
object colors, 46
Pintype arrows, 46
specialized pin symbols, 56
Tools menu, 43

Cutting objects, 34

Dangling
creating connections, 87

Dashboard
customizing, 39
invoking, 21

Data
exchanging with other tools, 123

Dialog box
Find/Replace, 36
Net Short, 92
Quick Connection View, 131
Split Net, 95

Differential pairs
creating, 94
creating in ICT, 73
removing from ICT, 73

Docked window
converting to floating window, 18
description, 17

DxDesigner
customizing workspace, 46
finding information within, 16
importing data from ModelSim, 168
invoking from a Command window, 21
invoking from Dashboard, 21
invoking from UNIX or LINUX, 21
invoking from Windows Start menu, 21
switching between releases of flows, 17
troubleshooting environment variables, 161
understanding user interface, 17
using VHDL and Verilog, 165
using VHDL and Verilog in, 165
window types, 17
DxPDF
generating PDF file using, 155
introduction, 155
— E —
Embedding
  existing object, 174
  new object, 173
  See also Object
Environment
  troubleshooting, 161
Exporting
  a design to metafile format, 147
— F —
Files
  finding in PATH or WDIR, 164
Filtering
  object selection, 108
Find/Replace dialog box, 36
Finding
  information within DxDesigner, 16
Flat design
  contrasted with hierarchical design, 61
  traversing sheets, 30
Flip, 101
Floating window
  converting to docked window, 18
  description, 18
Fonts
  for plotting, 152
  scaling, 144
  scaling in HPGL plot file, 149
Foreign database
  working with, 126
Form feed, plotting, 151
FUB
  deleting pins, 121
  placing on top-level schematic, 120
— G —
Graphics
  adding to schematic, 103
Grouping rows and columns, 69
— H —
Hierarchical design
  contrasted with flat design, 61
  creating using bottom-up method, 115
  introduction, 115
  See also OATs, Occurrence Attributes
  selecting a design methodology, 115
  traversing sheets, 31
Hierarchy tab, ICT viewer, 75
hierarchy, project, 25
— I —
ICE, 64
ICT viewer, 75
  Hierarchy tab, 75
  Net Properties tab, 75
  Reset All Filters, 75
  Symbol Properties tab, 75
Inserting serial components, 95
Interconnectivity Editor, 64
Interconnectivity table
  color preferences, 74
  creating and editing, 64
  creating from schematic, 65
  creating from scratch, 64
  splitting horizontally, 74
  splitting vertically, 74
  viewer, 75
— L —
Label
  selecting from command line, 107
  selecting it and associated object from command line, 107
leaf cells, 25
Licensing utilities
  running from command line, 164
Line
  adding to schematic, 104
Line width, plotting, 154
Linking
objects, 174

— M —
Mechanical parts, 83
Merging nets, 92
Metafile
  exporting design to metafile format, 147
Mirror, 101
Mode
  avoidance routing, 86
  orthogonal routing, 86
  routing, 86
  straight routing, 86
ModelSim, 165
  creating project, 167
  importing data into DxDesigner from, 168
  importing netlist into, 168
  preparing schematic to export to, 165

— N —
Navigator
  using, 25
Net Properties, ICT viewer, 75
Net Short
  dialog box, 92
Nets
  add to active schematic, 90
  aliasing, 91
  automatically attaching pin to existing, 93
  automatically creating connections by label names, 87
  connecting to block in ICT, 73
  creating and editing, introduction, 89
  deleting, 90
  merging, 92
  over-ride the default line width, 90
  renaming, 69, 90
  ripping, 97
  selecting, 106
  set default display characteristics, 89
  sorting, 69
  spacing, 100
  viewing associated component, 31
Non-graphical mode, 64

— O —
OATs, Occurrence Attributes
  See also Hierarchical design
Object
  changing colors of, 46
  converting embedded object to different file format, 174
  copying, 109
  cutting or copying, 34
  embedding, 173
  filtering selection choices, 108
  inserting, 173
  linking, 174
  linking and embedding, introduction, 173
  manipulating from Navigator, 27
  pasting from clipboard, 34
  reflecting, 32
  rotating, 33
  scaling, 33
  selecting individual, 105
  stretching, 33
Origin, plotting, 153
Output File (.lst) Format, 159

— P —
Paper size, 147, 150
Part List
  general information, 157
  output file (.lst) format, 159
  Part List Exclude property, 84
  starting from the command line, 158
  why use it, 157
Paste objects from clipboard, 34
PDF file
  generating, 155
  generating using the DxPDF interface, 155
Pin
  adding onsheet/offsheet, 93
  adding ports, 119
  adding specialized, 55
  attaching to existing net automatically, 93
  automatically attaching to existing net, 77
  configuring specialized, 56
  deleting FUBs, 121
  placing on schematic manually, 93
viewing associated component, 31
Pintype arrows
displaying and customizing, 46
Placing
components, 65
Plotting
configuring a basic plot, 146
from UNIX, 148
from UNIX using custom settings, 150
from UNIX using default settings, 149
Graphics dialog box, 152
in Windows, 146
introduction, 143
Options dialog box, 150
origin, 153
paper size
   ZSIZE, 150
rendering, 154
selecting paper size, 147
specify form feed, 151
specifying font, 152
spooling the plot with splplt, 148
to a file, 145
Port
printing, 150
Ports
adding missing, 88
adding to ICT, 71
connecting, 71
disconnecting, 71
propagating, 88
viewing in ICT, 71
Printing
current sheet, 144
from UNIX, 145
from Windows, 143
introduction, 143
paper tray selection in UNIX, 144
Project
creating new, introduction, 22
project hierarchy, 25
Propagating ports, 88
Properties
adding, 80
changing values, 81
controlling visibility, 81
deleting, 81
parameterized, 81
using the Property Definition Editor, 81
window, toggling on and off, 79
Property Definition Editor, 81
Push ICT, 72
Push Schematic, 72
— R —
Reflecting object, 32
Renaming
components, 66
nets, 69
Rendering
plotting, 154
Reordering sheets, 29
Reset All Filters, ICT viewer, 75
Resize Box, 100
Reuse
introduction, 115
   See also Hierarchical design
Reuse Blocks, 118
Rip Nets command, 100
Ripping
bus in ICT, 73
   nets in schematic editor, 97
Rollback, 62
root, 25
Rotating objects, 33
Routing modes
   avoidance, 86
   orthogonal, 86
   straight, 86
Rows
adjusting width, 70
grouping, 69
hiding, 70
unhiding, 71
— S —
Scaling objects, 33
Schematic
adding graphics, 103
adding text, 102
border, 47
changing border, 54
creating connections by net label names, 87
creating dangling connections, 87
creating intersecting connections, 87
creating new, 62
creating to export correctly to VHDL, 166
deleting border, 54
delisting borders, introduction, 63
filtering which objects to select, 108
generating PDF file, 155
inserting border on, 54
inserting VHDL and SPICE files on, 171
manipulating from Navigator, 29
preparing to create, 63
preparing to export to ModelSim, 165
printing and plotting introduction, 143
zooming, 35
Schematic Editor
introduction, 101
See also Schematic
Serial components, inserting, 95
Sheets
adding, 101
copying, 102
deleting, 102
reordering, 29
Shortcut Bar
adding new shortcut group, 42
configuring, 41
rename or remove shortcut group, 42
Sizing
text, attributes or labels, 33
Sorting nets, 69
Spacing of nets, 100
Split Net
dialog box, 95
splplt, spool plot command, 148
Spool to plotter, 150
Stretching objects, 33
String
changing name of, 36
Strokes, mouse movement
customizing using vdbindings.vbs, 113
enabling and disabling, 112
Symbol
adding ports, 119
adding specialized pins, 55
configuring specialized pins, 56
creating a Verilog, 170
creating VHDL, 170
placing, 76
synchronizing to component, 78
Symbol Properties, ICT viewer, 75
— T —
Templates
use when creating new project, 22
Test points, 84
Text
adding to schematic, 102
changing size of, 33
changing value of, 36
selecting from command line, 107
Text-owner indicator line, 104
Toolbox
add item to, 41
creating, 40
delete items from, 41
modify properties of existing tool, 41
Tools menu
adding a command to, 44
customizing, 43
editing a command entry, 44
removing a command from, 45
using arguments, 45
Troubleshooting
DxDesigner environment variables, 161
working environment, 161
your license, 163
— V —
Verilog
creating symbol, 170
using in DxDesigner, 165
VHDL
creating schematic that exports correctly, 166
creating symbol, 170
using in DxDesigner, 165
Viewer, interconnectivity table, 75
Viewing
pin and net and associated component, 31

— W —
Window types
docked and floating, 17
Windows
printing from, 143
Workspace
customizing, 46

— Z —
Zooming, 35
ZSIZE, 150
Third-Party Information

This section provides information on open source and third-party software that may be included in the DxDesigner product.

- This product may use libxslt open source software.
  ©Daniel Veillard. All Rights Reserved.
  ©Norman Walsh. All Rights Reserved.
  ©Thomas Broyer, Charlie Bozeman and Daniel Veillard. All Rights Reserved.
  ©Bjorn Reese and Daniel Stenberg. All Rights Reserved.
  ©Panagiotis Louridas. All Rights Reserved.

- This product may use libxml open source software.
  ©John Fleck. All rights reserved.
  ©O'Reilly & Associates, Inc. All rights reserved.
  ©Gary Pennington and Daniel Veillard. All rights reserved.
  ©Bjorn Reese and Daniel Veillard. All rights reserved.
  ©Daniel Veillard. All rights reserved.
  ©Bjorn Reese and Daniel Stenberg. All rights reserved.

  THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE

- This software application may include zlib third party software.
  ©Christian Michelsen

Permission to use, copy, modify, distribute and sell this software and its documentation for any purpose is hereby granted without fee, provided that the above copyright notice appear in all copies and that both that copyright notice and this permission notice appear in supporting documentation. Christian Michelsen Research AS makes no representations about the suitability of this software for any purpose. It is provided "as is" without express or implied warranty.
End-User License Agreement

The latest version of the End-User License Agreement is available on-line at:
www.mentor.com/terms_conditions/enduser.cfm

IMPORTANT INFORMATION
USE OF THIS SOFTWARE IS SUBJECT TO LICENSE RESTRICTIONS. CAREFULLY READ THIS LICENSE AGREEMENT BEFORE USING THE SOFTWARE. USE OF SOFTWARE INDICATES YOUR COMPLETE AND UNCONDITIONAL ACCEPTANCE OF THE TERMS AND CONDITIONS SET FORTH IN THIS AGREEMENT. ANY ADDITIONAL OR DIFFERENT PURCHASE ORDER TERMS AND CONDITIONS SHALL NOT APPLY.

END-USER LICENSE AGREEMENT (“Agreement”)  

This is a legal agreement concerning the use of Software between you, the end user, as an authorized representative of the company acquiring the license, and Mentor Graphics Corporation and Mentor Graphics (Ireland) Limited acting directly or through their subsidiaries (collectively “Mentor Graphics”). Except for license agreements related to the subject matter of this license agreement which are physically signed by you and an authorized representative of Mentor Graphics, this Agreement and the applicable quotation contain the parties’ entire understanding relating to the subject matter and supersede all prior or contemporaneous agreements. If you do not agree to these terms and conditions, promptly return or, if received electronically, certify destruction of Software and all accompanying items within five days after receipt of Software and receive a full refund of any license fee paid.

1. GRANT OF LICENSE. The software programs, including any updates, modifications, revisions, copies, documentation and design data (“Software”), are copyrighted, trade secret and confidential information of Mentor Graphics or its licensors who maintain exclusive title to all Software and retain all rights not expressly granted by this Agreement. Mentor Graphics grants to you, subject to payment of appropriate license fees, a nontransferable, nonexclusive license to use Software solely: (a) in machine-readable, object-code form; (b) for your internal business purposes; (c) for the license term; and (d) on the computer hardware and at the site authorized by Mentor Graphics. A site is restricted to a one-half mile (800 meter) radius. Mentor Graphics’ standard policies and programs, which vary depending on Software, license fees paid or services purchased, apply to the following: (a) relocation of Software; (b) use of Software, which may be limited, for example, to execution of a single session by a single user on the authorized hardware or for a restricted period of time (such limitations may be technically implemented through the use of authorization codes or similar devices); and (c) support services provided, including eligibility to receive telephone support, updates, modifications, and revisions.

2. EMBEDDED SOFTWARE. If you purchased a license to use embedded software development (“ESD”) Software, if applicable, Mentor Graphics grants to you a nontransferable, nonexclusive license to reproduce and distribute executable files created using ESD compilers, including the ESD run-time libraries distributed with ESD C and C++ compiler Software that are linked into a composite program as an integral part of your compiled computer program, provided that you distribute these files only in conjunction with your compiled computer program. Mentor Graphics does NOT grant you any right to duplicate, incorporate or embed copies of Mentor Graphics’ real-time operating systems or other embedded software products into your products or applications without first signing or otherwise agreeing to a separate agreement with Mentor Graphics for such purpose.

3. BETA CODE. Software may contain code for experimental testing and evaluation (“Beta Code”), which may not be used without Mentor Graphics’ explicit authorization. Upon Mentor Graphics’ authorization, Mentor Graphics grants to you a temporary, nontransferable, nonexclusive license for experimental use to test and evaluate the Beta Code without charge for a limited period of time specified by Mentor Graphics. This grant and your use of the Beta Code shall not be construed as marketing or offering to sell a license to the Beta Code, which Mentor Graphics may choose not to release commercially in any form. If Mentor Graphics authorizes you to use the Beta Code, you agree to evaluate and test the Beta Code under normal conditions as directed by Mentor Graphics. You will contact Mentor Graphics periodically during your use of the Beta Code to discuss any malfunctions or suggested improvements. Upon completion of your evaluation and testing, you will send to Mentor Graphics a written evaluation of the Beta Code, including its strengths, weaknesses and recommended improvements. You agree that any written evaluations and all inventions, product improvements, modifications or developments that Mentor Graphics conceived or made during or subsequent to this Agreement, including those based partly or wholly on your feedback, will be the exclusive property of Mentor Graphics. Mentor Graphics will have exclusive rights, title and interest in all such property. The provisions of this section 3 shall survive the termination or expiration of this Agreement.
4. **RESTRICTIONS ON USE.** You may copy Software only as reasonably necessary to support the authorized use. Each copy must include all notices and legends embedded in Software and affixed to its medium and container as received from Mentor Graphics. All copies shall remain the property of Mentor Graphics or its licensors. You shall maintain a record of the number and primary location of all copies of Software, including copies merged with other software, and shall make those records available to Mentor Graphics upon request. You shall not make Software available in any form to any person other than employees and on-site contractors, excluding Mentor Graphics’ competitors, whose job performance requires access and who are under obligations of confidentiality. You shall take appropriate action to protect the confidentiality of Software and ensure that any person permitted access to Software does not disclose it or use it except as permitted by this Agreement. Except as otherwise permitted for purposes of interoperability as specified by applicable and mandatory local law, you shall not reverse-assemble, reverse-compile, reverse-engineer or in any way derive from Software any source code. You may not sublicense, assign or otherwise transfer Software, this Agreement or the rights under it, whether by operation of law or otherwise (“attempted transfer”), without Mentor Graphics’ prior written consent and payment of Mentor Graphics’ then-current applicable transfer charges. Any attempted transfer without Mentor Graphics’ prior written consent shall be a material breach of this Agreement and may, at Mentor Graphics’ option, result in the immediate termination of the Agreement and licenses granted under this Agreement. The terms of this Agreement, including without limitation, the licensing and assignment provisions shall be binding upon your successors in interest and assigns. The provisions of this section 4 shall survive the termination or expiration of this Agreement.

5. **LIMITED WARRANTY.**

5.1. Mentor Graphics warrants that during the warranty period Software, when properly installed, will substantially conform to the functional specifications set forth in the applicable user manual. Mentor Graphics does not warrant that Software will meet your requirements or that operation of Software will be uninterrupted or error free. The warranty period is 90 days starting on the 15th day after delivery or upon installation, whichever first occurs. You must notify Mentor Graphics in writing of any nonconformity within the warranty period. This warranty shall not be valid if Software has been subject to misuse, unauthorized modification or improper installation. MENTOR GRAPHICS’ ENTIRE LIABILITY AND YOUR EXCLUSIVE REMEDY SHALL BE, AT MENTOR GRAPHICS’ OPTION, EITHER (A) REFUND OF THE PRICE PAID UPON RETURN OF SOFTWARE TO MENTOR GRAPHICS OR (B) MODIFICATION OR REPLACEMENT OF SOFTWARE THAT DOES NOT MEET THIS LIMITED WARRANTY, PROVIDED YOU HAVE OTHERWISE COMPLIED WITH THIS AGREEMENT. MENTOR GRAPHICS MAKES NO WARRANTIES WITH RESPECT TO: (A) SERVICES; (B) SOFTWARE WHICH IS LICENSED TO YOU FOR A LIMITED TERM OR LICENSED AT NO COST; OR (C) EXPERIMENTAL BETA CODE; ALL OF WHICH ARE PROVIDED “AS IS.”

5.2. THE WARRANTIES SET FORTH IN THIS SECTION 5 ARE EXCLUSIVE. NEITHER MENTOR GRAPHICS NOR ITS LICENSORS MAKE ANY OTHER WARRANTIES, EXPRESS, IMPLIED OR STATUTORY, WITH RESPECT TO SOFTWARE OR OTHER MATERIAL PROVIDED UNDER THIS AGREEMENT. MENTOR GRAPHICS AND ITS LICENSORS SPECIFICALLY DISCLAIM ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE AND NON-INFRINGEMENT OF INTELLECTUAL PROPERTY.

6. **LIMITATION OF LIABILITY.** EXCEPT WHERE THIS EXCLUSION OR RESTRICTION OF LIABILITY WOULD BE VOID OR INEFFECTIVE UNDER APPLICABLE LAW, IN NO EVENT SHALL MENTOR GRAPHICS OR ITS LICENSORS BE LIABLE FOR INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES (INCLUDING LOST PROFITS OR SAVINGS) WHETHER BASED ON CONTRACT, TORT OR ANY OTHER LEGAL THEORY, EVEN IF MENTOR GRAPHICS OR ITS LICENSORS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. IN NO EVENT SHALL MENTOR GRAPHICS’ OR ITS LICENSORS’ LIABILITY UNDER THIS AGREEMENT EXCEED THE AMOUNT PAID BY YOU FOR THE SOFTWARE OR SERVICE GIVING RISE TO THE CLAIM. IN THE CASE WHERE NO AMOUNT WAS PAID, MENTOR GRAPHICS AND ITS LICENSORS SHALL HAVE NO LIABILITY FOR ANY DAMAGES WHATSOEVER. THE PROVISIONS OF THIS SECTION 6 SHALL SURVIVE THE EXPIRATION OR TERMINATION OF THIS AGREEMENT.

7. **LIFE ENDANGERING ACTIVITIES.** NEITHER MENTOR GRAPHICS NOR ITS LICENSORS SHALL BE LIABLE FOR ANY DAMAGES RESULTING FROM OR IN CONNECTION WITH THE USE OF SOFTWARE IN ANY APPLICATION WHERE THE FAILURE OR INACCURACY OF THE SOFTWARE MIGHT RESULT IN DEATH OR PERSONAL INJURY. THE PROVISIONS OF THIS SECTION 7 SHALL SURVIVE THE EXPIRATION OR TERMINATION OF THIS AGREEMENT.

8. **INDEMNIFICATION.** YOU AGREE TO INDEMNIFY AND HOLD HARMLESS MENTOR GRAPHICS AND ITS LICENSORS FROM ANY CLAIMS, LOSS, COST, DAMAGE, EXPENSE, OR LIABILITY, INCLUDING ATTORNEYS’ FEES, ARISING OUT OF OR IN CONNECTION WITH YOUR USE OF SOFTWARE AS
DESCRIBED IN SECTION 7. THE PROVISIONS OF THIS SECTION 8 SHALL SURVIVE THE EXPIRATION OR TERMINATION OF THIS AGREEMENT.

9. INFRINGEMENT.

9.1. Mentor Graphics will defend or settle, at its option and expense, any action brought against you alleging that Software infringes a patent or copyright or misappropriates a trade secret in the United States, Canada, Japan, or member state of the European Patent Office. Mentor Graphics will pay any costs and damages finally awarded against you that are attributable to the infringement action. You understand and agree that as conditions to Mentor Graphics' obligations under this section you must: (a) notify Mentor Graphics promptly in writing of the action; (b) provide Mentor Graphics all reasonable information and assistance to defend or settle the action; and (c) grant Mentor Graphics sole authority and control of the defense or settlement of the action.

9.2. If an infringement claim is made, Mentor Graphics may, at its option and expense: (a) replace or modify Software so that it becomes noninfringing; (b) procure for you the right to continue using Software; or (c) require the return of Software and refund to you any license fee paid, less a reasonable allowance for use.

9.3. Mentor Graphics has no liability to you if infringement is based upon: (a) the combination of Software with any product not furnished by Mentor Graphics; (b) the modification of Software other than by Mentor Graphics; (c) the use of other than a current unaltered release of Software; (d) the use of Software as part of an infringing process; (e) a product that you make, use or sell; (f) any Beta Code contained in Software; (g) any Software provided by Mentor Graphics’ licensors who do not provide such indemnification to Mentor Graphics’ customers; or (h) infringement by you that is deemed willful. In the case of (h) you shall reimburse Mentor Graphics for its attorney fees and other costs related to the action upon a final judgment.

9.4. THIS SECTION IS SUBJECT TO SECTION 6 ABOVE AND STATES THE ENTIRE LIABILITY OF MENTOR GRAPHICS AND ITS LICENSORS AND YOUR SOLE AND EXCLUSIVE REMEDY WITH RESPECT TO ANY ALLEGED PATENT OR COPYRIGHT INFRINGEMENT OR TRADE SECRET MISAPPROPRIATION BY ANY SOFTWARE LICENSED UNDER THIS AGREEMENT.

10. TERM. This Agreement remains effective until expiration or termination. This Agreement will immediately terminate upon notice if you exceed the scope of license granted or otherwise fail to comply with the provisions of Sections 1, 2, or 4. For any other material breach under this Agreement, Mentor Graphics may terminate this Agreement upon 30 days written notice if you are in material breach and fail to cure such breach within the 30 day notice period. If Software was provided for limited term use, this Agreement will automatically expire at the end of the authorized term. Upon any termination or expiration, you agree to cease all use of Software and return it to Mentor Graphics or certify deletion and destruction of Software, including all copies, to Mentor Graphics’ reasonable satisfaction.

11. EXPORT. Software is subject to regulation by local laws and United States government agencies, which prohibit export or diversion of certain products, information about the products, and direct products of the products to certain countries and certain persons. You agree that you will not export any Software or direct product of Software in any manner without first obtaining all necessary approval from appropriate local and United States government agencies.

12. RESTRICTED RIGHTS NOTICE. Software was developed entirely at private expense and is commercial computer software provided with RESTRICTED RIGHTS. Use, duplication or disclosure by the U.S. Government or a U.S. Government subcontractor is subject to the restrictions set forth in the license agreement under which Software was obtained pursuant to DFARS 227.7202-3(a) or as set forth in subparagraphs (c)(1) and (2) of the Commercial Computer Software - Restricted Rights clause at FAR 52.227-19, as applicable. Contractor/manufacturer is Mentor Graphics Corporation, 8005 SW Boeckman Road, Wilsonville, Oregon 97070-7777 USA.

13. THIRD PARTY BENEFICIARY. For any Software under this Agreement licensed by Mentor Graphics from Microsoft or other licensors, Microsoft or the applicable licensor is a third party beneficiary of this Agreement with the right to enforce the obligations set forth herein.

14. AUDIT RIGHTS. You will monitor access to, location and use of Software. With reasonable prior notice and during your normal business hours, Mentor Graphics shall have the right to review your software monitoring system and reasonably relevant records to confirm your compliance with the terms of this Agreement, an addendum to this Agreement or U.S. or other local export laws. Such review may include FLEXlm or FLEXnet report log files that you shall capture and provide at Mentor Graphics’ request. Mentor Graphics shall treat as confidential information all of your information gained as a result of any request or review and shall only use or disclose such information as required by law or to enforce its rights under this Agreement or addendum to this Agreement. The provisions of this section 14 shall survive the expiration or termination of this Agreement.
15. CONTROLLING LAW, JURISDICTION AND DISPUTE RESOLUTION. THIS AGREEMENT SHALL BE GOVERNED BY AND CONSTRUED UNDER THE LAWS OF THE STATE OF OREGON, USA, IF YOU ARE LOCATED IN NORTH OR SOUTH AMERICA, AND THE LAWS OF IRELAND IF YOU ARE LOCATED OUTSIDE OF NORTH OR SOUTH AMERICA. All disputes arising out of or in relation to this Agreement shall be submitted to the exclusive jurisdiction of Portland, Oregon when the laws of Oregon apply, or Dublin, Ireland when the laws of Ireland apply. Notwithstanding the foregoing, all disputes in Asia (except for Japan) arising out of or in relation to this Agreement shall be resolved by arbitration in Singapore before a single arbitrator to be appointed by the Chairman of the Singapore International Arbitration Centre (“SIAC”) to be conducted in the English language, in accordance with the Arbitration Rules of the SIAC in effect at the time of the dispute, which rules are deemed to be incorporated by reference in this section 15. This section shall not restrict Mentor Graphics’ right to bring an action against you in the jurisdiction where your place of business is located. The United Nations Convention on Contracts for the International Sale of Goods does not apply to this Agreement.

16. SEVERABILITY. If any provision of this Agreement is held by a court of competent jurisdiction to be void, invalid, unenforceable or illegal, such provision shall be severed from this Agreement and the remaining provisions will remain in full force and effect.

17. PAYMENT TERMS AND MISCELLANEOUS. You will pay amounts invoiced, in the currency specified on the applicable invoice, within 30 days from the date of such invoice. Any past due invoices will be subject to the imposition of interest charges in the amount of one and one-half percent per month or the applicable legal rate currently in effect, whichever is lower. Some Software may contain code distributed under a third party license agreement that may provide additional rights to you. Please see the applicable Software documentation for details. This Agreement may only be modified in writing by authorized representatives of the parties. Waiver of terms or excuse of breach must be in writing and shall not constitute subsequent consent, waiver or excuse.

Rev. 060210, Part No. 227900