LAN Modeling

Overview

This lesson focuses on the use of LAN models and background link utilization. You will learn to

- Configure the object palette with the models you need
- Set up application and profile configurations
- Model a LAN as a single node
- Specify background utilization that changes over time on a link
- Simulate multiple scenarios simultaneously
- Apply filters to graphs of results and analyze the results

This lesson focuses on two features, LAN models, which model entire LANs, and the link Background Load attribute, which is used to model existing link traffic.
• **LAN Models:** If you are modeling a medium or large internetwork, you may only be interested in specific aspects of the network’s behavior (whether a key router will be overloaded, for example). In such cases, single nodes can model entire LANs.

• **Link Background Load:** Use the **Background Load** attribute to model existing traffic on a link instead of explicitly modeling each packet. You can also specify changes in this background traffic over the course of a simulation.

**Background Load Attribute Dialog Box**
Setting Up the Scenario

In this lesson, your job is to model an east coast company’s WAN. The company has offices in Atlanta, Philadelphia, New York, and Boston, which are connected to the central network in Washington, D.C. The offices use phone lines to connect to each other, and are therefore susceptible to delays caused by additional, unrelated traffic on the lines.

This company wants you to determine how this background traffic is affecting FTP traffic on their network. To do this, you will model FTP performance on the network, first without background traffic and then with background traffic. Because you are not interested in modeling the details of each office’s LAN, you will use LAN models to model the individual LANs as single nodes.

The first step in setting up the WAN is to specify the overall context for the network with the Startup Wizard. Once that is done, you can proceed with building the network itself. This topic focuses on:

- Configuring an object palette
- Specifying a map background
- Zooming in on a background
Begin by opening a new project in Modeler and configuring the scenario context using the Startup Wizard:

1. If it is not already running, start it, select **File > New… > Project**, then click **OK**.

2. Name the new project `<initials>_LAN_Mod` and the scenario `no_back_load`, then click **OK**.

3. Click **Next >** when the Startup Wizard opens and select “Create empty scenario” for the **Initial Topology**.

You can specify a map to use as a background for your network. To set a map background:

1. Click **Choose from maps** for **Network Scale** and click **Next >**.

2. Choose **usa** from the **Border Map** list.

3. Choose **usa** from the **MapInfo Maps** list and click **>>** to move it to the **Selected (background first)** pane.
Choose Map Wizard

4 Click **Next >**.

5 Select **LAN_Mod_Model_List** to be included in your network by clicking on the **Include?** cell and changing the value from **No** to **Yes**. Click **Next >**.

6 Review your settings and click **Finish** to close the Startup Wizard.

➤ The workspace now shows the specified map and object palette.
Modeler’s full set of node and link models would be overwhelming to work with all at once, so the object palette can be configured to show only a specific subset, or model list. You can use the standard model lists, adapt them for your own needs, or make your own list.

You can create your own custom object palettes for use in modeling projects.

For this lesson, we created the **LAN_Mod_Model_List**. Now you will adapt that model list by adding the LAN node model to it:

1. Click the **Object Palette Icon** (or choose **Open Object Palette** from the **Topology** menu if Object Palette dialog box is not open).

   ![Object Palette Icon](image)

   ➤ The Object Palette dialog box opens.
The Object Palette dialog box lets you change the object palette and then save it.

2 Scroll to the top of folder treeview and click the **Node Models** folder in the Object Palette dialog box.

Under Node Models, click **Fixed Node Models > By Name > 10BaseT**.
3 Under 10BaseT, right click on **10BaseT_LAN** and click on **Add to Default Palette: LAN_Mod_Model_List**.

**10BaseT LAN Added to Object Palette**

*The 10BaseT_LAN icon appears in the LAN_Mod_Model_List in the object palette.*

4 Click **Close** on the Object Palette.
Because the network you will create is on the east coast of the U.S., there is no need to view the entire map. To zoom in on the east coast:

1. Click the **Zoom** toolbar button.

2. Select the top left corner of the area to zoom in on and drag a rectangle to bottom right corner. Be certain that both Atlanta and Boston are included in the zoomed view.

   **Using the Zoom Button**

3. Continue to zoom until the names of cities, including Boston and Atlanta, appear on the map.

   Tip: If you are not happy with your first zoom, you can click the **Zoom to Previous** toolbar button, next to the **Zoom** toolbar button, and then zoom in again.
Configuring Applications

It is a good idea to define the profiles and applications that will be used by the LAN before you begin constructing the network. You define the profiles in the profile definition object and applications in the application definition object.

- **A profile** is applied to a workstation, server, or LAN. It specifies the applications used by a particular group of users. You might have one profile for Marketing (heavy use of email; light use of file transfer) and another profile for Engineering (light use of email; heavy use of file transfer).

- **An application** may be any of the common applications (email, file transfer) or a custom application you define. Eight common (“standard”) applications are already defined: Database Access, Email, File Transfer, File Print, Telnet Session, Video conferencing, Voice over IP Call, and Web Browsing.

Profile Definition and Application Definition Objects
To Configure the Application Configuration Object

Follow these steps.

1. Open the object palette (if it is not already open).

2. Drag an **Application Config** object to the project workspace.

3. Right-click on the new object and select **Edit Attributes**.
   - The Attributes dialog box opens.

4. Click on the question mark next to the **name** attribute to see a description of the attribute. Close the attribute description dialog box when done.

**Application Definitions Set to Default**

Click here to see a description

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>name</td>
<td>node_0</td>
</tr>
<tr>
<td>Application Definitions</td>
<td>None</td>
</tr>
<tr>
<td>Voice Encoder Schemes</td>
<td>All Schemes</td>
</tr>
</tbody>
</table>

5. Set the **name** attribute to **Application Configuration**.
6 Change the **Application Definitions** attribute to **Default** by clicking in the attribute’s Value column and selecting **Default** from the drop-down list.

 ➤ Selecting **Default** configures the application definition object to make 16 pre-configured applications available for use. These applications are different configurations of the eight standard applications mentioned earlier. Now you will be able to include these applications in the profile you are about to create.

7 Click **OK** to accept the changes and close the **Attributes** dialog box.
To Configure the Profile Configuration Object

Follow these steps.

1. Drag a **Profile Config** object from the object palette to the project workspace.

2. Right-click on the object and select **Edit Attributes**.

3. Set the **name** attribute to **Profile Configuration**.

4. Change the **Profile Configuration** attribute by clicking in its Value column and selecting **Edit...** from the drop-down list.

   **Selecting Edit... from the Menu**

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>name</td>
<td>node_0</td>
</tr>
<tr>
<td>Profile Configuration</td>
<td>None</td>
</tr>
</tbody>
</table>

   ➡️ The Profile Configuration dialog box appears.
Profile Configuration Dialog Box

![Profile Configuration Table Diagram]
To Define a New Profile and Add It to the Table

Follow these steps.

1. Change the number of rows to 1.

2. Name the new profile **LAN Client** by clicking in the Profile Name column of the first row.

3. Skip the next column, Application. We’ll configure the other attributes first and come back to this one later.

4. Change the **Operation Mode** to **Simultaneous**.

5. Click in the profile’s **Start Time (seconds)** cell to open the Start Time Specification dialog box.

6. Select **constant** from the **Distribution Name** pull-down menu.

**Start Time Specification Dialog Box**

![Start Time Specification Dialog Box Image]
7 Set **Mean Outcome** to 100, then click **OK** to close the Start Time Specification dialog box.

- The Start Time attribute has a value of **constant (100)**.

Do not close the profile configuration attribute dialog box.

You will be modeling FTP performance. That application should be included in the profile.

1 Click in the Applications column and choose **Edit...** from the pop-up menu.

- The **Applications** dialog box appears.

2 Change the number of rows to **1**.

3 Set the **Name** to **File Transfer (Heavy)** by clicking in the cell and selecting the application from the drop-down list.

The contents of the drop-down list are controlled by the Applications Configuration object. When you selected **Default** as the value for the **Application Definitions** attribute in this object, you enabled this list of applications.
Note that the list includes 16 entries, a heavy and light version for each of the eight standard applications.

4 Set **Start Time Offset** to **uniform (0, 300)**.

4.1 Verify that the **Distribution Name** is **uniform**.

4.2 Set **Minimum Outcome** to **0**.

4.3 Set **Maximum Outcome** to **300**, then click **OK**.

5 Verify that the completed dialog box looks like this:

**Completed Applications Dialog Box**

![Completed Applications Dialog Box](image)

6 Click **OK** to close the Applications Table dialog box.
7 Click **OK** to close the Profile Configuration Table, then click **OK** again to close the Attributes dialog box.
Building the Network

Now that you have set up the scenario, configured the application, and created a profile that uses the application, you are ready to begin constructing the WAN. Because the network contains four identical subnets, you can create the first subnet in Atlanta, with its nodes inside it, and then copy the subnet to Boston, New York, and Philadelphia. You will also copy it to Washington, D.C. and modify it further. This topic focuses on:

- Building subnets
- Copying and pasting network objects
- Modifying subnets
- Connecting subnets

A subnet is a single network object that contains other network objects (links, nodes, and other subnets). Subnetworks allow you to simplify the display of a complex network through abstraction.
Subnets help you logically organize your network model. You can nest subnets within subnets to an unlimited degree. For this lesson, you can use subnets as logical containers for the offices in each of the cities. To create a subnet:

1. Open the object palette if it is not already open, and move it to the lower right corner of the screen so that it is out of the way.

2. Place a fixed subnet over Atlanta.
   
   2.1. Click the subnet icon in the object palette and drag it to the workspace.
   
   2.2. Right-click to turn off node creation.

3. Modify the subnet extent of the Atlanta subnet. The subnet extent is the geographic area covered by the subnet, which may be much larger than the actual area you wish to model.

**Subnet Extent**

Subnet Extent
3.1 Right-click and select **Edit Attributes (Advanced)**.

3.2 Set the name attribute to Atlanta.

3.3 Change the **x span** and **y span** attributes to **.25**. The unit of measure of these attributes is determined by the unit of measure of the top-level area, degrees in this case. The area covered by **.25** is the area covered by one-quarter of one degree of latitude or longitude.

3.4 Click **OK**.

Notice that the subnet extent is now much smaller. (It may be hidden underneath the subnet icon.)

---

Double-clicking on a subnet object allows you to see what is “inside” the subnet.

---

When you double-click on a subnet, Modeler changes the view to show you what is inside that subnet. Subnets can contain nodes, links, and other subnets. An example topology follows. You will not see this topology right now. You are about to create it.
Initially, a subnet’s grid properties are based on its parent subnet. If the subnet’s grid settings are inappropriate, you can change them to fit your network. To change the grid inside a subnet:

1. **Double-click** on the Atlanta subnet.

2. Select **View > Background > Set Properties**.
   
   ➤ Note that the display grid is in degrees, which is not appropriate for an office.

3. Set units to **Meters**.

4. Set resolution to **10 pixels/m**.

5. Uncheck the Visible checkbox for Satellite orbits.

6. Verify that Drawing is set to **Dashed**.
7 Set division to 10.

Set View Properties Dialog Box

8 Click the Close button.

Modeling the East Coast company’s network does not require modeling the precise nature of each node in each subnet, so you can represent the subnets with a LAN model. To create a LAN model:

1 Place a 10BaseT_LAN in the workspace.

2 Right-click on the 10BaseT_LAN and choose the Edit Attributes menu item.
You can change a LAN model’s attributes so that it represents a network with a certain number of workstations and a particular traffic profile. To represent one of the East Coast company’s satellite offices:

1. Change the LAN model’s **name** attribute to **Office_LAN**.

2. Expand the Applications attribute group.

3. Choose **Edit…** for the **Application: Supported Profiles** attribute.

4. Change the number of rows to 1.

5. Change **Profile Name** to **LAN Client**.

   ➐ Now this LAN will use the LAN Client profile you created earlier. This profile includes the File Transfer (Heavy) application. The LAN will receive and send traffic that models heavy FTP use.

6. Set **Number of Clients** to 10, then click **OK**.

7. Click **OK**.
You have now modeled a 10 workstation LAN inside the Atlanta subnet. This single object is equivalent to a 10-workstation star topology LAN.

A Single LAN Object is Equivalent to a LAN Composed of Many Objects

Because this LAN model is composed of workstations and links only, it must be connected to a router. The router can then be connected to other routers in the network.

To create a router:

1. Drag a **BN_BLN_4s_e4_f_sl8_tr4** node (a Nortel Networks router) from the object palette to the workspace near the **Office_LAN** node.

2. Name the new node **router**.
3 Connect the **router** and the **Office_LAN** nodes with a **10BaseT** link. Right-click to turn off link creation.

The Atlanta subnet is now configured. Because the subnets in the other cities are identical, you can copy the Atlanta subnet and place it appropriately.

When several subnets or network objects have an identical configuration, you can copy and paste these objects.

To copy the subnet:

1. Return to the parent subnet view by clicking on the **Go to Parent Subnet** button (you can also right-click on the workspace to display the workspace pop-up menu, then choose **Go to Parent Subnet** from the menu).

2. Select the subnet.

3. Select **Edit > Copy** or press `<Control>+c.`
Paste the subnet to each of the four different cities:

1. Select **Edit > Paste** or press `<Control>+v` and click on the Washington, DC icon.

   **Pasting the Subnet**

   ![Pasting the Subnet](image)

   ➡️ A new subnet appears.

2. Press `<Control>+v` again to paste subnets over Philadelphia, New York, and Boston.

3. Right-click on each subnet and select Set Name to rename each city’s subnet as follows:
   - Washington, D.C.: **Washington_DC**
   - Philadelphia: **Philadelphia**
   - New York: **New_York**
   - Boston: **Boston**
Connect each subnet to the Washington_DC office:

1. Select the **LAN_Mod_PPP_DS0** link in the object palette.

2. Draw a **LAN_Mod_PPP_DS0** link from **Atlanta** to **Washington_DC**.

    ➤ A Select Nodes dialog box appears asking which nodes in each subnet are to be endpoints of the link.

3. For **node a**, choose the **Atlanta.router** node.

4. For **node b**, choose the **Washington DC.router** node.

5. Click **OK** to establish the link.
6 Repeat this process, drawing links from each city to Washington DC, specifying each city’s router as the links’ endpoints.

To prevent overlapping links, you can click on intermediate points in the workspace to make a link follow a path before finally clicking on its destination node.

7 Right-click to turn off link creation.

The network should resemble the following:
To complete the network, the main office in Washington D.C. needs to have a switch and a server added to it. To configure the network in D.C.:

1. Double-click on the **Washington_DC** subnet to enter its subnet view.

2. Place one `<Bay Network Accelar1050>` switch and one `ethernet_server` node in the workspace.

3. Rename the `<Bay Network Accelar1050>` node to **switch**.

4. Rename the `ethernet_server` to **FTP**.

5. Connect the “router” and the “FTP” nodes to the switch with **10BaseT** links. Right-click to turn off link creation.

6. Close the object palette.
Configure the Server to Support the FTP Application

Follow these steps.

1. Open the Attributes dialog box for the **FTP** server.

2. Expand the Applications attribute group.

3. Choose **Edit…** for the **Application: Supported Services** attribute.

4. Change the number of rows to **1**.

5. Select **File Transfer (Heavy)** from the **Name** column pop-up menu.

6. Click **OK** to close the Supported Services dialog box, and then click **OK** to close the (FTP) Attributes dialog box.

The Washington, D.C. subnet is now complete and should resemble the following figure.
7. Use the workspace pop-up menu to return to the parent subnet view.

8. Save the project by selecting **File > Save**.
Background Load

Now that you have created a model to act as a baseline for the performance of the East Coast company’s network, you can add background traffic to the links connecting the cities and compare the results from the two scenarios.

This topic focuses on

- Duplicating a scenario
- Implementing a varying background load on the links

**Background loading** is an efficient means of modeling a known traffic load on a link.

Network studies show that traffic rises gradually over the course of the day as employees arrive and begin work. You can use background link utilization to model this pattern.

Because you want to compare the performance of the network with and without background utilization, you need to prepare two scenarios, one for each situation.
You will duplicate the existing scenario, then add background traffic to it:

1. Select **Scenarios > Duplicate Scenario…**

2. Name the scenario **back_load** and click **OK**.

**Background Load** is an attribute of each link. To set background load on the links between the cities:

1. Select the links between subnets. Right-click on the link between Washington, D.C. and Atlanta, then choose **Select Similar Links** from the pop-up menu.

2. Display the **Attributes** dialog box for the link between Washington, D.C. and Atlanta.

3. Click in the Value cell for the **Traffic Information** attribute and select **Edit…**

⇒ A **Traffic Information** table appears.
4 Change the number of rows to 1.

5 Click in the [Atlanta.router -> Washington_DC.router] column and choose Edit…

6 Set Average Packet Size to Default.

7 Click on the value cell for “Traffic Load [bps]” and select Edit…

   ➪ The Traffic Intensity Attribute Profile dialog box appears.

8 Set the Profile name to “My_WAN_Load”.

9 Complete the Profile table as shown in the following figure.
The intensity table above indicates that for the first 300 seconds of the simulation, the background load on this link will be 19,200 bps (that is, 30 percent of the DS0 capacity of the link). For the next 200 seconds, the background load on the link will be 25,600 bps (about 40 percent of the link capacity), and for the last part of the simulation, the load will be 32,000 bps (about 50 percent of the link capacity).
10 Click **OK** to close the profile table.

11 Click in the [Washington_DC.router -> Atlanta.router] and choose **Edit**...

12 Set Average Packet Size (bytes) to Default.

13 Click on the value cell of the Traffic Load (bps) and choose **Select**...

→ The following table appears.

**Attribute Profile Table**

14 Select <Local Profiles> from the Profile Library list and “My_WAN_Load” from the Profile list.

15 Click **OK** to close the **Profile Selection** dialog box.

16 Click **OK** to close the **Traffic Information** table dialog box.
Do not close the link attributes dialog box.
The last step in setting Traffic Information is to apply the changes made to the Atlanta–Washington, D.C. link to all selected links.

1. Check the **Apply changes to selected objects** check box in the **Atlanta <-> Washington_DC** Attributes dialog box.

   ![Link Attributes Dialog Box](image)

2. Click **OK** to close the Attributes dialog box, then click **Yes** if you are prompted to continue.

   ➤ Note that “4 objects changed.” appears in the message area.

   ![Confirming Message](image)
3 Save the project by selecting **File > Save.**
Collecting Statistics

Now that you have configured both scenarios (one without background load as a baseline, and one with background load), you are ready to collect data and analyze it.

The relevant statistics for this network are the throughput and utilization statistics for the links and the global FTP download time for the network.

This topic focuses on:

- Specifying statistics to collect in each scenario
- Switching between scenarios
- Running multiple simulations
To Collect Statistics in the back_load Scenario

Follow these steps.

1. Right-click in the workspace to display the workspace pop-up menu, and select Choose Individual DES Statistics.

2. Select the Global Statistics > Ftp > Download Response Time (sec) statistic.

Selecting the FTP Download Response Time Statistic

3. Select the Link Statistics > point-to-point > throughput (bits/sec) --> and utilization --> statistic.
Selecting the Throughput and Utilization Statistics

4. Click **OK** to close the **Choose Results** dialog box.

The throughput and utilization statistics that you have specified will be collected for every link in the simulation. In order to compare the statistics in the **back_load** scenario to the **no_back_load** scenario, the same statistics must be collected in the **no_back_load** scenario. To change scenarios and collect statistics:

1. Select **Scenarios > Switch To Scenario**, then choose **no_back_load**.
Selecting the no_back_load Scenario

2 Collect the same statistics that you did in the back_load scenario:

   — Global Statistics > Ftp > Download Response Time (sec)
   — Link Statistics > point-to-point > throughput (bits/sec) -->
   — Link Statistics > point-to-point > utilization -->

3 Close the Choose Results dialog box and save the project.

You are now almost ready to run the simulations to collect the statistics you have specified.

First, though, verify that your Network Simulation Repositories preference is set appropriately.

1 Choose Edit > Preferences.
2 Type network sim in the Search for: field and click the Find button.

3 If the Value field for the Network Simulation Repositories preference is not stdmod, click on that field.

   ➤ The Network Simulation Repositories dialog box opens.

4 Click the Insert button, then type stdmod in the field.

5 Click OK twice to close the Network Simulation Repositories and Preferences dialog boxes.

Now you are ready to run the simulations to collect the statistics you have specified.

Using the Manage Scenarios dialog box, you can rename scenarios, change their order, and run single or multiple simulations.

Instead of running each simulation separately, you can batch them together to run consecutively. To run multiple simulations:
1 Select **Scenarios > Manage Scenarios...**

   ➡ The Manage Scenarios dialog box appears.

**Manage Scenarios Dialog Box**

<table>
<thead>
<tr>
<th>#</th>
<th>Scenario Name</th>
<th>Saved</th>
<th>Results</th>
<th>Sim Duration</th>
<th>Time Units</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>no_back_load</td>
<td>saved</td>
<td>uncollected</td>
<td>1.0</td>
<td>hour(s)</td>
</tr>
<tr>
<td>2</td>
<td>back_load</td>
<td>saved</td>
<td>uncollected</td>
<td>1.0</td>
<td>hour(s)</td>
</tr>
</tbody>
</table>

2 Click on the **Results** value for the no_back_load and back_load scenarios and change the value to `<collect>`.

3 Set the **Sim Duration** value for each scenario to **2,000** and the **Time Units** to **seconds**.

**Running the Simulation from the Manage Scenarios Dialog Box**
4  Click **OK**.

- This runs simulations for both scenarios. A DES Execution Manager dialog box shows the simulation progress. Close the dialog box when the simulations are done.

- If your simulation does not complete, if no results were collected, or if the results vary significantly from those shown, you will have to troubleshoot your simulation. See "Troubleshooting Tutorials".
Comparing Results

You are now ready to examine the results of the two scenarios. Because you collected the same statistics in each scenario, you can use the Compare Results feature to look at them together.

To view the results from two or more different scenarios against each other, you can use the Compare Results feature. You can also apply different built-in filters to the graphs.

This topic focuses on:

- Comparing results between scenarios
- Applying filters to graphs

The Compare Results feature shows results from two or more scenarios. To look at link utilization:

1. Right-click on the workspace to display the pop-up menu and choose View Results.

2. Under the DES Graphs tab, selects Results for Current Project and then select both scenarios.
3 Under Show Results, select 
Object Statistics > Network > 
Atlanta <-> Washington_DC [0] > 
point-to-point > utilization -->.

4 Because utilization varies over the course of a simulation, it is helpful to look at the time average for this statistic. Change the Filter menu from As Is to Average.

5 Select Overlaid Statistics from the pull down menu for Presentation.
Setting the Filter

6 Click **Show** to display the graph. Your graph should resemble the following figure, though it will not match exactly:
The network with the background load (back_load) shows higher utilization. You may want to look at the utilization of other links to determine the maximum utilization of any link.

You can also compare the link throughputs (bps) by selecting **Object Statistics > Network > Atlanta <-> Washington_DC [0] > point-to-point > throughput (bits/sec)**.

Next, let’s look at Global FTP response time:
1. Move the link utilization graph aside and click the **Unselect** button in the Compare Results dialog box.

2. Check the **Global Statistics > Ftp > Download Response Time (sec)** statistic in the Compare Statistics dialog box.

3. Verify that the Filter menu shows **average**, then click **Show**.

**Select Average from the Filter Menu**

The graph should resemble the following figure:
Average Download Response Time Compared

This graph shows that, as steady state is reached, response time increases by several seconds when the link is heavily loaded.

1. Select **File > Close** and save changes before closing.
Now that you have completed the LAN lesson, you can move on to the Web Reporting lesson. This lesson presents the web reporting feature and how it can help you to make informed decisions about a network’s behavior. Return to the main tutorial menu and choose Web Reporting from the list of available lessons.

**Note**—Be sure to delete the stdmod setting for the Network Simulation Repositories preference when you are finished doing tutorials. To delete the setting, select Edit > Preferences, search for Network Simulation Repositories, click on the value, and choose Delete.