GeoFrame Well Data Editing and Log Depth Matching

Training and Exercise Guide

GeoFrame 4
September 20, 2001
Contents

About This Course

Chapter 1
WellEdit Overview
  Learning Objectives
  Keywords
  WellEdit Position in GeoFrame
  WellEdit Workflow
  Start WellEdit Application
  Exercise 1.1: Start WellEdit
  Exercise 1.2: Customize WellEdit Inspect Window
  Exercise 1.3: Customize WellEdit Main Window Appearance

Chapter 2
WellEdit General Features
  Learning Objectives
  Keywords
  Exercise 2.1 Overview
  Exercise 2.1: Customize the Window Appearance
  Exercise 2.2 Overview
  Exercise 2.2: Data Functioning
  Exercise 2.3 Overview
  Exercise 2.3: Statistics Tool

Chapter 3
WellEdit Editing Features
  Learning Objectives
  Keywords
  Exercise 6.1 Overview
  Exercise 6.1: Basic Features

Chapter 4
WellEdit Splicing Features
  Learning Objectives
  Keywords
  Exercise 4.1 Overview
  Exercise 4.1: Log Curve Splicing

Chapter 5
WellEdit Log Depth Matching Features
  Learning Objectives
  Keywords
  Exercise 5.1 Overview
  Exercise 5.1: Log Depth Matching

Chapter 6
WellCompositePlus
  Learning Objectives
  Keywords
  Exercise 6.1 Overview
Exercise 6.2 Overview

Exercise 6.2: Advance Features
About This Course

This course helps geoscientists use GeoFrame utilities for log data editing, core data editing, core image data editing, log depth matching and generating well data graphics template to visualize the log data.

For more information on WellEdit, please refer to the Online Help from GeoFrame Bookshelf.

Please Note: Document conventions regarding the mouse.

**MB1:** Mouse Button 1 (Left Mouse Button). The default instruction to “Click…” is to select, highlight, or activate the item using MB1

**MB2:** Mouse Button 2 (Middle Mouse Button)

**MB3:** Mouse Button 3 (Right Mouse Button)
Chapter 1
WellEdit Overview

WellEdit is a GeoFrame application that enables you to display, analyze, and edit the data before you interpret it. The data types that WellEdit can handle are:

- Core Data
- Core Image Data
- Log data

Learning Objectives

Upon completion of this course, you should be able to:

- Understand the typical workflow of WellEdit
- Know how to start with WellEdit

Keywords

WellEdit, Process Manager, WellEdit Inspect Window, Presentation, Depth Track, Summary Track, Scale Change

WellEdit Position in GeoFrame

The following general GeoFrame workflow represents the WellEdit application position in the petrophysics and interpretation product chain of GeoFrame 4.
**WellEdit Typical Workflow**

The diagram below is a typical workflow for user to use WellEdit application.

![WellEdit Workflow Diagram](image)

**Start WellEdit Application**

You can start WellEdit Application from the GeoFrame Application Manager or from the GeoFrame Process Manager, the procedures to start WellEdit Application in detailed will be covered by the following Exercise (How to Start WellEdit Application)

Exercise 1.1: Start WellEdit Application

Note: Before you start to do any exercises on WellEdit, please make sure if all the data (Core data, Core Image and Log data) you wish to work with have been loaded into GeoFrame Database, if not, use Data Load and ASCII Load module to load the data first, your instructor will tell you where the training data are stored.

Load the data file welledit.gf66 (your instructor will tell you where it is) by using Data load module.

**Starting the WellEdit Module from the Application Manager**

1. From the GeoFrame Application Manager, click on the icon with Petrophysics to open the Petrophysics Catalog window
2. From the Petrophysics Catalog window, choose (highlight) WellEdit and click the OK button to run the application

Starting the WellEdit Module from the Process Manager

1. From the GeoFrame Application Manager, click on the icon with Process to open the Process Manager window

2. From the Process Manager window, click on the Product Catalog icon to open Product Catalog window

3. From the Product Catalog window, click on Petrophysics to open petrophysics product family

4. Under the petrophysics product family, select WellEdit and click on button OK to bring it into the Process Manager display area

5. In the Process Manager display area, highlight WellEdit icon and click on the WellEdit module with MB3, hold down MB3 and select Inspect to run WellEdit application

The Main Window Components of WellEdit

After you start WellEdit Application, the first WellEdit Inspect window shown as below will pop up, from this window you can select the Borehole(s) you wish to work with, and you can customize the Index type, Top and Bottom Depth, Presentation File template and Borehole display order. As for the detailed procedures to work with this window, please do the Exercise (How to Customize WellEdit Inspect Window).

Exercise 1.2: Customize WellEdit Inspect Window

1. After you start and run the WellEdit application from exercise1, the WellEdit Inspect window is displayed

2. From the WellEdit Inspect window, click on button Select Boreholes… to open the Select Borehole dialog box
3. From the Select Borehole dialog box, click on a borehole (WellEdit) to highlight it in the list, and then click the OK button to bring the selected borehole into WellEdit Inspect window.

4. Click on the Presentation File… button to open the Presentation File Selection dialog box.

5. From the Presentation File Selection dialog box, select the template file welledit_tmp.lgp from the GeoFrame system (you can use your own template file to define how to display borehole data in WellEdit) and click the OK button to close the Presentation File Selection dialog box.

6. Click the Run button to open the WellEdit Main window (the borehole data will be displayed in the WellEdit Main window as defined by the template file you selected).

7. There are a number of Menus, Tabs, Icons and Panels, from the WellEdit main window, you can customize the window display appearance before you do the actual data editing, please see Exercise (How to Customize WellEdit Main Window Appearance) on how to work with this window.

NOTE: If there is no curve display in the graphics, please add curve SP,GR,CALI in track1, add curve IDPH,IMPH and SFLU in track3, add curve NPHI, RHOB in track5 and add DT in track8.
Exercise 1.3: Customize WellEdit Main Window Appearance

1. From the WellEdit Main window, go to menu View > Depth Track to toggle ON or OFF display of the Depth Track (If your main display area is large and you must scroll it sideways to check the depth, toggle ON the depth track will make your life easier)

2. Click and drag the depth track sash right or left to adjust the width of the depth track panel

3. From the WellEdit Main window, go to menu View > Summary Track to toggle ON or OFF display of the Summary Track. The Summary Track is used to display the data being edited (original and edited version) and remains empty until data is selected and an edit mode is invoked.
4. From the **WellEdit Main** window, go to menu **View > Scale Change** to customize the vertical display scale.

5. Click on the **Insert area expansion** button and drag up or down to resize the area. From the Insert area, you can check the following information:
   - Identifies the trace in the track listed just beneath it.
   - Defines the units (ohms, inches, pounds) and the left and right scale values.
   - Shows the display name of the data item.
Chapter 2
WellEdit General Features

Learning Objectives
Upon completion of this course, you should be able to:

- Know the General features
- Know how to add more objects into main graphics for editing
- Know how to use Data Functioning
- Know how to use Statistics Tool

Keywords:
WellEdit window, General Tab, Object Selector, Track Selector, Zoom In, Zoom Out, Zone Zoom, Data Functioning, Statistics Tool, Save Output

Exercise 2.1 Overview

In the main WellEdit window, there are four tabs: General, Edit, Depth Match and Splice. Once you select the General tab, you can access a number of icons to work with the graphics. The WellEdit window will look like this:
Select a Object to Edit

If you wish to start a Data Editor or you like to check and change the attributes for a graphical object or you want to delete an object, you need to use the Object Selector Icon to select a graphical object first.

Select a Track to Add a Object

If you like to add objects to a specific track (new generated curves by Data Functioning) or you want to change the attributes (width...) of the track or you wish to delete a track, you should use the Track Selector Icon to select a track first.
Customize the Window Appearance

You can zoom in/out and change the vertical scale of the active borehole from the icons: [zoom in], [zoom out] or [vertical scale] in this window.

Exercise 2.1: Customize the Window Appearance

Add the Core Porosity data (CPOR) into track 4

1. Click on the Track Selector icon [ ] and click in track 4 (the selected track is outlined in red on each side)
2. Go to menu Edit > Add Object to open the Add Object window
3. From the Add Object window, click the Petrophysics tab
4. Select Core Data Trace and click OK to close the Add Object window and open Core Data Selection window
5. From the Core Data Selection window, type in CPOR* in the text field next to Query By… and click the Return/Enter from keyboard, then select one of the data from the middle panel, click OK to close the Core Data Selection window and open window
6. From the window, you can customize the attributes (color, scale, etc.) of the core data that will be displayed, and then click OK to close the window. The core porosity data you select will be displayed in track 4.

Add the Core Image data into track 6

1. Click on the Track Selector icon [ ] and click in track 6
2. Go to menu Edit > Add Object to open the Add Object window
3. From the Add Object window, select the Petrophysics tab
4. Select Core Image and click OK to close the Add Object window and open Select Core Image Collection window
5. From the Select Core Image Collection window, select a core image collection and click OK to close the Select Core Image Collection window and open Core Image Attribute Editor window
6. From the Core Image Attribute Editor window, click the OK button to close it, and the core image will be displayed in track 6
Add the FMS image data into track 7

1. Click on the Track Selector icon \[\text{Track Selector}\] and click in track 7
2. Go to menu Edit > Add Object to open Add Object window
3. From the Add Object window, select Geology tab
4. Select Image > FMS 4 and click OK to close the Add Object window and open Select Image Collection window
5. From the Select Image Collection window, select one of the image collection and click on OK to close the Select Image Collection window and open FMS4 Image Attribute Editor window
6. From the FMS4 Image Attribute Editor window, click the OK button to close it, and the FMS image will be displayed in track 7

Change the colormap of FMS image

1. Click on the Object Selector icon \[\text{Object Selector}\] and then click on the FMS 4 image color bar from the Insert area of track 7 (there are red grips attached to the image)
2. Go to menu Edit > Attributes to open FMS 4 Image Attribute Editor window
3. From the FMS 4 Image Attribute Editor window, change the Colormap from Heated to Yellow and then click on OK to close it, the colormap of FMS image in track 7 will be changed.

Add Dip Tadpole in Track5

1. Click on the Track Selector icon \[\text{Track Selector}\] and click in track 5
2. Go to menu Edit > Add Object to open the Add Object window
3. From the Add Object window, select the Geology tab
4. Select Tadpole and click OK to close the Add Object window and open the Select Collection window
5. Select Dip results collection: Bordip DIP.MSD collection and click OK
Exercise 2.2 Overview

Data Functioning

From the WellEdit Data Functioning Feature, you can do some computation and interpretation based on your experience before you use the GeoFrame interpretation product.
**Exercise 2.2: Data Functioning**

**Compute porosity from RHOB**

1. Click on the Data Functioning icon to open WellEdit Data Functioning window

2. From the WellEdit Data Functioning window, click on File Open… to open Select a File window

3. From the Select a File window, in the Files panel, select *density_porosity.dfun* and click OK to chose it

4. From the WellEdit Data Functioning window, highlight the item *DPHI.LIM* and click Evaluate
5. You can scroll the scrollbar from left to right to check the output DPHI.LIM or click the List button to check the DPHI.LIM

6. From the WellEdit main window, click on the Track Selector icon and select track 4

7. From the WellEdit Data Functioning window, click the Display button to open the Curve Attribute Editor window

8. From the Curve Attribute Editor window, customize the color to Blue and Line Style to thicker, click on OK to close it

9. From the WellEdit Data Functioning window, highlight number 2.71 and click Adjust… to open the Adjust Constant window

10. From the Adjust Constant window, move the scrollbar left and right to adjust the parameter, and check how the displayed DPHI.LIM curve changes with the new parameters.

11. Click on OK to close the Adjust Constant window

12. From the WellEdit Data Functioning window, click on Save Data… to open the Save Output window

13. From the Save Output window, toggle on DPHI.LIM. You have the options for saving the data as either implicitly or explicitly indexed. If implicit, you need to set the output sampling rate and interpolation method

14. Click on OK from the Save Output window to save the data into the GeoFrame Database and close the window.

15. From the WellEdit Data Functioning window, click Cancel to close this window.
Exercise 2.3 Overview

Statistics Tool

You can use the Log Curve Statistics Tool in WellEdit to report statistics on one or more selected curves.

Statistics Tool can be started by clicking on the Statistics icon in the General icon tab or from the Tools menu, in either case the following dialog box opens.

Exercise 2.3: Statistics Tool

How to use Log Curve Statistics Tool to get RHOB, NPHI, DT and GR statistics information

1. From the WellEdit main window, click on Log Curve Statistics Tool icon to open the Statistics Tool dialog box, then click on tab Setup and tab Curves

2. Click on the Curve Selection icon in the Statistics Tool dialog box, if necessary (It should be selected by default when the Curves tab is visible.)
3. Select RHOB, NPHI, DT, and GR one by one from the graphics presentation window. (Clicking the curve in the Insert Area will be much easier than selecting from the displayed curve), if the curve you wish to select is not displayed, you can click the Add Curves button and use the data item selector to select one or more curves – the selected curves will come into the list.

4. If you make mistakes, select one or more curves from the list, then click the Remove button to remove a curve from the list or clear the list.

5. Click the Interval tab from the Statistics Tool dialog box

6. Select Use Curve Extent from the Source of Interval option menu (if you like to check the curve’s statistics data for specific zone or between specific markers or user-defined depth interval, you change the option to Select by Zone or Select by Markers or User-defined Interval from the Source of Interval option menu).

7. Click on the tab Cutoff from the Statistics Tool dialog box, the dialog box will look like this:

8. Click Select Cutoff Curve#1… and select RHOB using the data item selector.

9. Turn ON the toggle next to the Greater Than field and enter 2.2.

10. Click Select Cutoff Curve#2… and select NPHI using the data item selector.
11. Turn **ON** the toggle next to the **Less Than** field and enter **0.25**

12. You can select 'And' option, or 'OR' option, to indicate whether to use either or both clauses in determining what values will be ignored

13. From the **Statistics Tool** dialog box, click on tab **Results** to perform the statistics computation and view the results

14. Click **Close** to close the **Statistics Tool** dialog box
Chapter 3

WellEdit Editing Features

Learning Objectives

Upon completion of this course, you should be able to:
- Know how to edit Core Data
- Know how to edit Core Image Data
- Know how to edit Log Data: Shifting, Patching, De-spiking, Filtering, Baseline Shifting, Resampling

Keywords

Core Data, Core Image, Log Curve, Draw/Erase Edit Mode, Constant Value Edit Mode, Spread sheet Edit Mode, Filter Edit Mode, Resample Mode, Baseline Shift Edit Mode, Shift Edit Mode, Replace/Insert Edit Mode, Lateral Average Edit Mode

Exercise 3.1 Overview

From the WellEdit main window, if you click on tab Edit, you can access a number of icons to edit core data, core image data, and log curve data, the window appearance should be like this.
Core Data Editing

You can start the Core Editor to edit the selected core measurement data, cores and missing intervals, or to create cores and missing intervals from scratch. Below is the sub window of Core Edit Mode:

Exercise 3.1 Core Data Editing

How to create cores and missing intervals from scratch

1. From the WellEdit main window, select tab General and click on the Track Selector icon.

2. From the WellEdit main window, click in a track (track4) you wish to display the created cores and missing intervals.

3. From the WellEdit main window, select tab Edit.

4. Click on the Core Edit Mode icon to open the Core Edit Mode dialog box.

5. From the Core Edit Mode dialog box, click on Create a new core icon, name it core1.

6. Either in the main display or in the summary track, click, and drag over an interval, name it core1 from the New Core dialog box and click OK to close it. You can go...
back to **Core Edit Mode** dialog box, type exact values for the **Top Depth** and the **Bottom Depth** (7000-7010 ft.)

7. Specify the **Core Color** (Yellow), **Recovery** (100), **Show Type** (Gas) and **Show Description** attributes

8. Click the **Update** button

9. Repeat step 5 to 8 to create three more cores (**core2**, **core3**, **core4**, **core5**) with **Colors** (red, blue, green, pink) and **Recovery** (100, 80, 50, 30) and **Show type** (Oil, Condense, Gas, Other)

10. Click **Create a Missing Interval** icon and name it as **core_missing**

11. Either in the main display, or in the summary track, click **MB1** and drag over an interval inside **core5**. You can go back to **Core Edit Mode** dialog box, type exact values for the **Top Depth** and the **Bottom Depth** (7300–7302 ft), the **Recovery** for **core5** will be recomputed

12. Click the **Update** button

13. Select **Delete a Core** icon, either in the main display or in the summary track, click to select a core (**core4**) or in the **Core Edit Mode** dialog box, click on the **Core** button, select a core from the list and click on **OK** button to close the **Select** window

14. Click **OK** to confirm the deleting, and close the **Confirmation** dialog box

15. Select **Delete a Missing Interval** icon, either in the main display or in the summary track, click to select a missing interval (**core_missing**) 

16. Click **OK** to confirm the deleting and close the **Confirmation** dialog box, the **Recovery** for **core5** will be recomputed

17. Click on **Output** icon and save the created cores
How to edit existing cores and missing intervals

1. From the WellEdit main window, select tab General and click on the Object Selector icon.

2. From the main display, click on a displayed core (core1).

3. From the WellEdit main window, select tab Edit.

4. Click the Core Edit Mode icon to open the Core Edit Mode dialog box.

5. From the Core Edit Mode dialog box, click on Edit a Core icon.

6. Either in the main display or in the summary track, click to select a core (core1), or in the Core Edit Mode dialog box: click on the Core button, select a core (core1) from the list and click on the OK button to close the sub-window. The selected core (core1) is marked with three red grips: one on the top of the core, one on the bottom of the core and one in the middle.

7. Click on the top grip and drag up to extend the top depth of the core (core1), or in the Core Edit Mode dialog box: Type a new value for Top Depth and click on the Update button.

8. Click on the bottom grip and drag down to extend the bottom depth of the core (core1), or in the Core Edit Mode dialog box: Type a new value for Bottom Depth and click on the Update button.
9. Click on the middle of the core and drag up or down to reposition the entire core up or down

10. If there is a existing Missing Interval you wish to edit, you can click on Edit a Missing Interval icon and do the same action as step 6 to 9 to edit it

How to edit an existing Core Data (CPOR)

You can depth shift a group of core measurement points, but you cannot shift beyond the core boundaries or adjacent core points, whichever are closer.

1. From the WellEdit main window, click on tab General and select the Object Selector icon

2. From the WellEdit main window Insert Area, select the core data (CPOR)

3. From the WellEdit main window, click on tab Edit and select the Core Edit Mode icon to open the Core Edit Mode dialog box

4. Refer to the exercise “How to create cores and missing intervals from scratch” to create four cores (core6, core7, core8 and core9), you customize the cores attributes by yourself.

5. Click on Shift a core up or down icon
6. Either in the main display or in the summary track; Click on a core (core6) to select it or in the Core Edit Mode dialog box: Click on the Core button and select a core (core6) from the list, click the OK button to select it. The entire core (core6) and the data points (CPOR) it contains are highlighted.

7. Click and drag to move the entire core (core6) up or down, OR type a new value for Shift Amount. A positive number moves the core down and a negative number moves it up. When you click on the Update button, the core is repositioned.

8. Click the Shift core measurement points up or down within the core icon.

9. In the main display or in the summary track, within core 7, click and drag to select a group of core measurement points. The core measurement points are highlighted.

10. Click and drag to move the group of core measurement points up or down. The core measurement points are moved, the original data is displayed in black, and edited data is in red. If you try to move core measurement points beyond the containing core boundaries or beyond adjacent core points, an error message displays.

11. Click the Flip a group of core measurement points icon.

12. Either in the main display or in the summary track, click and drag to select the group of core measurement points (core8) you want to flip, then release the mouse button. The core measurement points are flipped.

13. Click the Set core measurement points to absent value icon.

14. Either in the main display or in the summary track, click and drag to select a group of core measurement points (core9), then release the mouse button, the absent points in the core data trace will be displayed as tick marks at the edges of the track.

15. Click the Delete core measurement points icon.

16. Either in the main display or in the summary track, click and drag to select a group of core measurement points (core9) you want to delete, then release the mouse button, a confirmation dialog box is displayed before the core measurement points are deleted.

17. If you are happy with the edited core data, just click the Output icon to save the edited core data into database, if you are not happy with your editing, click Undo Last Edit Action icon, or Revert to Original Data icon, to cancel your previous editing and start a new editing session.
Exercise 3.2 Overview

Core Image Editing

From the Core Image Edit icon, you can edit the core image, below is the sub-window of Core Image Edit Mode.

Exercise 3.2: Core Image Editing

How to select core images and shift/resize the selected core image

1. From the WellEdit main window, click on tab General and select Object Selector icon.

2. Click on the core image in track 5 and then click on the Core Image Edit Mode icon.

3. From the Core Image Edit Mode dialog box, click on the Select core images icon and click on the image in track 5, the selected core image is outlined in red and highlighted in the core image list (you can use <Ctrl> + MB1 click to make multiple core image selection).
4. Click the **Shift or Resize Core Images** icon and select the core image in track 5, the selected core image is marked with three grips: one on the top of the core image, one on the bottom of the core image, and one in the middle.

5. Drag the middle grip of the image up or down to shift the core image.

6. Drag the top grip up to extend the top depth of the core image.

7. Drag the bottom grip down to extend the bottom of the image.

8. If you take a multiple core image selection, just drag one of the core images up or down, all the image will be shifted together.

9. Select one or more core images.

10. Click the **Hide Core Images** icon: The image are hidden and the image list is updated.

11. Select one or more hidden core images from the image list.

12. Click on **Redisplay Core Images** icon: The images are redisplayed and the image list is updated.

13. Select one or more core images.

14. Click on **Flip Core Images** icon: The selected images are flipped and redisplayed.

15. Select one or more images.

16. Click on **Mirror Core Image** icon: The selected images are mirrored (flipped left-right) and redisplayed.

**How to adjust azimuth orientation of core images**

1. Click on the **Select Core Images** icon to select a core image (should be unrolled type image).

2. Click on Adjust azimuth orientation of core images icon.

3. Drag the middle of the core image left or right to adjust the Azimuth of the core image.

4. If you take a multiple core image selection, just drag one of the core images left or right, all the image's Azimuth will be adjusted together.
How to split and un-split a core image

1. Click on Split a Core Image icon.
2. Move the mouse cursor to a proper depth on a core image and click on MB1, the core image is split into two core images and the image list is updated.
3. Select one core image and then click on Select Above icon: All images above this core image are selected.
4. Select one core image and then click on Select Below icon: All images below this core image are selected.
5. Select multiple core images (<Ctrl> + MB1 click).
6. Click on Link Core Image icon: All images are linked by a green link symbol.
7. Select a core image with link symbol

8. Click on Unlink Core Images icon: All links of this image disappear

9. Select two core images previously split (multiple selection: <Ctrl> + MB1 click)

10. Click on Un-split Core Images icon: The two images join together to become one image

How to match the image with a dip sinusoid (only for unrolled type core image)

1. Click on Match with a Dip Sinusoid icon

2. Click to make sure both depth and azimuth toggles are ON: Reposition a core image and match with a dip sinusoid for both depth and azimuth

3. Click on a sinusoid wave or a dip tadpole: A sine wave will be shown on the core image track

4. Use MB1 to drag the sine wave to the position on a core image

5. Click MB3: The core image moves to the sine wave position and the azimuth is matching with the sine wave on the sinusoid track

6. Click on Match with a Dip Sinusoid icon

7. Click to make sure only the depth toggle is ON: Reposition a core image and match with a dip sinusoid for only depth position

8. Click on a sinusoid wave or a dip tadpole: A sine wave will be shown on the core image track

9. Use MB1 to drag the sine wave to the position on a core image

10. Click MB3: The core image moves to the sine wave position

11. Click on Match with a Dip Sinusoid icon

12. Click to make sure only the azimuth toggle is ON: Reposition a core image and match with a dip sinusoid for only azimuth position

13. Click on a sinusoid wave or a dip tadpole: A sine wave will be shown on the core image track

14. Use MB1 to drag the sine wave to the position on a core image
15. Click **MB3**: The core image’s azimuth is matching with the sine wave on the sinusoid track

---

**How to Match with an Electrical Image (only for unrolled type core image)**

1. Click on **Match with a Electrical Image** icon

2. Click to make sure both depth and azimuth toggles are ON: Reposition a core image and match with a electrical image for both depth and azimuth

3. Either:
   - Click on the FMS image: A default sine wave is shown on the FMS image track
   - Click on **MB2** and drag the amplitude of the sine wave to match the sine wave on the FMS image
   - Click on **MB3** to finish sine wave position on the FMS image track
   - Click on **MB1** to drag the sine wave to the position on a core image
   - Click on **MB3** to finish matching
Or:

- Click on the core image: A default sine wave is shown on the FMS image track
- Click on MB2 and drag the amplitude of the sine wave to match the sine wave on the core image
- Click on MB3 to finish sine wave position on the core image track
- Click on MB1 to drag the sine wave to the position on a FMS image
- Click on MB3 to finish matching

4. Click on Match with a Electrical Image icon.

5. Click to make sure only depth toggle is ON: Reposition a core image and match with a electrical image for only depth position

6. Either:

   - Click on the FMS image: A default sine wave is shown on the FMS image track
   - Click on MB2 and drag the amplitude of the sine wave to match the sine wave on the FMS image
   - Click on MB3 to finish sine wave position on the FMS image track
   - Click on MB1 to drag the sine wave to the position on a core image
   - Click on MB3 to finish matching

Or:

- Click on the core image: A default sine wave is shown on the FMS image track
- Click on MB2 and drag the amplitude of the sine wave to match the sine wave on the core image
- Click on MB3 to finish sine wave position on the core image track
- Click on MB1 to drag the sine wave to the position on a FMS image
- Click on MB3 to finish matching

7. Click on Match with a Electrical Image icon.

8. Click to make sure only azimuth toggle is ON: Reposition a core image and match with a electrical image for only azimuth position

9. Either:
- Click on the FMS image: A default sine wave is shown on the FMS image track
- Click on MB2 and drag the amplitude of the sine wave to match the sine wave on the FMS image
- Click on MB3 to finish sine wave position on the FMS image track
- Click on MB1 to drag the sine wave to the position on a core image
- Click on MB3 to finish matching

Or:

- Click on the core image: A default sine wave is shown on the FMS image track
- Click on MB2 and drag the amplitude of the sine wave to match the sine wave on the core image
- Click on MB3 to finish sine wave position on the core image track
- Click on MB1 to drag the sine wave to the position on a FMS image
- Click on MB3 to finish matching
10. If you are happy with the editing, just click on Output icon and select OK to save the edited core image into database.
Exercise 3.3 Overview

Log Curve Editing

From WellEdit module, you have a number of options to edit log curves data, such as Draw/Erase, shift, constant value, baseline shift, filter, resample, etc., here there are some hints for log curve data editing:

- Before you start to edit one specific curve, please select it first
- You can perform editions from multiple edit modes on the same log curve before saving the data to the database, you don’t need to re-select the same curve
- If you want to select a different log curve for editing, you must either save the edited data or use the Revert to Original Data button to clear the edit history before you can edit the new log curve

- Draw/Erase Edit Mode
- Constant Value Edit Mode
- Filter Edit Mode
- Spreadsheet Edit Mode
- Resample Mode

Exercise 3.3: Log Curve Editing

This exercise shows you how to do basic log curve data (DT) editing (de-spiking, resampling, squaring etc…)

1. From WellEdit main window, select tab General and click on Object Selector icon

2. Click on curve DT from track 8

3. From WellEdit main window, select tab Edit and click on Draw/Erase Edit Mode to open the Draw/Erase Mode dialog box: At same time, in the main display, a copy of the trace data is drawn in red to represent the edited data (if the original curve is red, the edited curve will be blue)
4. Click on the **Click Points** icon, then click with MB1 one or more new points over interval (7200-7205 ft).

5. Click with MB3 to finish the interaction: A short description of the edit action is shown in the **Edit History** box below the main display.

6. Click on the **Drag Point** icon.

7. Click on and hold MB1 with a point of the log curve being edited and drag left or right (around depth 7300 ft) to introduce a number of spikes.

8. Go to the **WellEdit** main window, click on **Constant Value Edit Mode** icon to open the **Constant Value Mode** dialog box.

9. From the **Constant Value Mode** dialog box, click on Select an Interval icon.

10. Click and drag over **7400-7410 ft** to define an interval of the curve being edited.

11. Release the mouse button when you are satisfied with the interval.

12. Click on the **Pick Value** icon.

13. Click on and pick a value for the edited curve (DT).
14. When the interval and constant value are set as desired, click on the **Apply** button to change the edited curve: A short description is shown in the **Edit History** box below the main display.

15. From the **WellEdit** main window, click on the **Spreadsheet Edit Mode** icon to open the **Spreadsheet Mode** dialog box.

![Spreadsheet Mode dialog box](image)

16. From the **Spreadsheet Mode** dialog box, change a number of depth log curve (DT) value around 7300 ft and 7310 ft (introduce some spikes which will be repaired by the following exercise).

17. Click **Apply** button to perform the editing.

18. From the **WellEdit** main window, click on **Filter Edit Mode** icon to open the **Filter Mode** dialog box, the options for the filter type are:

Moving Average-Uniform (the default)

Moving Average-Weighted
Moving Average-Hodges-Lehmann

De-spike-Absolute

De-spike-Normalized Ratio

Squaring

19. Click on the Interval icon

20. Click and drag around 7300 ft to define an interval of the curve (DT) to be filtered

21. Release the mouse button when you are satisfied with the interval

22. Set the Type of Filtering as Moving Average-Uniform

23. Specify the Computation Options to As Is (you have Logarithm or Reciprocal options)

24. Set Number of Samples to 5 and Index Reference as 3

25. Click Apply button to perform the filter operation on the log curve (DT) being edited

26. Click the Interval icon

27. Click and drag around 7100 ft to define an interval of the curve (DT) to be de-spiked

28. Release the mouse button when you are satisfied with the interval

29. Set the Type of Filtering as De-spike and algorithm as Absolute Threshold (the minimum difference between two consecutive values which define a spike)
30. Specify the Window to 2 ft (vertical distance between two samples which constitute a spike)

31. Set the Threshold to 10

32. Click on Apply to perform the de-spike operation on the log curve (DT)

33. From the WellEdit main window, click on Resample Edit Mode icon to open the Resample Mode dialog box
34. From the **Resample Mode** dialog box, set the **Top Depth** and **Bottom Depth** interval.

35. Set the Resampled Index to Regular.

36. Set the **Resampling Method** to *Interpolation* and **Interpolation Method** to *Linear*.

37. Set the **Sampling Rate** to 12.

38. Click on **Apply** button to perform the editing operation on log curve (DT).

39. From the **WellEdit** main window, click on the **Output** icon to open the **Output** dialog box.
40. From the Output dialog box, specify the Output Curve Set to your UNIX login name, set the Modifiers as your initial.

41. Set the Sampling Type as Implicit and click on OK button to save the data after with all of the above editing and close the Output dialog box.

Exercise 3.4 Overview

Baseline Shift Edit Mode

The Baseline Shift mode allows you to interactively redefine the baseline for a segment of a log curve or for an entire log curve by selecting a baseline value to which the selected points will be shifted. Selected points on the trace are shifted to precisely the indicated baseline and the points between selected points (within the interval top and base) are extrapolated. The common use for the Baseline Shift mode is to normalize wandering SP curves.
Exercise 3.4: Baseline Shift Editing

1. From the WellEdit main window, select tab General and click on Object Selector icon.

2. Click on the log curve (SP) from the track 1.

3. From the WellEdit main window, select tab Edit and click on the Baseline shift Edit Mode icon to open the Baseline Shift Mode dialog box.

4. Make sure if the Top Depth and Bottom Depth have been set.

5. Click on the Pick Value icon and click on a value for the baseline (or you type in a Baseline Value into the dialog box).

6. Click on the Pick Index icon and click on an index position where the curve value should be set to the baseline value (at least 2 index points should be picked for baseline shift editing).

7. Click on Apply button to perform the editing.
8. If you are happy with the results, just click on **Output** icon to save the results into database or click on **Revert to Original Data** icon to cancel all the editing action.
Exercise 3.5 Overview

**Shift Edit Mode**

The Shift Edit mode has six icons that allow:

- Shifting a log curve vertically
- Shifting an interval of a log curve vertically
- Shifting multiple intervals of a log curve vertically
- Stretching/Squeezing an interval of a log curve
- Shifting a log curve horizontally
- Shifting an interval of a log curve horizontally

**Exercise 3.5: Log Curve Shift Editing**

1. From the WellEdit main window, select tab General and click on Object Selector icon
2. Click on the log curve (RHOB) from the track 4
3. From the WellEdit main window, select tab Edit and click on Shift Edit Mode icon to open the **Shift Mode** dialog box

![Shift Mode dialog box](image)
4. From the **Shift Mode** dialog box, click on the **Vertical Shift** icon (a ghost curve is shown that tracks the cursor motion)

5. Click on the curve being edited (RHOB) and drag it up or down (or type in a shift value and click on the **Update** button)

6. Release the mouse button to apply the shift to the edited log curve

7. Click on the icon

8. Specify the interval by dragging from the top depth and bottom depth (**7300-7350 ft**)

9. Click on the curve (RHOB) in the interval and drag it up or down

10. Click on the **Stretching/Squeezing** icon

11. Click on the curve (RHOB) being edited to define a **Anchor Point** (the end of the interval to be stretched or squeezed that will remain fixed)

12. Click at the **Shift Point** (the end of the interval which you will shift, the interval in between the Anchor Point and the Shift Point will be stretched or squeezed) and drag to define the Shift Amount

13. Click on the **Horizontal Shift** icon

14. Click on the curve (RHOB) being edited and drag it left or right

15. Release the mouse button to apply the shift to the edited log curve

16. Click on the Horizontal Interval Shift icon

17. Specify the interval by dragging from the top depth to the bottom depth

18. Click on the curve in the interval and drag it left or right

19. Release the mouse button to apply the shift to the curve in the interval

20. Click on the **Revert to the Original Data** icon to cancel all of the editing action
Replace/Insert Edit Mode

Clicking the Replace/Insert Edit Mode icon displays the Replace/Insert Mode dialog box; this dialog box gives you a number of options for putting values from another log curve (the source log curve) into the log curve being edited (the target log curve):

- **Replace-Same Interval** replaces an interval in the log curve being edited (the target log curve) with the same interval from another log curve (the source log curve).

- **Replace-Stretch/Squeeze to Fit** replaces an interval in the log curve being edited (the target log curve) with an interval from another log curve (the source log curve). If the source and target intervals are not the same size, the values from the source log curve will be stretched or squeezed to force it to fit.

- **Replace-Shift Above to Fit** replaces an interval in the target log curve with an interval from the source log curve. If the intervals are not the same size, the target log curve values above the target interval are shifted up or down to make or take up the extra room.

- **Replace-Shift Below to Fit** replaces an interval in the target log curve with an interval from the source log curve. If the intervals are not the same size, the target log curve values below the target interval are shifted up or down to make or take up the extra room.

- **Insert-Shift Above to Fit** inserts an interval of values from the source log curve at an index position in the target log curve and the target log curve values above that position are shifted up or to make space.
Insert-Shift Below to Fit inserts an interval of values from the source log curve at an index position in the target log curve and the target log curve values below that position are shifted down or to make space.

**Lateral Average Edit Mode**

You can select a number of curves with the same measurement and make a lateral average computation; this mode can be used to edit the RST or TDT data with several runs in the same depth interval.
Chapter 4

WellEdit Splicing Features

Learning Objectives

- Know how to do log curve splicing
- Know how to quality control the splicing point selection

Keywords

Log Curve Splicing, Splice Point, Splice Interval, Activity

Exercise 4.1 Overview

Splice Mode is independent of other edit modes. Unlike the other edit modes; it is not necessary to select a log curve to edit before entering the mode. The Splice mode doesn’t edit a single log curve, but instead allows you to select a number of log curves from two or more activities that should all be spliced together in one operation, a special graphical display (shown below) is available to aid you in selecting intervals and provide visual feedback on what the resulting log curve looks like.

- Data Selection for Splicing
- Select Splicing Point
- Select Splicing Interval

Exercise 4.1: Log Curve Splicing

1. From the WellEdit main window, select tab **Splice**

2. Click on **Splice Mode** icon to open the **Splice Mode** dialog box
3. From the Splice Mode dialog box, click on Select Activities... button to open the Select Activity dialog box
4. From the Select Activity dialog box, select TOH.006 and TOH.008 from the Activity Entity panel and click OK to close the Select Activity dialog box.

5. Click on the button Use Common Codes to bring all the common codes of this two Service runs into the middle panel of Splice Mode dialog box.

6. From the common code list panel, highlight CALI, GR, LLD, LLS and MSFL (deselect all other curves)

7. Change CALI to GR in the Display Log Curve text field.

8. Click on button Splice Display button to refresh the WellEdit main graphics window.
9. Click on the **Pick Index** icon

10. Click on an index (2300 m) in the main or summary region of the display to create a splice marker

11. Click on the **Select Interval** icon

12. Click in the track 1 above the splice marker and click in the track 2 below the splice marker
13. You can click on the Pick Index icon to edit an interval boundary (drag it up or down)

14. If you are happy with the splice curve result, from the Splice Mode dialog box, click on Output icon to open the Splice Output dialog box
15. From the Splice Output dialog box, you have options to customize the output curve data’s attributes and sampling rate

16. Click OK to close Splice Output window

17. Click OK to close Splice Mode window

There is a very important feature of Splice Mode that allows you to specify different splice points for the different curves being spliced, you can access this feature by clicking on the button Customize Splice Offsets. For example, suppose you choose two splice groups; specified two splice intervals: Group 1 from 1000 to 1500 ft. and Group 2 from 1500 to 2000 ft.; and chosen RHOB, NPHI, and GR channels from each group. If you do not go into Customize Splice Offsets, the three log curves will be spliced at 1500 ft. If, however, you specify offsets of 32,49,and 86 ft. for the three log curves in Group 1 (respectively), then the RHOB log curve will be spliced at 1468 ft., the NPHI at 1415 ft., and the GR at 1414 ft.
Chapter 5
WellEdit Log Depth Matching Features

Learning Objectives

Upon course completion you should be able to:

- Know how to do automatic log depth matching
- Know how to do interactive log depth matching
- Know how to quality control for log depth matching

Keywords

Log depth match, Automatic depth matching, Interactive depth matching, Base curve, Match curve, Equate curve, and Correlation line

Exercise 5.1 Overview

**WellEdit Depth Match Mode** is independent of the other edit modes. Unlike the other edit modes; it is not necessary to select a log curve to edit before entering the mode. The Depth Match Mode lets you depth shift one or more curves relative to a base curve (known to be on depth) by defining correlation lines between the base curve and the match curve (a representative of the curves to be shifted).

An automatic algorithm may be used to compute the correlation lines. A special graphical display is available to review and modify the correlations computed automatically, or to pick new correlations.

- Data Selection for Depth Matching
- Automatic Depth Matching
- Interactive Depth Matching

Exercise 5.1: Log Depth Matching

1. From **WellEdit** main window, click on tab **Depth Match** and select the **Depth Match** icon. Select the **SFE4** borehole if not already selected.
Select the Base and Match Curves

2. Select Base Curve. The Base Channel Selector window opens.

3. Enter GR in the Array Code box and hit Return.

4. Select the GR channel from the Induction service run (GR.Calibrated.TOH.014) and click OK. The GR channel in the TOH.014 service run displays in the Base Channel window.

5. Select Match Channel.

6. Enter GR in the Array Code box and hit Return.

7. Select the GR channel from the LDT-CNT service run (GR.Calibrated.TOH.035) and click OK. The selected GR channel displays in the Match Channel window.

8. Select Equate Curves. This opens the Equate Channels Selection window.

9. Activate the “Curves in Same Service Run” radio button and click “Query and Add”

10. Click OK. This enters all curves logged in the LDT-CNT service runs as equate curves.

11. Check the Match parameters. The default values are okay for this exercise. You can set Correlation Type to Correlate when the base curve and match curve both are GRs.
Run Automatic Depth Match (ADM)

1. Click on button Automatic Matching.

2. You can now enter a group name – “CNLtoDIT,” for example.

Run Interactive Depth Match (IDM)

Select Depth Match Display.

The Interactive Depth Match display replaces the previous WellEdit Display. The Left GR track contains the Base curve; the next (to the right) contains the Match curve. Correlation lines between these tracks are from the Automatic Matching. After the depth track, to the right, is the overlay track, which shows both the base and match curve in the same track.

Add a new correlation line as follows:

1. Select the Create Correlation Line icon from the Depth Matching window to add correlation lines.

2. Scroll to around 7800 feet and select a point on the Base curve for a correlation line. Select the point by clicking and releasing the left mouse button (MB1). As you move the cursor to the right (towards the match curve) you will see the correlation line and a ghost curve to help you select the correlation point on the match curve.

3. Line up the ghost curve on top of the match curve so that it overlays, then click and release MB1 to finalize the correlation.

4. Add other correlation lines as desired.
5. Review the results in the overlaid Base/Match curve track.

6. Delete several correlation lines by selecting the **Delete Correlation Lines** icon. Use MB1 on the correlation lines to select for deletion. You can select one line by clicking and releasing or several lines by clicking and dragging a box.

7. You can also use the **Edit Correlation Lines** icon to edit the existing correlation lines, **Shift Correlation Lines** icon to move an existing correlation line to a new depth position, **Clone Correlation Lines** icon to copy an existing correlation lines in another depth position.

8. Click the **Save** icon on the **Depth Matching** window to start **Depth Match Output**.
9. Click **OK** to save the edited curves and correlations. You can assign a meaningful name to the output group.

*Notes:* You can select core data trace a match curve to LDM (Stretch and Squeeze) core data and save it back to database as core data.
Chapter 6
WellCompositePlus

Learning Objectives

Upon completion of the course, you should be able to:

- Know how to use WellCompositePlus basic features to build log graphic presentation
- Know how to use WellCompositePlus advanced features to customize the log graphic presentation
- Know how to save the template file
- Know how to use UtilityPlots to generate crossplots.
- Know how to use the Interaction feature to investigate log data and lithology

WellCompositePlus is the primary utility for building log graphic presentations.

For more information on WellCompositePlus, please refer to the Online Help from GeoFrame Bookshelf.

Keywords

WellCompositePlus, Object Selector, Track Selector, General, Petrophysics, Geology, Add object, Annotation, CrossPlot, UtilityPlots, Interaction, Presentation Editor

Exercise 6.1 Overview

This exercise is designed to show you how to display borehole data using the WellCompositePlus basic functionalities, including how to add track, add object, edit attributes of track and object, make annotation (text, symbol) and how to build crossplots from WellCompositePlus (only touch the Menu of the main window)

Exercise 6.1: Basic Features

(If the data has been loaded into your GeoFrame database, please skip step 1 to 7)

1. From GeoFrame Application Manager, click the Data Management Catalog icon to open Data Management Catalog window.

2. From Data management Catalog window, select/highlight Data load module under Loaders and Unloader folder and click the OK button or APPLY to start Data Load main window.
3. Click the **Input File**… button in the **Data Load** main window to open the **Select the File(s) to Load** dialog window.

4. Type in the directory path *(your instructor will tell you what it is)* /*.dlis* inside the filter’s blank text field.

5. Click on button **Filter** to display files of the selected directory and select the file *wellcompositeplus.gf66* from the **Files** sub-window, and then click on button **OK**. Do not assign a Field, Well, Borehole, or Producer name to the project.

6. Click the **Run** button from the **Data load main window** to start loading data.

7. After data loading is finished, click the **Exit** button to close the **Data load window** (click **OK** for all pop-up message windows, after clicking on **Exit** button from **Data load main window**)

8. From **GeoFrame Application Manager**, click the **Process** icon to open **Process Manager main window**.

9. Start a new activity in the **Process Manager** by selecting pull down menu **File > New Activity**.

10. Click on the ![icon](image) icon on the left side of the **Process Manager main window** to open the **Product Catalog** window, and then click the **Petrophysics** folder to select **WellCompositePlus** and **Utility Plots** module (to form a processing chains) and click the **OK** button.

11. Click the **Activity** button to open a sub-window and name your activity as what you wish to call it.

12. Click on the first icon ![icon](image) from top on the left side of the **Process Manager main window** to open the **Data Focus Selection** window, set the data focus on **Katy No.1** by doing the following from this sub-window:

   13. Highlight the project name using **MB1** (left mouse button) if it is not highlight.

   14. Change the **Show menu** to **Borehole**.

   15. Highlight (MB1) only the **rockclass** borehole under **rockclass** field and click the **OK** button.

   16. Select and double click (MB1) on **WellCompositePlus** module to open **WellCompositePlus parameter setting window**, set parameters as illustrated:
17. Check **Data Focus** to see if it is **rockclass**, otherwise set it correctly

18. Toggle on **Depth-Indexed Data**: Top (ft) = 7200 ft, Bottom (ft) = 8003 ft

19. Click the **Presentation File**... button, and select `blank.lgp` from the **Files** panel. Then click **OK** to close the **Presentation File** window

20. Click **Run** to open the **WellCompositePlus** main graphic display window
21. Select the Track Selector icon and then double-click inside the blank track to open Track Editor panel. Type in Shale in the Name text field, click OK to close this panel.

22. Go to menu Edit > Add Object… to open Add Object sub-window.

23. From Add Object sub-window, add the index (depth scale) line grid by
   - Select the General tab
   - Highlight Grid-Index and click on Apply (don't click on OK to close Add Object sub-window) to open Grid Editor panel
   - From Grid Editor panel, change the Line Increment, Line Style and Color attributes as what you like (keep default setting is fine for this exercise)
   - Click on OK to close the Grid Editor panel

24. From Add Object sub-window, add linear scale grid lines by
   - Select tab General
   - Highlight Grid-Linear and click on OK to open Grid Editor panel
• From Grid Editor panel, change the Line Increment to 0.25 under Line1 (the track width is 2.5 in, divide it into 10 small grids with thin line), change the Line Increment to 1.25 under Line2 (separate the track into 2 parts with thicker line)

• Click on the white button (with line) under Line2 to change the Line Thickness

• Click on OK to close the Line Style Selector Panel

• Click on OK to close the Grid Editor panel

25. Go to Edit > Add Track to open Track Editor, type in Depth in the Name text field, change the Track Width to 0.75 and click OK to close the Track Editor

26. Go to Edit > Add Object… to open the Add Object sub-window

27. From Add Object sub-window, add the index (depth) number by

• Select tab General

• Highlight Depth/Time Number and click on OK to open Depth/Time Number Editor panel

• From Depth/Time Number Editor panel, change the Depth Interval from 50 to 20 (you can change the other attributes if you like)

• Change Index to MD (measure depth)

• Click on OK to close the Depth/Time Number Editor panel

28. Go to Edit > Add Track to open Track Editor, type in Depth in the Name text field, change the Track Width to 0.75 and click OK to close the Track Editor
29. Go to Edit > Add Object… to open Add Object sub-window

30. From Add Object sub-window, add the index (depth) number by
   - Select the General tab
   - Highlight Depth/Time Number and click on OK to open the Depth/Time Number Editor panel
   - From Depth/Time Number Editor panel, change the Depth Interval from 50 to 20 (you can change the other attributes if you like)
   - Change Index to TVD (true vertical depth)
   - Click on OK to close the Depth/Time Number Editor panel

31. Go back to Edit > Add Track to open Track Editor, type in Resistivity in the Name text field and click on OK to close the Track Editor

32. Select Edit > Add Object to open the Add Object sub-window

33. Within the Add Object sub-window, add the index (depth scale) line grid (same as before)

34. Go back to the Add Object sub-window, add the logarithmic scale grid lines by:
   - Select tab General
   - Highlight Grid-Logarithmic and click on OK to open Grid Editor panel
   - From Grid Editor panel, change the Line Increment to 1 under Line1, change the Line Increment to 10 under Line2
   - Under Line1 and Line2, change start to 0.2 and stop to 2000
   - Click on the white button (with line) under Line2 to change the Line Thickness
   - Click OK to close the Line Style Selector Panel

35. Click OK to close the Grid Editor panel

36. Go to Edit > Add Track, and repeat Step 34 to add a track named Porosity

37. Repeat the steps to add a grid into the Porosity track

38. Go to Edit > Add Track, and repeat steps to add a track named CoreData

39. Repeat steps above to add a grid into the CoreData track

40. From WellCompositePlus main window, select the Track Selector icon first, and then click the inside track Shale (track1)
41. Go to menu Edit > Add Object to open Add Object sub-window

42. From Add Object sub-window, add GR curve into track Shale by:
   - Select tab General
   - Select Log Curve and click Apply to open Log Curve Selection panel. (don’t click OK to close the Add Object sub-window.)
   - From Log Curve Selection panel, type in GR* in the Curve Code text field
   - Hit <Return> on the keyboard
   - Select GR with Curve-Set PRE001 and Last Modifier CRC and click OK to close Log Curve Selection panel and open Curve Attribute Editor panel
   - From the Curve Attribute Editor panel, click Line Style… to change the Line Thickness and Texture
   - Click on Line Foreground… and change the Line Color to Red
   - Change Left Scale and Right Scale (keep default for this exercise)
   - Click on OK to close Curve Attribute Editor panel

43. Repeat step 32 to add SP curve (type in SP*) with Color Blue

44. Repeat step 32 to add CALI curve (type in CALI*) with Color Green

45. From Add Object sub-window, add constant Bit Size (BS) curve into track Shale by
   - Select the General tab
   - Select Log Curve-Constant and click Apply to open the Curve Attribute Editor panel (don’t click OK to close Add Object sub-window.)
   - From Curve Attribute Editor panel, type in BS in the Name text field
   - Click on Line Style… to change the Line Thickness and Texture
   - Click on Line Foreground… to change the Line Color to Hot Pink
   - Change Left Scale to 6
   - Change Right Scale to 16
   - Type in 8.5 in the Constant Value text field
   - Click on OK to close Curve Attribute Editor panel

46. From Add Object sub-window, add shading between BS and CALI to detect washout
47. Select the General tab

48. Select Area Shading and click OK to close the Add Object sub-window and open the Area Editor panel

49. From the Area Editor panel, click Fill Pattern… and select a pattern symbol you like, then close the pop-up window

50. Click on Fill Foreground… and select the foreground color you like, then close the pop-up window

51. Click on Fill Background… and select the background color you like, then close the pop-up window

52. Change the Filling Mode to Fill From/To

53. Click on Boundary1… and select BS, then close the pop-up window

54. Click on Boundary2… and select CALI, then close the pop-up window

55. Click OK to close the Area Editor

56. Increase the top inset area to see the curve names and scales displayed. Click and hold the small box at the bottom right of the insert area and drag cursor down to make the insert area larger.

57. Bring the GR curve to the front of area shading

58. Select the Graphics Object Selector and click the GR curve header from insert area to select GR curve (there are 3 red breaks in GR curve).

59. Go to Edit > Bring to Front

60. Repeat these steps to bring SP and CALI curve to the front of area shading

61. From WellCompositePlus main window, select the Track Selector icon first, and then click inside track Resistivity (track3)

62. Repeat these steps to add ILD, ILM and SFLU curve into Resistivity track.

63. Close the Add Object sub-window by clicking OK

64. From WellCompositePlus main window, select the Track Selector icon, and then click inside track Porosity (track4)

65. Repeat step 31 to 34 to add RHOB, NPHI and DT curve into Porosity track

66. Repeat steps to add area shading between RHOB and NPHI to detect gas in clean (non-shale) formation, the presentation looks like this:
67. From the **WellCompositePlus** main window, select the **Track Selector** icon first, and then click inside track **CoreData** (track 5)

68. Go back to menu **Edit > Add Object** to open **Add Object** sub-window

69. From the **Add Object** sub-window, add **GR** curve as 2D image by:

   - Click the **General** tab
   - Select **2D image** and click on **OK** to open the **Log Curve Selection** Panel
   - From **Log Curve Selection** panel, type in **GR** in the **Curve Code** text field
   - Hit <Return> on the keyboard
70. Select the Object Selector icon and click on GR from track Shale

71. Go back to menu Edit and hold down MB1 to select Copy

72. Select the Track Selector icon and click inside track CoreData

73. Click Edit > Paste

74. Click Edit > Add Object to open the Add Object sub-window

75. From the Add Object sub-window, add core data into track CoreData by:
   - Select the Petrophysics tab
   - Select Core Data Trace
   - Click on OK to open Core Data Selection panel
   - Type in CPOR* in the Array Code text field and hit <Return> on the keyboard
   - Click OK to open the CoreData Trace panel
   - Change Radius to 0.03
   - Change the Left Scale to 0.45 and Right Scale to –0.15
   - Click OK to close the CoreDataTrace panel

76. Click the Object Selector icon and double-click on GR from track CoreData’s insert area (header) to open Curve Attributes window (if no window pops-up, go back to menu Edit > Attributes to open it)

77. From the Curve Attributes window, change the color to Blue for GR curve

78. Click on Data Functioning icon to open Function Editor, write the following data function in the light blue text edit window to compute porosity from density log
   - RHOB.IN=RHOB
   - RHOMA_SAND=2.65
- RHO_FLUID = 1.0
- DPHI_SAND = (RHOMA_SAND - RHOB.IN) / (RHOMA_SAND - RHO_FLUID)
- DPHI.SAN = MIN (1, MAX (0, DPHI_SAND))

79. From the Function Editor window, highlight DPHI.SAN and click Evaluate, then move the scroll bar left and right to see the results of DPHI.SAN

80. Select the track CoreData (be certain the Track Selector is selected)

81. Click Display from the Function Editor window to open Curve Attribute Editor panel

82. From the Curve Attribute Editor panel, change the Line Foreground Color to Green and compare the DPHI porosity from density with Core porosity CPOR

83. From the Function Editor window, highlight the parameter 2.65 and click Adjust. Move the scroll bar left and right to see the display changing with different parameter in track CoreData

84. From the Function Editor window, you can change the RHOB binding from Database by:
   - Highlight RHOB first
   - Click on Change… to open a sub-window
   - From this sub-window, select which curve you wish to use
   - Click OK to close the sub-window
   - Click Cancel to close the Function Editor window

85. Go to View > Scale Change… to open the Scale Change panel, select 1/200 and click OK to close this panel

86. Select View > Summary to add the summary track

87. The summary track automatically displays the full curve range of the gamma ray curve.

88. Go back to WellCompositePlus main window and click the Annotation icon to open the Annotation Tools

89. From the Annotation Tools panel, click the icon with A (Attributes) to set Background Color to Red (moving Opacity from 0 to 1 before picking color)

90. From the main graphical display window, select a position where you wish to make an annotation, and then type in the words to annotate your presentation

91. Close the Annotation Tools panel by clicking Close
92. Select the Object Selector icon, click on NPHI from Porosity track or insert area first, then press <Ctrl> + MB1 to click on RHOB to make multicurve selection (there are 3 red breaks on both NPHI and RHOB).

93. Go to Tools > Utility Plots > CrossPlot and click CrossPlot.

94. Make sure the ITC door is open for both the WellCompositePlus and the CrossPlot windows.

95. Go to Tools > Interactions from WellCompositePlus window to open the Interactions panel.

96. From the Interactions panel, click the icon and draw a box in the graphical display window (3800-3900ft.) See what happened in CrossPlot window.

97. Close the Interactions panel.

98. Go to CrossPlot window and select Options > Interactions to open the Utility Plots Interactor Tools panel.

99. From the Utility Plots Interactor Tools panel, select the Pick Rectangle Zone, then click on Attributes to change the Fill Foreground color to Cyan.

100. Click OK to close the Polygon Editor.

101. Draw a box inside the CrossPlot window, check the interval highlighted in the WellCompositePlus display window.

102. Click Remove all from Utility Plots Interactor Tools panel to delete all the highlighted data and interval for both windows.

103. Click the Close button to close Utility Plots Interactor Tools panel.

104. From the CrossPlot window, select Options > Curve Fits to generate a linear regressive line (you can change the line attributes and other options from here).

105. Click OK to close the Curve Fits window and go to File > Close in the CrossPlot window to exit CrossPlot.

106. From the WellCompositePlus main window, go to File > Save Presentation As... to open Save Presentation As sub-window.
107. Keep all the options toggled on under Curves panel except Ignore Overrides, under Other data types panel, only leave Code option on, and enter a file name in the Selection text field with extension .lgp (lgp_templates/demo.lgp)

108. Click OK to close the Save Presentation As sub-window

109. Click the Print icon to activate the Print dialog. Header, Trailer, and Header Parameters can all be accessed from here. Custom headers with, or without, company logos can be made to order. Printers that are available on your local network are accessed with the Printer icon.

110. Select the File Only option by turning off the toggle button next to Printer. By creating a PDS file, you can use PDS Preview from the Application Manager Utility Catalog to see the output before printing it.
111. Go to File > Exit to close the WellCompositePlus window

Questions:

From this exercise, how do you change the graphical object's attributes?

From this exercise, how do you change the track width for multi-track?

From this exercise, how do you change the track order after you build the presentation?

Exercise 6.2 Overview

This exercise is designed to show you how to display borehole data and build template file using the WellCompositePlus advanced functionalities, including how to add track, add object, edit attributes of track and object, change the order of tracks through Presentation Editor. This exercise will also demonstrate how to build a CrossPlot from the Utility Plots module and do the interaction between WellCompositePlus and Utility Plots for picking parameters and qualitatively analyzing log data (Only touch the icon of the main window)

Exercise 6.2: Advanced Features

1. Continue with the previous exercise (WellCompositePlus Exercise 6.1)

2. Open the activity you named for WellCompositePlus Exercise 6.1 from Process Manager

3. Double-click on WellCompositePlus to open the WellCompositePlus parameter setting window

4. Check the Data Focus, Top & Bottom Depth and Presentation File setting. If it is wrong (different from previous exercise), you need to change the setting

5. Click Run to open the WellCompositePlus main graphical display window, it should display what you built from previous exercise

6. Click the Presentation Editor icon to open the Presentation Editor window
7. From the **Presentation Editor** window, click **Add Track**... to add a new track. Name it: **Lithofacies**

8. Repeat this step to add 3 more new tracks, name them: **PetroAnalysis**; **DipAnalysis**; and **ImageAnalysis**

9. Change the **Depth** track width from 0.75 to 0.5. Change all other track widths from 2.5 to 1.5

10. Click **Apply** from **Presentation Editor** window (don’t click on **OK**)

11. You can change the track’s order by select the specific track first, and then use the **UP** and **DOWN** arrow to move it up and down

12. Use MB1 to change Object Type from Track to Petrophysics > RockClass

13. Change Track from **All** to **Lithofacies**

14. Click **Add RockClass** to open **Select Lithofacies Collection** sub-window, click **OK** to close this sub-window

15. Use MB1 to change Object Type from Petrophysics > RockClass to Petrophysics > Elan Volume

16. Change Track from Lithofacies to PetroAnalysis

17. Click **Add Elan Volume** to open Volume/Fluid Collection sub-window
18. Highlight ELAN_PVP_OUTPUTS.COM1... collection from **Volume/Fluid Collection** sub-window

19. Click **OK** to close **Volume/Fluid Collection** sub-window

20. Use MB1 to change Object Type from Petrophysics > Elan Volume to Geology > Dip Graphical Objects > Tadpole

21. Change Track from PetroAnalysis to DipAnalysis

22. Click Add Tadpole to open Select Collection sub-window

23. Highlight the **dip analysis results** collection from **Select Collection** sub-window

24. Click **OK** to close the **Select Collection** sub-window

25. Use MB1 to change Object Type from Geology > Dip Graphical Objects > Tadpole to Geology > Image

26. Change Track from DipAnalysis to ImageAnalysis

27. Change Image Type from Azimuth Lateralog Tools to FMS4 Tool

28. Click Add Image to open Select Image Collection sub-window

29. Highlight one of the image collection from **Select Image Collection** sub-window

30. Click **OK** to close **Select Image Collection** sub-window

31. Use MB1 to change Object Type from Geology Image to General Log Curve

32. Change Track from **Image Analysis** to **Porosity**

33. Click the icon (far right) to change the curve’s attributes

34. By changing **Object Type** and **Track**, you can add and edit all of the object mentioned in previous exercise and their attributes, the final presentation looks like this:
35. Click OK to close the Presentation Editor window

36. Keep the WellCompositePlus window open and go to Process Manager to Inspect Utility Plots (Double click or MB3 > Inspect) to open the Utility Plot Parameter Editor window
37. From the Utility Plot Parameter Editor window, change Application Type from CrossPlot to Zplot

38. Change Top and Bottom depth from 3850 to 4300 ft

39. Click Presentation File… to open Presentation/Overlay File Selector

40. Select presentation_Rhob_vs_Nphi_fresh_cp_1e.gpd and click OK to close the Presentation/Overlay File Selector panel

41. Click Run to start Utility Plot

42. Open ITC door for both windows (WellCompositePlus and Utility Plots)

43. Go back to WellCompositePlus main window, and click on Interaction icon to open the Interactions panel

44. Select a interval from display (using MB1) between 3880 to 3900 ft, check the interactions in Utility Zplot window
45. Click Close to exit the Interactions panel

46. From the Utility Zplot window, select Options > Interactions to open Utility Plots Interactor Tools panel

47. Highlight the option Pick Rectangle Zone and draw a box in Zplot window (lower left) to select some data points, then check what happened with the WellCompositePlus display window
48. Click Close to exit the Utility Plots Interactor Tools panel

49. Go to File > Close in Zplot window to exit the Utility Plots

50. Go to WellCompositePlus main window and select menu File > Save Presentation As to save the template file

51. Select File > Exit to close the main WellCompositePlus display window if you wish

Notes:

After this exercise, all the questions of exercise 1 are answered

You can combine exercise 1 and exercise 2 to build very flexible template file to display all data related to a specific borehole

It is very useful by integrating **WellCompositePlus** and **Utility Plots** to do quick and qualitative log data analysis and pick interpretation parameters